articy:draft API: articy:draft API

for articy:draft 2 (v2.4)
 Nevigo Logo
articy:draft API

Overview

What is articy:draft API?

The articy:draft API allows an external application to connect to an articy:server, open a project and work with the elements of this project. It is very easy to write a program that searches certain articy:draft objects, lists or exports specific values or even write those values back into the articy:draft project. This API allows articy:draft to be integrated into a complex tool chain

The basic principle

Your program (from the articy:draft perspective this is the external program) basically invokes an GUI-less articy:draft and operates just like a regular user. This means, the your program needs to connect to an articy:server, login with an user account known to and licensed by the articy:server and opening a project that is allowed for the particular user account. Just like when using the articy:draft GUI, projects can be opened in normal or in exclusive mode with all possibilities and restrictions coming with those modes. Once the project has been opened successfully, objects can be searched using a simple search that resembles the search function of the articy:draft GUI. In addition to that, the internal query language allows formulating complex SQL-like queries. Queried objects and their respective properties can be listed, changed or exported using the same exporter functionality that the articy:draft GUI provides. Before objects can be changed, claiming their partition is a pre-requisite. Finally, opened projects can be saved, claimed partitions can be unclaimed/published and the project can be closed. Every API method provides detailed error codes for failed actions and a logger callback allows your program to receive all information, that is also available to the user when running articy:draft in GUI mode.

How to use articy:draft API?

Preparations

Language of your program

Write your application or service in any .NET language (e.g. C#, VB.NET, Delphi.NET, managed C++ (for a complete list please check http://en.wikipedia.org/wiki/List_of_CLI_languages)

.NET Framework

Your application needs to use .NET Framework 4.0 or higher. Be careful NOT to use the .NET Framework 4.0 client profile.

Main method

Your main method needs to be attributed with STAThread.

app.config

Since the components of articy:draft use a mix of .NET 2.0 and .NET 4.0 your program needs to apply an app.config containing:

1 <?xml version="1.0"?>
2 <configuration>
3 <startup useLegacyV2RuntimeActivationPolicy="true">
4 <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/>
5 </startup>
6 </configuration>

DLLs

Many DLLs and other files of articy:draft will be needed when running your own program. So you should set the output dir to the bin\x64 or bin\x86 folders of the API installer's installation directory. You may install the API files several time to different directories. The installer is more or less a simple automated copying. No registry keys are created.

References

When starting a new project you must add references to the following assemblies

  • PublicApiTypes
  • ArticyApi
  • QueryLayer
Copyright © 2014 ByteRockers' Games GmbH & Co. KG


articy:draft API: Namespace List

Namespace List
Here is a list of all documented namespaces with brief descriptions:
[detail level 123]
▼N Articy
N Api
▼N Export
N Office
▼N Models
N Scripting


articy:draft API: Package Articy

Namespaces
Package Articy

Namespaces

package | Api
package | Export
package | Models


articy:draft API: Package Articy.Api

  • Articy
  • Api
Classes | Enumerations | Functions
Package Articy.Api

Classes

class | ApiCollaborativeHelper
class | ApiConsts
static class that contains some constants and a error code helper method More...
class | ApiJourneyBuilder
class | ApiLocationTools
class | ApiSession
Once the session is created successfully, all further API calls are invoked on this session object. More...
class | ArticyApi
This static class the the bootstrapping singleton to startup and shutdown the articy:draft API More...
class | ArticyApiException
class | CloseProjectArgs
Argument class for ApiSession.CloseProject More...
class | ComplexApiCallArgs
base class for the argument objects used for API calls that have many parameters More...
class | ExportDataArgs
The abstract base class for all specialized export arguments More...
class | ExportDocumentToDocxArgs
The parameter args to be used for exporting a document object to Word More...
class | ExportObjectSelectionDataArgs
Abstract base class for all exports that allow pre-selection of to-be-exported objects. More...
class | ExportToAccessArgs
Specialized argument class for the articy:access export More...
class | ExportToDocxArgs
Specialized argument class for the DOCX export More...
class | ExportToFullXmlArgs
Specialized argument class for the XML export This export currently has no other configuration options More...
class | ExportToXlsxArgs
Specialized argument class for the XLSX export More...
class | ExportXlsxForReimportArgs
Argument class for the XLSX export for Re-Import More...
class | FlowListNode
Contains the information about a single node in the flow linearization More...
class | FlowReference
Contains the information about a reference in the flow linearization More...
class | GenericExportDataArgs
When using the method ApiSession.ExportData an instance of this object needs to be passed along. More...
class | JourneyPointAction
class | ObjectPropertyInfo
This class aggregates information about a single property that is exposed from ObjectProxy More...
class | ObjectPropertyNames
This class contains constants for all properties that are introduced by the base objects of articy:draft. More...
class | ObjectProxy
Represents one articy:draft object like it is shown in the articy:draft GUI. More...
class | OpenProjectArgs
This argument object contains all parameters for the ApiSession.OpenProject method More...
class | ResultSet
This object is the container of objects that were found from a query. It is also internally used to cache meta/schema data for all accessed properties from elements in the row collection. This reduces the memory footprint and gives some extra speed when having many object of the same type in the result set. More...
class | SimplePartitionActionArgs
Base class for arguments that require a partition Guid. Some methods only need these arguments with no additional parameters More...
class | Transformer
This class contains methods to transform a selection of location objects. This object can only be created from an ApiLocationTools that is bound to a specific location. More...
class | UnclaimPartitionArgs
Argument class for unclaiming partition(s) More...
class | WaitForAssetProcessingArgs
Argument class for the ApiSession.WaitForAssetProcessing method. The main purpose is to be able to specify a log source name where progress messages should be reported More...

Enumerations

enum ExporterNames {
DocxExport, XlsxExport, XlsxForReimport, XmlContentExport,
AccessExport
}
enum PropertyDataType {
Unknown, Text, Integer, Float,
ObjectReference, ObjectList, Enum, Boolean,
Color, DateTime
}
known data types of fields/properties More...
enum PropertyDataSubType {
None, DependencyReference, SimpleReference, NativeReference,
Query, Script, ColorWithoutAlpha, ColorWithAlpha
}
a more detailed information about the data type More...
enum SystemFolderNames {
Project, Flow, Entities, Locations,
Documents, Assets, Journeys, GlobalVariables
}
Technical names of system folders. These names can be used in the FROM clause of a query and to get the folder object when using the GetSystemFolder method More...
enum ObjectType {
InvalidObjectReference, Project, Flow, Dialogue,
DialogueFragment, FlowFragment, Comment, Jump,
Hub, Condition, Instruction, Connection,
Pin, Locations, LocationsUserFolder, Location,
LayerFolder, Link, Zone, Path,
Spot, Entities, EntitiesUserFolder, Entity,
Journeys, JourneysUserFolder, Journey, JourneyPoint,
Assets, AssetsUserFolder, Asset, Documents,
DocumentsUserFolder, Document, TextObject, GlobalVariables,
VariableSet, Variable, LocationImage, LocationText,
LocationAnchor
}
This enumeration contains all object types available for API access. More...
enum JourneyActionTypes {
Skip = 2, Next = 3, Submerge = 4, Emerge = 5,
Branch = 6
}
Available actions to take while recording a journey More...
enum EntryType {
Error, Warning, Info, Trace,
Debug
}
Entry type of log messages More...
enum | ProjectRightLevel { NoRight = -1, Guest = 0, Worker = 1, Admin = 2 }
right levels of users in projects More...
enum SearchConflictsIn {
References = 1, FeatureValues = 2, TechnicalNames = 4, Asset = 8,
ScriptExpressions = 16, AnyConflict = 31
}
Flag enum for searching for conflicts More...
enum SearchTextIn {
Name = 1, Description = 2, FeatureValues = 4, Pins = 8,
OtherTexts = 16, AnyText = 31
}
Flag enum to specify where the simple text search should look up its strings More...
enum TextFilterRelation {
HasValue = 0, IsEmpty = 1, Equal = 2, NotEqual = 3,
Greater = 4, LessOrEqual = 5, Less = 6, GreaterOrEqual = 7,
Contains = 8, DoesNotContain = 9, StartsWith = 10, DoesNotStartWith = 11,
EndsWith = 12, DoesNotEndWith = 13, MatchRegex = 14, DoesNotMatchRegex = 15
}
enumeration of filter relations used for SimpleSearch More...
enum | PropertyFilter { None = 0, Base = 1, Custom = 2, All = 3 }
Flag based filter for GetAvailableProperties of ObjectProxy More...
enum | HierarchyAdjustment { AsUncle = 0, AsSibling = 1, AsChild = 2 }
Specifies the placement of a new document object in respect to the given context object. More...
enum | RepartitionMode { Create, Retire, Toggle }
Specifies how repartitioning should work on the given objects More...
enum | FlowToListTraversalType { DepthFirst, BreadthFirst, ShortestPath }
enum ErrorCode {
NotInitialized = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 0, AlreadyInitialized = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 1, DotNetFrameworkNotFound = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 2, Internal = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 3,
GenericException = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 4, ProjectNotFound = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 5, SourceControlError = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 6, UnknownServerError = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 7,
UnknownExport = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 8, InvalidExportDescriptior = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 9, NotConnected = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 10, ColumnNotFound = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 11,
WriteDenied = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 12, ObjectNotAvailable = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 13, InvalidState = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 14, UnknownPartition = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 15,
PartitionNotClaimed = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 16, CantForcefullyUnclaimOwnPartition = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 17, ProjectNotOpen = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 18, ProjectOpen = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 19,
CantSetCalculatedProperty = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 20, PropertyNotFound = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 21, UnexpectedObjectClass = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 22, ObjectNotCustomizeable = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 23,
NoTemplateSet = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 24, FeatureNotPresent = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 25, CantSetStrip = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 26, UnsetObjectStrip = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 27,
UnknownDataType = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 28, UnknownDataSubType = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 29, InvalidValue = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 30, ObjectCreationForbidden = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 31,
CantOpenProject = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 32, NeedExclusiveModeToOpen = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 33, NotAllowedInExclusiveMode = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 34, UnknownTemplate = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 35,
TemplateNotAllowedForObject = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 36, CantSetReadOnlyProperty = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 37, CantSetObjectAggregates = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 38, ObjectIsNotConnectable = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 39,
ForbiddenPinCount = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 40, FatalErrorDetected = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 41, UnsupportedObject = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 42, IndexOutOfRange = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 43,
ParentDoesNotAllowFolders = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 44, ObjectNull = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 45, InvalidParentForCreate = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 46, NeedMoreVertices = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 47,
WrongReferencedObjectType = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 48, InvalidTechnicalName = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 49, DisplayNameMustNotBeEmpty = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 50, ParseException = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 51,
AssetsNotReady = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 52, PartitionClaimed = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 53, InvalidDataFound = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 54, MissingProjectFolder = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 55,
ExportFailed = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 56, AssetObjectExpected = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 57, AssetFileNotFound = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 58, DeleteNotAllowed = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 59,
CantDeletePartitionRoot = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 60, CantDeleteSystemFolder = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 61, WrongContextForDocument = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 62, WrongContextObjctTypeForDocument = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 63,
InvalidHierarchyAdjustment = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 64, DocumentObjectExpected = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 65, ComponentLicenseMissing = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 66, InvalidQuery = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 67,
InvalidVariableName = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 68, NameNotUnique = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 69, ExpressionError = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 70, NonScriptableProperty = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 71,
ObjectNotPartitionable = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 72, RepartitioningFailed = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 73, WrongObjectType = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 74, ParentNotClaimed = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 75,
CantAddPin = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 76, CantRemovePin = ApiConsts.ApiFacility << ApiConsts.FacilityShift | 77, ServerExceptionCatched = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 100, MandatoryParameterMissing = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 101,
NotANumber = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 102, AccessDenied = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 103, InvalidServerState = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 104, DataInconsistent = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 105,
DatabaseException = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 106, NoSession = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 107, RequestTimeout = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 108, RemoteRequestTimeout = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 109,
NoActiveConnection = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 110, ServerDbUnavailable = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 111, ServerFail = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 112, RemoteServerException = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 113,
UserNotFound = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 200, InvalidPassword = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 201, LoginNotAllowed = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 202, CantCreateUser = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 203,
CantUpdateUser = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 204, ProjectNotFoundOnServer = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 300, CantOpenExclusive = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 301, ProjectAlreadyOpen = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 302,
ClaimsPresent = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 303, ProjectAlreadyOpenedExclusive = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 304, ProjectDeactivated = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 305, ProjectUnavailable = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 306,
UsersWorking = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 307, NeedExclusiveModeToCleanup = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 308, RepartitioningActive = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 309, NoClaimPresent = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 400,
NeedsFullUpdate = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 401, NoLicense = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 500, ServerLicenseExpired = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 501, ServerLicenseAlreadyActivated = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 502,
LicenseKeyMismatch = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 503, NoApiLicense = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 504, NoCAL = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 600, DowngradeRequired = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 602,
InsufficientCAL = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 603, NoCALAvailable = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 604, Underlicensed = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 605, CantEnterPartitioningMode = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 700,
CantConnectArticyServer = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 0x1000, ArticyServerToOld = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 0x1001, ArticyServerToNew = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 0x1002, NoArticyServerInfoAvailable = ApiConsts.ServerFacility << ApiConsts.FacilityShift | 0x1003
}
This enumeration contains error codes that are detected by the API More...

Functions

delegate void LoggingCallback (string aMessageSource, EntryType aType, string aText)
The delegate used to report logging information More...

Enumeration Type Documentation

enum PropertyDataType

known data types of fields/properties

Enumerator
Unknown | property type is unknown
Text | property is of type text
Integer | property is an integer number type
Float | property is a floating point number
ObjectReference | property is a reference to an object
ObjectList | property is a list of references to other objects
Enum | property is an enumerated value
Boolean | property is a boolean value
Color | property is a color
DateTime | property is a date-time value
enum PropertyDataSubType

a more detailed information about the data type

Enumerator
DependencyReference | The reference is a dependency reference
SimpleReference | The reference is a simple object reference
NativeReference | The reference comes from a native C# object,
Query | The reference list is the result of a query
Script | Property is a script text
ColorWithoutAlpha | A color without alpha channel
ColorWithAlpha | A color including alpha channel
enum SystemFolderNames

Technical names of system folders. These names can be used in the FROM clause of a query and to get the folder object when using the GetSystemFolder method

Enumerator
Project | the root node of the project
Flow | the folder of all flow nodes
Entities | the entities root folder
Locations | the folder that contains locations
Documents | the folder that contains Documents
Assets | the folder that contains assets
Journeys | the folder that contains journeys
GlobalVariables | the folder that contains namespaces and variables
enum ObjectType

This enumeration contains all object types available for API access.

Enumerator
InvalidObjectReference | an object reference whose target does not exist
Project | the root object of the project.
Flow | the flow system folder object.
Dialogue | the object is a Dialogue
DialogueFragment | the object is a DialogueFragment
FlowFragment | the object is a FlowFragment
Comment | the object is a comment/annotation
Jump | the object is a jump
Hub | the object is a hub
Condition | the object is a condition node
Instruction | the object is an instruction node
Connection | the object is a connection that connects two pins
Pin | the object is a Pin
Locations | the locations system folder
LocationsUserFolder | a user created folder for locations
Location | the object is a location
LayerFolder | the object is a location layer folder
Link | the object is a Link (placed on a location)
Zone | the object is a Zone (placed on a location)
Path | the object is a Path (placed on a location)
Spot | the object is a Spot (placed on a location)
Entities | the system folder for entities
EntitiesUserFolder | a user created folder for entities
Entity | the object is an entity
Journeys | the system folder for journeys
JourneysUserFolder | a user created folder for journeys
Journey | the object is a journey
JourneyPoint | the object is a journey point
Assets | the system folder for assets
AssetsUserFolder | a user created folder for journeys
Asset | the object is a asset meta data object
Documents | the system folder for documents
DocumentsUserFolder | a user created folder for Documents
Document | the object is a document object
TextObject | the object is a text section of a document object
GlobalVariables | the object is the system folder for namespaces and global variables
VariableSet | the object is a namespace for global variables
Variable | the object is a global variable
LocationImage | an image object within the location
LocationText | a text object within the location
LocationAnchor | a anchor object for texts / images in locations
enum JourneyActionTypes

Available actions to take while recording a journey

Enumerator
Skip | Skips the children of this node and continues directly with its output pins.
Next | Follows the path along with the next element.
Submerge | Dives into the children of this node.
Emerge | Dives out of the children back to the parent node.
Branch | Identifies a branching option, multiple of these might be returned as an allowed action and each stands for one possible choice to advance the journey.
enum EntryType

Entry type of log messages

Enumerator
Error | the message denotes an error
Warning | the message denotes a warning
Info | the message denotes a information
Trace | the message is a trace entry
Debug | the message is a debug outpuz
enum ProjectRightLevel

right levels of users in projects

Enumerator
NoRight

the user has no right on this project

Guest

User has guest level access, only read access allowed. A User that has a viewer license assigned always has this right level when assigned to a project

Worker

User has worker access and can modify all normal objects

Admin

User has project admin access and can:

  • access project settings. (GUI only)
  • Has the right to migrate the project to a newer version
  • Is Allowed to manage project members (GUI only)
enum SearchConflictsIn

Flag enum for searching for conflicts

Enumerator
References | Searches for objects that have broken references
FeatureValues | Searches for objects where custom feature values are invalid according to their constraints
TechnicalNames | Searches for duplicate technical names within the content objects
Asset | Searches for assets that are in a conflicting state
ScriptExpressions | Searches for scripts that are in a conflicting state
AnyConflict | searches for all of the above issues
enum SearchTextIn

Flag enum to specify where the simple text search should look up its strings

Enumerator
Name | Searches in the display name property
Description | searches in the Text/Description/Spoken Text property
FeatureValues | searches in custom feature values, numbers are converted to strings before testing
Pins | searches in the text of connected pins of flow objects
OtherTexts | searches in other texts like technical names, Note content markup texts, stage directions, preview texts
AnyText | searches on all of the above places
enum TextFilterRelation

enumeration of filter relations used for SimpleSearch

Enumerator
HasValue | text is present in the field(s) to search
IsEmpty | no text is present in the field(s) to search
Equal | the text in the field(s) to search equals the given value
NotEqual | the text in the field(s) to search differs the given value
Greater | the text in the field(s) to search is greater than the given value
LessOrEqual | the text in the field(s) to search is less than or equal to the given value
Less | the text in the field(s) to search is less than the given value
GreaterOrEqual | the text in the field(s) to search is greater as or equal to the given value
Contains | the text in the field(s) to search contains the given value
DoesNotContain | the text in the field(s) to search does not contains the given value
StartsWith | the text in the field(s) to search starts with the given value
DoesNotStartWith | the text in the field(s) to search does not start with the given value
EndsWith | the text in the field(s) to search ends with the given value
DoesNotEndWith | the text in the field(s) to search does not end with the given value
MatchRegex | the text in the field(s) to search matches the regular expression given
DoesNotMatchRegex | the text in the field(s) to search does not match the regular expression given
enum PropertyFilter

Flag based filter for GetAvailableProperties of ObjectProxy

Enumerator
None | get no properties
Base | only get properties from the underlying object
Custom | only get custom properties that were introduced by features
All | get all available properties
enum HierarchyAdjustment

Specifies the placement of a new document object in respect to the given context object.

Enumerator
AsUncle | Creates the element as sibling of the parent of the given context object (Hierarchy level -1)
AsSibling | Creates the new object directly after the given context element as sibling at the same hierarchy level (Hierarchy level +0) and placing it directly after all the children of the context element.
AsChild | Creates the new object as the child of the context element. (Hierarchy level +1) This child is always the first child, any already existing child objects are moved down.
enum RepartitionMode

Specifies how repartitioning should work on the given objects

Enumerator
Create | Only create new partitions
Retire | Only retire existing partitions
Toggle | Retire if alrady a partition, create if not
enum FlowToListTraversalType
Enumerator
DepthFirst | Descent first before using the next alternative
BreadthFirst | First visit alternative before descending
ShortestPath | Hybrid model that tries to generate less fragments
enum ErrorCode

This enumeration contains error codes that are detected by the API

Enumerator
NotInitialized | the API was not initialized before trying to create a session
AlreadyInitialized | tried to initialize more than one time
DotNetFrameworkNotFound | the required .NET framework was not found
Internal | thrown when an internal error occured in the a:d logic
GenericException | an unexpected exception from a lower level system was catched and wrapped
ProjectNotFound | the project given to load is unknown (either missing rights, deleted or never existing)
SourceControlError | an exception was catched that originates from source control (-> see inner exception)
UnknownServerError | an articy:server exception was catched but there is no RpcStatusCode available for a more detailed error
UnknownExport | the exports technical name is not known
InvalidExportDescriptior | failed to parse the export descriptor or missing export type in root element
NotConnected | an command was issued that requires to be logged on
ColumnNotFound | a column was not found on a given object
WriteDenied | writing to a row was denied because the row is read-only
ObjectNotAvailable | an object that was encapsulated by an proxy does not exist any more
InvalidState | a call is impossible in the current object/project state
UnknownPartition | the given partition guid is unknown
PartitionNotClaimed | tried to unclaim a partition that the API user does not own
CantForcefullyUnclaimOwnPartition | tried to forcefully unclaim an own partition
ProjectNotOpen | is thrown when a method expects an open project but there is no open project
ProjectOpen | is thrown when a method expects that no open project exist but there is a open project
CantSetCalculatedProperty | tried to write a calculated property
PropertyNotFound | the given property does not exist for the given object
UnexpectedObjectClass | the given class was not expected to be API exposed
ObjectNotCustomizeable | tried to set a feature value on a non customizable object
NoTemplateSet | tried to set a feature value on a object without a set template
FeatureNotPresent | tried to set a feature value where the object does not contain that feature
CantSetStrip | a strip can't be set directly
UnsetObjectStrip | thrown when trying to access an unset object collection
UnknownDataType | a value getter or setter encountered an unknown data type
UnknownDataSubType | a value getter or setter encountered an unknown data sub type
InvalidValue | the given value is not allowed for setting it to a property
ObjectCreationForbidden | it is forbidden to create an object of this type at this target
CantOpenProject | thrown when a project can't be opened
NeedExclusiveModeToOpen | thrown when a project needs an exclusive mode to open but the flag was not set
NotAllowedInExclusiveMode | thrown when partition actions are used in exclusive mode
UnknownTemplate | the referenced template does not exist (either name or ID)
TemplateNotAllowedForObject | the template exists but is not allowed for the object
CantSetReadOnlyProperty | tried to set a property that is read-only
CantSetObjectAggregates | thrown when properties of data subtype "Model" are tried to be written by the API
ObjectIsNotConnectable | thrown when a connectable object is needed (adding pins for example)
ForbiddenPinCount | thrown when a the operation would result in a forbidden pin count
FatalErrorDetected | thrown when a fatal error in the business logic was detected
UnsupportedObject | thrown when trying to access an object that is not allowed for API use
IndexOutOfRange | list access with index out of range
ParentDoesNotAllowFolders | thrown by create folder if the parent does not allow it
ObjectNull | thrown then a non-null object proxy was expected but null was found
InvalidParentForCreate | thrown when a object creation fails due to a wrong parents. E.g. Trying to import an Asset into an EntityUserFolder
NeedMoreVertices | thrown when creating a path or polygon with violated minimum vertex count
WrongReferencedObjectType | thrown when wrong object type is assigned to an object reference (Link or Jump for example)
InvalidTechnicalName | thrown when an internal error occurred in the a:d logic
DisplayNameMustNotBeEmpty | thrown when a display name is null, empty or only contains whitespace chars
ParseException | thrown if parsing a query reported an error
AssetsNotReady | asset system is not clean and not ready for unclaim
PartitionClaimed | You tried to update a partition that you already have claimed
InvalidDataFound | This error code denotes that a folder given as project folder contains a non matching project or no project at all
MissingProjectFolder | This error code is thrown when an open project does not know where to place the project data. E.g. the project was never opened and no Project-Folder was given in the open args.
ExportFailed | This error code is thrown when an export could not completed successfully. The reason may either be an unexpected exception from the lower layer or most likely an error condition that was also reported to the logging callback (if set)
AssetObjectExpected | This error code is thrown when an asset object is expected but was not given.
AssetFileNotFound | This error code is thrown when an asset
DeleteNotAllowed | This error code is thrown when a delete is not allowed. This can be the case if an inner object is a partition root object.
CantDeletePartitionRoot | This error is thrown when you try to delete an object that is the root of a partition
CantDeleteSystemFolder | This error is thrown when you try to delete a system folder object (e.g. Assets)
WrongContextForDocument | operations on documents require a context object, that must be a document or a child of a document. If this is not the case this exception is thrown.
WrongContextObjctTypeForDocument | Only Documents & TextObjects are allowed to have children in a document.
InvalidHierarchyAdjustment | This error is thrown if the hierarchical placement of a new document element is not allowed. e.g. Trying to add an TextObject as sibling of an Document object.
DocumentObjectExpected | This error is thrown when an document object was expected as parameter but another was given.
ComponentLicenseMissing | This error is thrown when a functionality is used which needs a specific license, but this license is not present.
InvalidQuery | This error is thrown when a calculated reference strip is accessed, but executing the query fails for some reason.
InvalidVariableName | This error is thrown when the given full qualified variable name is malformed.
NameNotUnique | This error is thrown when a variable or variable set name is already used.
ExpressionError | This error is thrown when an expression contains an error.
NonScriptableProperty | This error is thrown when trying to validate an expression on a property that does not support scripting.
ObjectNotPartitionable | This error is thrown when trying to partition an object that cannot be a partition.
RepartitioningFailed | This error is thrown when a repartitioning action failed.
WrongObjectType | This object passed to a function is of the wrong or an unsupported object type
ParentNotClaimed | This error code is throw when using accessing the position/sizing members of an flow-item and the parent-container object is not claimed.
CantAddPin | This error code is throw when trying to add a pin to an object that either has no pins (e.g Entity), does not allow to add pins (e.g. Condition) or has reached the limit of allowed pins (currently 10)
CantRemovePin | This error code is throw when trying to remove a pin from an object that has no pins (e.g. Entity) or does not allow to remove pins ( e.g. Condition)
ServerExceptionCatched | An exception was catched, no detailed error reason available
MandatoryParameterMissing | The call could not be process because mandatory parameters were missing
NotANumber | The parsing of a number failed
AccessDenied | The requesting user did not have the required rights to access/modify the requested information
InvalidServerState | The call could not be completed in the current server session state. (e.g. trying to login when a authenticated session already exists)
DataInconsistent | Some consistency checks on the given parameter have failed
DatabaseException | An error from the database query layer has been catched
NoSession | A method that expected an existing session was called, but the session is not available
RequestTimeout | The processing of a method did not return in time
RemoteRequestTimeout | The processing of an upsteam call (e.g. License-Server) did not return in time
NoActiveConnection | There was not active connection at the time a call was issued.
ServerDbUnavailable | This error code is thrown if you try to login to an server which did not have its database ready
ServerFail | generic error if the server reaches a code point where other checks already should have stopped the processing
RemoteServerException | The processing of an upsteam call (e.g. License-Server) has thrown an exception.
UserNotFound | the requested user was not found on the server or was deactivated
InvalidPassword | the password (hash) does not match
LoginNotAllowed | The login was denied because the same user has an active session from a different machine
CantCreateUser | The new user row can't be created because either the user already exists or no license is available
CantUpdateUser | The user row can't be updated because the login name conflicts with an already existing user
ProjectNotFoundOnServer | The requested project was not found (or deactivated)
CantOpenExclusive | The requested project can't be opened exclusive (already exclusively open elsewhere or locks are present)
ProjectAlreadyOpen | The server known that you have the project already open (it is not allowed to open the same project twice at the same time)
ClaimsPresent | When you try to claim an partition and that partition is already claimed, this error is thrown
ProjectAlreadyOpenedExclusive | The project can't be opened because it already is open exclusive by another user
ProjectDeactivated | You tried to open a deactivated project
ProjectUnavailable | You tried to open an project that is temporarily unavailable (e.g. a ForcefullyUnclaimPartitions command is pending)
UsersWorking | Tried to initiate a "forcefully unclaim all partitions" command while users are working in the project and you did not specify to kick those users
NeedExclusiveModeToCleanup | Project needs an exclusive mode to cleanup
RepartitioningActive | Current operation can't be executed because the publishing/commiting of an repartitioning is pending. Try again later.
NoClaimPresent | You tried to forcedully unclaim a partition that is not currently claimed
NeedsFullUpdate | The project was repartitioned, before new claims can be taken, a full project update needs to be done.
NoLicense | You tried to log into a server that has no license. (SystemAdmin user can still log-in to fix this)
ServerLicenseExpired | The articy:server main product license has expired
ServerLicenseAlreadyActivated | The articy:server was requested to activate a license, but is already licensed
LicenseKeyMismatch | The license update for the server returned a license key that was not requested (should never happen)
NoApiLicense | A user tried to login using the articy:draft API but the server was not licensed for API usage
NoCAL | A user logged in that did not have a client access license assigned (either multi-user or viewer)
DowngradeRequired | The server admin tries to change the license of a user to a more restrictive license (e.g. from "multi-user" to "viewer"), but the user is member of a project and has access that is not covered by the requested license. The downgrade is automatically done when the matching checkbox in the editing dialog is checked
InsufficientCAL | This error is returned when you try to give a user higher access than it current license allows (e.g. TeamMember level for a user with viewer license)
NoCALAvailable | This error is returned when you try to upgrade a user to a new CAL, but all free licenses are already used
Underlicensed | This error is returned when a user tries to log on an the CAL type the user owns has more licenses used than allowed. This error only can arise with CALs that have an expiry date.
CantEnterPartitioningMode | This error is returned when a user tries to enter the repartitioning mode, but another user already uses it.
CantConnectArticyServer | This error is thrown when the given server can't be connected
ArticyServerToOld | This error is thrown when the connected articy:server has a version that is to low to operate with
ArticyServerToNew | This error is thrown when the connected articy:server has a version that is to new to operate with
NoArticyServerInfoAvailable | This error is thrown when articy:draft was no possible to retrieve the server capability/version information

Function Documentation

delegate void Articy.Api.LoggingCallback | ( | string | aMessageSource,
 |  | EntryType | aType,
 |  | string | aText
 | ) |  |

The delegate used to report logging information

Parameters
aMessageSource | the source of the message. Can either be one of the predefined sources 'System' or 'API' or a user given source name as found as LogSourceName in the parameter args objects required by some methods
aType | the entry type of the message
aText | the actual message text

This is the delegate of an method your program should provide to the articy:draft API to receive log messages.


articy:draft API: Package Articy.Export

  • Export
Namespaces
Package Articy.Export

Namespaces

package Office


articy:draft API: Package Articy.Export.Office

  • Export
  • Office
Enumerations
Package Articy.Export.Office

Enumerations

enum | ExportMethod { Multiple, Single, List }
Specifies how the DOCX export genrates its documents More...
enum ExportSortedBy {
DisplayName, TechnicalName, ObjectType, Template,
ProjectPath, NavigatorOrder
}
Determines the sort criteria for the objects for DOCX & XLSX exports. For XLSX export the sorting is applied after the objects are grouped. So each group is sorted separately. More...
enum | ExportGroupedBy { Nothing, Folder, ObjectType, Template }
Determines the grouping objects for XLSX exports More...
enum | PageSize { A4, Letter }
Determines the pagesize in office documents More...
enum | ExportWhichName { DisplayName, TechnicalName }
Determines which names should be exported in XLSX exports. Is applied to feature / property names in headlines and to object references in the content data area More...
enum | ExportFeatureOrder { Alphabetical, UsageCount }
Determines the sort order of features in the XLSX exports More...
enum | ExportVariableOrder { ScriptingName, Namespace, DataType }
Determines which names should be exported in XLSX exports. Is applied to variable names More...

Enumeration Type Documentation

enum ExportMethod

Specifies how the DOCX export genrates its documents

Enumerator
Multiple | Multiple documents are created, one for each object
Single | All objects are put into one document
List | One document is created, the output format is a compact list like form
enum ExportSortedBy

Determines the sort criteria for the objects for DOCX & XLSX exports. For XLSX export the sorting is applied after the objects are grouped. So each group is sorted separately.

Enumerator
DisplayName | The objects are sorted by their "DisplayName"
TechnicalName | The objects are sorted by their "TechnicalName"
ObjectType | The objects are sorted by their object type
Template | The objects are sorted by their template name
ProjectPath | The objects are sorted based on the path in the navigator tree
NavigatorOrder | Sort the objects by Navigator order, this is mostly by Displayname but different for locations & documents.
enum ExportGroupedBy

Determines the grouping objects for XLSX exports

Enumerator
Nothing | No groups are built
Folder | Objects are grouped by their containing folder
ObjectType | Objects are grouped by their type
Template | Objects are grouped by their template
enum PageSize

Determines the pagesize in office documents

Enumerator
A4 | assume DIN A4 paper size for layouting
Letter | assume letter paper size for layouting
enum ExportWhichName

Determines which names should be exported in XLSX exports. Is applied to feature / property names in headlines and to object references in the content data area

Enumerator
DisplayName | Use display names where possible
TechnicalName | use technical names where possible
enum ExportFeatureOrder

Determines the sort order of features in the XLSX exports

Enumerator
Alphabetical | Features are sorted ascending by their names (either display- or technical- name), depending on "WhichName" setting. Then they a placed left to right
UsageCount | Features that are used more often (by the objects on that sheet) are shown first.
enum ExportVariableOrder

Determines which names should be exported in XLSX exports. Is applied to variable names

Enumerator
ScriptingName | sort ascending by ScriptingName
Namespace | sort ascending by Namespace
DataType | sort ascending by DataType


articy:draft API: Package Articy.Models

  • Models
Namespaces
Package Articy.Models

Namespaces

package Scripting


articy:draft API: Package Articy.Models.Scripting

  • Models
  • Scripting
Enumerations
Package Articy.Models.Scripting

Enumerations

enum VariableType { Integer, Boolean }
Enum specifying the type of a global variable More...

Enumeration Type Documentation

enum VariableType

Enum specifying the type of a global variable


articy:draft API: Namespace Members

Here is a list of all documented namespace members with links to the namespaces they belong to:

- z -

  • Zone : Articy::Api


articy:draft API: Namespace Members

  • LoggingCallback() : Articy::Api


articy:draft API: Namespace Members

  • EntryType : Articy::Api
  • ErrorCode : Articy::Api
  • ExportFeatureOrder : Articy::Export::Office
  • ExportGroupedBy : Articy::Export::Office
  • ExportMethod : Articy::Export::Office
  • ExportSortedBy : Articy::Export::Office
  • ExportVariableOrder : Articy::Export::Office
  • ExportWhichName : Articy::Export::Office
  • FlowToListTraversalType : Articy::Api
  • HierarchyAdjustment : Articy::Api
  • JourneyActionTypes : Articy::Api
  • ObjectType : Articy::Api
  • PageSize : Articy::Export::Office
  • ProjectRightLevel : Articy::Api
  • PropertyDataSubType : Articy::Api
  • PropertyDataType : Articy::Api
  • PropertyFilter : Articy::Api
  • RepartitionMode : Articy::Api
  • SearchConflictsIn : Articy::Api
  • SearchTextIn : Articy::Api
  • SystemFolderNames : Articy::Api
  • TextFilterRelation : Articy::Api
  • VariableType : Articy::Models::Scripting


articy:draft API: Namespace Members

- z -

  • Zone : Articy::Api


articy:draft API: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
▼N Articy |
▼N Api |
C ApiCollaborativeHelper |
C ApiConsts | static class that contains some constants and a error code helper method
C ApiJourneyBuilder |
C ApiLocationTools |
C ApiSession | Once the session is created successfully, all further API calls are invoked on this session object.
C ArticyApi | This static class the the bootstrapping singleton to startup and shutdown the articy:draft API
C ArticyApiException |
C CloseProjectArgs | Argument class for ApiSession.CloseProject
C ComplexApiCallArgs | base class for the argument objects used for API calls that have many parameters
C ExportDataArgs | The abstract base class for all specialized export arguments
C ExportDocumentToDocxArgs | The parameter args to be used for exporting a document object to Word
C ExportObjectSelectionDataArgs | Abstract base class for all exports that allow pre-selection of to-be-exported objects
C ExportToAccessArgs | Specialized argument class for the articy:access export
C ExportToDocxArgs | Specialized argument class for the DOCX export
C ExportToFullXmlArgs | Specialized argument class for the XML export This export currently has no other configuration options
C ExportToXlsxArgs | Specialized argument class for the XLSX export
C ExportXlsxForReimportArgs | Argument class for the XLSX export for Re-Import
C FlowListNode | Contains the information about a single node in the flow linearization
C FlowReference | Contains the information about a reference in the flow linearization
C GenericExportDataArgs | When using the method ApiSession.ExportData an instance of this object needs to be passed along.
C JourneyPointAction |
C ObjectPropertyInfo | This class aggregates information about a single property that is exposed from ObjectProxy
C ObjectPropertyNames | This class contains constants for all properties that are introduced by the base objects of articy:draft
C ObjectProxy | Represents one articy:draft object like it is shown in the articy:draft GUI.
C OpenProjectArgs | This argument object contains all parameters for the ApiSession.OpenProject method
C ResultSet | This object is the container of objects that were found from a query. It is also internally used to cache meta/schema data for all accessed properties from elements in the row collection. This reduces the memory footprint and gives some extra speed when having many object of the same type in the result set.
C SimplePartitionActionArgs | Base class for arguments that require a partition Guid. Some methods only need these arguments with no additional parameters
C Transformer | This class contains methods to transform a selection of location objects. This object can only be created from an ApiLocationTools that is bound to a specific location.
C UnclaimPartitionArgs | Argument class for unclaiming partition(s)
C WaitForAssetProcessingArgs | Argument class for the ApiSession.WaitForAssetProcessing method. The main purpose is to be able to specify a log source name where progress messages should be reported
▼N Export |
▼N Models |


articy:draft API: ApiCollaborativeHelper Class Reference

  • Api
  • ApiCollaborativeHelper
Static Public Member Functions | List of all members
ApiCollaborativeHelper Class Reference

Static Public Member Functions

static PartitionInfo | GetPartitionInfo (Guid aPartition)
static PartitionInfo | GetPartitionInfo (ProjPartitionModel aPartitionModel)
static void | SetActionLog (CollaborativeActionBase aAction, string aLogSourceName, LoggingCallback aLoggingCallback)


articy:draft API: ApiConsts Class Reference

  • Api
  • ApiConsts
Static Public Member Functions | Public Attributes | List of all members
ApiConsts Class Reference

static class that contains some constants and a error code helper method More...

Static Public Member Functions

static int MakeErrorCode (int aFacility, int aErrorNumber)
helper method to combine a facility number and an error number to an error code More...

Public Attributes

const string | MsgSrcSystem = "System"
the message source used to report "system" messages from the underlying articy:draft client More...
const string | MsgSrcApi = "API"
the message source used to report API related messages More...
const int | ErrorCodeMask = 0xffff
the bit mask that can be applied to the ErrorCode of an Articy.Api.ArticyApiException to extract the error number More...
const int | FacilityShift = 16
the number of bits the facility bits are shifted up (left) More...
const int | FacilityMask = 0xff
the bitmask used to extract the facility number from the ErrorCode of an Articy.Api.ArticyApiException. This mask must be applied after shifting down the bits. More...
const int | ApiFacility = 0
the facility number from API reported errors More...
const int | ServerFacility = 1
the facility number for articy:server reported errors More...

Detailed Description

static class that contains some constants and a error code helper method

Member Function Documentation

static int MakeErrorCode | ( | int | aFacility,
 |  | int | aErrorNumber
 | ) |  |
inlinestatic

helper method to combine a facility number and an error number to an error code

Parameters
aFacility | the facility that has reported the error
aErrorNumber | the facility private error number
Returns
an error code with the combined bits from facility and error number

Member Data Documentation

const string MsgSrcSystem = "System"

the message source used to report "system" messages from the underlying articy:draft client

const string MsgSrcApi = "API"

the message source used to report API related messages

const int ErrorCodeMask = 0xffff

the bit mask that can be applied to the ErrorCode of an Articy.Api.ArticyApiException to extract the error number

const int FacilityShift = 16

the number of bits the facility bits are shifted up (left)

const int FacilityMask = 0xff

the bitmask used to extract the facility number from the ErrorCode of an Articy.Api.ArticyApiException. This mask must be applied after shifting down the bits.

const int ApiFacility = 0

the facility number from API reported errors

const int ServerFacility = 1

the facility number for articy:server reported errors


articy:draft API: ApiJourneyBuilder Class Reference

  • Api
  • ApiJourneyBuilder
Public Member Functions | Properties | List of all members
ApiJourneyBuilder Class Reference
Inheritance diagram for ApiJourneyBuilder:

Public Member Functions

void | StoreJourney (ObjectProxy aFolder, string aDisplayName)
void | TakeAction (JourneyPointAction aAction)
void | Dispose ()

Properties

ObjectProxy | Journey [get]
ObjectProxy | CurrentJourneyPoint [get]
ReadOnlyCollection< JourneyPointAction > | AvailableActions [get]


articy:draft API: ApiLocationTools Class Reference

  • Api
  • ApiLocationTools
Public Member Functions | Properties | List of all members
ApiLocationTools Class Reference

Public Member Functions

BitmapSource | GetLocationBitmap (Size aMaxSize)
Gets the rendered bitmap for the current location with a specified maxmimum size More...
void | SaveLocationAsJpeg (string aFilename, Size aMaxSize, int aJpegQuality=90)
Saves the current location as a jpeg file with a specified filename, a maximum size and a specified quality level More...
void | SaveLocationAsPng (string aFilename, Size aMaxSize)
Saves the current location as a png file with a specified filename and a maximum size More...
void | SaveLocationAsXps (string aFilename)
Saves the current location as an xps file with a specified filename More...
Transformer CreateTransformer ()
Creates a transformer object to enable transformation mode for LocationObjects More...
Transformation related

The following methods provide methods to get vertex and transformation data

Matrix | GetTransformMatrix (ObjectProxy aLocationObject)
Gets the transform matrix of a specified LocationObject More...
Rect | GetLocalBoundingBox (ObjectProxy aLocationObject)
Gets the local bounding box of a specific LocationObject More...
Rect | GetTransformedBoundingBox (ObjectProxy aLocationObject)
Gets the transformed bounding box of a specific LocationObject More...
List< Point > | GetLocalVertices (ObjectProxy aLocationObject)
Gets a list of points containing the coordinates for the local vertices More...
List< Point > | GetTransformedVertices (ObjectProxy aLocationObject)
Gets a list of points containing the coordinates for the transformed vertices More...
Point | GetPosition (ObjectProxy aLocationObject)
Gets the position of a specific LocationObject More...
void | SetPosition (ObjectProxy aLocationObject, Point aNewPosition)
Sets the position of a LocationObject to a new point More...
void | ResetTransformation (ObjectProxy aLocationObject)
Resets the transformation for a specified LocationObject. Sets the rotation to 0.0, the TransformXAxis to 1.0/0.0 and the TransformYAxis to 0.0/1.0 More...
Conversion related

The following methods provide methods to convert or process shapes

void | SimplifyPath (ObjectProxy aPath, double aTolerance=-1)
Simplifies the path of a specified shape, thus reducing the points count along the path with a specified tolerance. More...
void | PolygonToRectangle (ObjectProxy aZone)
Converts a specified zone from a polygon to a rectangle More...
void | PolygonToCircle (ObjectProxy aZone)
Converts a specified zone from a polygon to a circle More...
void | CircleToRectangle (ObjectProxy aZone)
Converts a specified zone from a circle to a rectangle More...
void | CircleToPolygon (ObjectProxy aZone, int aNumPoints=72)
Converts a specified zone from a circle to a polygon More...
Anchor related

The following methods provide methods to work with images

ObjectProxy | CreateAnchor (ObjectProxy aLocationObject, Point aPosition)
Creates an anchor of a specified LocationObject at a specified position More...
void | RemoveAnchor (ObjectProxy aAnchor)
Deletes a specified anchor More...
void | RemoveAllAnchors (ObjectProxy aAnchoredObject)
Removes all anchors of a specified AnchoredObjects More...
void | ClearCropRect (ObjectProxy aLocationImage)
Resets the cropping of a specified LocationImage More...
void | ResetAspectHorizontal (ObjectProxy aLocationImage)
Resets the aspect ratio of a specified LocationImage in horizontal mode More...
void | ResetAspectVertical (ObjectProxy aLocationImage)
Resets the aspect ratio of a specified LocationImage in vertical mode More...
Rect | GetImageCropRect (ObjectProxy aLocationImage)
Gets the cropping rectangle of a specified LocationImage More...
void | SetImageCropRect (ObjectProxy aLocationImage, Rect aCropRect)
Sets the cropping rectangle of a specified LocationImage with a specified rectangle. The cropping coordinates are from 0.0 to 1.0 for each axis More...
void | SetImage (ObjectProxy aLocationImage, ObjectProxy aImageAsset)
Assigns a specified image asset to a specified LocationImage object More...

Properties

ObjectProxy | Location [get]
ApiSession | Session [get]

Member Function Documentation

Matrix GetTransformMatrix ( ObjectProxy aLocationObject )
inline

Gets the transform matrix of a specified LocationObject

Parameters
aLocationObject The LocationObject for the bounding box
Returns
Transform Matrix of the specified LocationObject
Rect GetLocalBoundingBox ( ObjectProxy aLocationObject )
inline

Gets the local bounding box of a specific LocationObject

Parameters
aLocationObject The LocationObject for the bounding box
Returns
Rectangle containing the local coordinates of the system bounding box
Rect GetTransformedBoundingBox ( ObjectProxy aLocationObject )
inline

Gets the transformed bounding box of a specific LocationObject

Parameters
aLocationObject The LocationObject for the transformed bounding box
Returns
Rectangle containing the transformed coordinates of the system bounding box
List<Point> GetLocalVertices ( ObjectProxy aLocationObject )
inline

Gets a list of points containing the coordinates for the local vertices

Parameters
aLocationObject The LocationObject for the local vertices
Returns
List of points for the local vertices
List<Point> GetTransformedVertices ( ObjectProxy aLocationObject )
inline

Gets a list of points containing the coordinates for the transformed vertices

Parameters
aLocationObject The LocationObject for the transformed vertices
Returns
List of points for the Transformed Vertices
Point GetPosition ( ObjectProxy aLocationObject )
inline

Gets the position of a specific LocationObject

Parameters
aLocationObject The specified LocationObject for the position
Returns
Point containing the coordinates of the position of the LocationObject
void SetPosition | ( | ObjectProxy | aLocationObject,
 |  | Point | aNewPosition
 | ) |  |
inline

Sets the position of a LocationObject to a new point

Parameters
aLocationObject | The LocationObject you want to move
aNewPosition | Point containing the coordinates for the new position
void ResetTransformation ( ObjectProxy aLocationObject )
inline

Resets the transformation for a specified LocationObject. Sets the rotation to 0.0, the TransformXAxis to 1.0/0.0 and the TransformYAxis to 0.0/1.0

Parameters
aLocationObject The specified LocationObject to reset
void SimplifyPath | ( | ObjectProxy | aPath,
 |  | double | aTolerance = -1
 | ) |  |
inline

Simplifies the path of a specified shape, thus reducing the points count along the path with a specified tolerance.

Parameters
aPath | The specified path to simplify
aTolerance | The specified tolerance to reduce the points count with. Value is set to -1 by default
void PolygonToRectangle ( ObjectProxy aZone )
inline

Converts a specified zone from a polygon to a rectangle

Parameters
aZone The specified ZoneObject to convert
void PolygonToCircle ( ObjectProxy aZone )
inline

Converts a specified zone from a polygon to a circle

Parameters
aZone The specified ZoneObject to convert
void CircleToRectangle ( ObjectProxy aZone )
inline

Converts a specified zone from a circle to a rectangle

Parameters
aZone The specified ZoneObject to convert
void CircleToPolygon | ( | ObjectProxy | aZone,
 |  | int | aNumPoints = 72
 | ) |  |
inline

Converts a specified zone from a circle to a polygon

Parameters
aZone | The specified ZoneObject to convert
aNumPoints | Int value to specify the number of points used. Default value is set to 72
ObjectProxy CreateAnchor | ( | ObjectProxy | aLocationObject,
 |  | Point | aPosition
 | ) |  |
inline

Creates an anchor of a specified LocationObject at a specified position

Parameters
aLocationObject | The specified LocationObject to create the anchor for
aPosition | The specified point at which the anchor is to be created
void RemoveAnchor ( ObjectProxy aAnchor )
inline

Deletes a specified anchor

Parameters
aAnchor The anchor to be deleted
void RemoveAllAnchors ( ObjectProxy aAnchoredObject )
inline

Removes all anchors of a specified AnchoredObjects

Parameters
aAnchoredObject The specified AnchoredObject to remove the anchors from
void ClearCropRect ( ObjectProxy aLocationImage )
inline

Resets the cropping of a specified LocationImage

Parameters
aLocationImage The specified LocationImage the cropping is to be reset for
void ResetAspectHorizontal ( ObjectProxy aLocationImage )
inline

Resets the aspect ratio of a specified LocationImage in horizontal mode

Parameters
aLocationImage The LocationImage of which the aspect ratio is to be reset for
void ResetAspectVertical ( ObjectProxy aLocationImage )
inline

Resets the aspect ratio of a specified LocationImage in vertical mode

Parameters
aLocationImage The LocationImage of which the aspect ratio is to be reset for
Rect GetImageCropRect ( ObjectProxy aLocationImage )
inline

Gets the cropping rectangle of a specified LocationImage

Parameters
aLocationImage The specified LocationImage to get the cropping rectangle of
Returns
Cropping Rectangle containing the coordinates for the cropping area
void SetImageCropRect | ( | ObjectProxy | aLocationImage,
 |  | Rect | aCropRect
 | ) |  |
inline

Sets the cropping rectangle of a specified LocationImage with a specified rectangle. The cropping coordinates are from 0.0 to 1.0 for each axis

Parameters
aLocationImage | The specified LocationImage the cropping rectangle is to be set for
aCropRect | The specified cropping rectangle to be set
void SetImage | ( | ObjectProxy | aLocationImage,
 |  | ObjectProxy | aImageAsset
 | ) |  |
inline

Assigns a specified image asset to a specified LocationImage object

Parameters
aLocationImage | The specified LocationImage object
aImageAsset | The specified image asset to be set
BitmapSource GetLocationBitmap ( Size aMaxSize )
inline

Gets the rendered bitmap for the current location with a specified maxmimum size

Parameters
aMaxSize The specified maximum size the bitmap is to be rendered in
Returns
BitmapSource of the rendered location in the specified size
void SaveLocationAsJpeg | ( | string | aFilename,
 |  | Size | aMaxSize,
 |  | int | aJpegQuality = 90
 | ) |  |
inline

Saves the current location as a jpeg file with a specified filename, a maximum size and a specified quality level

Parameters
aFilename | The specified filename for the jpeg file
aMaxSize | The specified maximum size for the image
aJpegQuality | The specified quality level of the image. Default value is set to 90
void SaveLocationAsPng | ( | string | aFilename,
 |  | Size | aMaxSize
 | ) |  |
inline

Saves the current location as a png file with a specified filename and a maximum size

Parameters
aFilename | The specified filename for the png file
aMaxSize | The specified maximum size for the image
void SaveLocationAsXps ( string aFilename )
inline

Saves the current location as an xps file with a specified filename

Parameters
aFilename The specified filename for the xps file
Transformer CreateTransformer ( )
inline

Creates a transformer object to enable transformation mode for LocationObjects

Returns
Transformer object containing the location and its objects


articy:draft API: ApiSession Class Reference

  • Api
  • ApiSession
Public Member Functions | Properties | List of all members
ApiSession Class Reference

Once the session is created successfully, all further API calls are invoked on this session object. More...

Inheritance diagram for ApiSession:

Public Member Functions

void | Dispose ()
Dispose the session object. More...
ApiJourneyBuilder | StartJourneyOn (ObjectProxy aStartObject)
ApiLocationTools | GetLocationToolsFor (ObjectProxy aLocationObject)
Create an ApiLocationTool object More...
void | DeleteObject (ObjectProxy aObject)
Deletes the given object and all its dependencies. More...
ObjectProxy | CloneObject (ObjectProxy aObject, ObjectProxy aParent)
Creates a deep copy of the given object, i.e. all children of that object will be copied, too. More...
ObjectProxy | CloneChildren (ObjectProxy aObject, ObjectProxy aParent)
Link CloneObject, but clones all children of aObject instead of just aObject. aObject itself is not cloned. Connections from a child to aObject are not cloned as they cannot necessarily be connected to aParent. More...
void | MoveObject (ObjectProxy aObject, ObjectProxy aNewParent)
Moves the given object into the given target/parent container. The new parent must already be claimed and must allow the given object. Cross partition moves will also fail More...
void | MoveObjects (List< ObjectProxy > aObjects, ObjectProxy aNewParent)
Moves the given objects into the given target/parent container The new parent must already be claimed and must allow the given objects. Cross partition moves will also fail More...
List< FlowListNode > | LinearizeFlowSegment (ObjectProxy aStartingElement, FlowToListTraversalType aTraversalType, int aMaxDepth=0, bool aIncludeUnconnected=true)
Create a linear list of a possible branching flow subtree. Tries to keep connected parts together and in linear order. Provides More...
void | SetActionLog (CollaborativeActionBase aAction, ComplexApiCallArgs aArgs)
void | SetActionLog (CollaborativeActionBase aAction, string aLogSourceName)
project handling related

Methods for opening, closing and working with articy:draft projects.

void | OpenProject (OpenProjectArgs aArgs)
Once logged into an articy:server successfully, open a project using this method. More...
void | CloseProject (CloseProjectArgs aArgs)
Closes the currently opened project. More...
void | SaveProject ()
Once retrieved objects have been changed via this API, calling this method causes the changes to be written to the local project folder. More...
void | PublishProject ()
Saves the project and publishes all partitions that are claimed and contain changes. The partitions will stay claimed. More...
void | ExportData (GenericExportDataArgs aArgs)
This method starts an export with a generic XML based parameter descriptor. More...
void | ExportData (ExportDataArgs aArgs)
Starts an export using the information given in the specialized ExportDataArgs descriptor More...
string | GetExportSettings (ExportDataArgs aArgs)
Gets the XML version of the export settings More...
GenericExportDataArgs | LoadExportPreset (string aPresetDisplayName, ExporterNames aExporterName)
Loads a export preset and constructs a ExportArgs class that can be used with ExportData. You should add the selected objects, set up the Log source an may override the filename paramter. More...
void | ExportDocument (ObjectProxy aDocument, string aFilename)
Exports a document objects using the specific document export. Uses all the defaults from the ExportDocumentToDocxArgs A valid output filename must be given More...
void | ExportDocument (ObjectProxy aDocument, ExportDocumentToDocxArgs aArgs)
Exports a document objects using the specific document export More...
Simple search (like in navigator)
List< ObjectProxy > | SimpleFindObjects (string aTextToSearch)
The simplest form of the search. Searches if any text contains the given string. (not case-sensitive) Search is started at the project root node. More...
List< ObjectProxy > | SimpleFindObjects (ulong aSearchRoot, string aTextToSearch)
Searches if any text contains the given string starting at a given node. (not case-sensitive) More...
List< ObjectProxy > | SimpleFindObjects (ulong aSearchRoot, string aTextToSearch, TextFilterRelation aRelation, SearchTextIn aWhereToSearch, bool aCaseSensitive)
Searches if a text matches under the given compare operator. More...
List< ObjectProxy > | SimpleFindConflicts (ulong aSearchRoot, SearchConflictsIn aWhereToSearch)
Searches the project for object that have conflicts. More...
Methods for direct object access
ObjectProxy GetProjectRoot ()
Gets the projects root object. More...
ObjectProxy | GetObjectById (ulong aId)
Gets an an object whose ID is known. More...
ObjectProxy | GetObjectByTechName (string aTechnicalName)
Gets an object whose technical name is known. More...
ObjectProxy | GetVariableSetByName (string aName)
Gets a variable set with the given name. More...
ObjectProxy | GetSystemFolder (SystemFolderNames aFolderName)
Gets on "system folder" object More...
ulong | GetSystemFolderId (SystemFolderNames aFolderName)
Gets the ID of a system folder More...
query related
ResultSet | RunQuery (string aQuery)
Searches the opened project for articy objects. More...
ResultSet | RunQuery (string aQuery, ObjectProxy aSelfReference)
Searches the opened project for articy objects. More...
asset related

The following methods are use to modify/change assets and to ensure the asset background processes are finished to be able to close the project or unclaim a partition.

The respective methods already call the WaitForAssetProcessing internally, But you should use it by yourself when you want to ensure that all Thumbnails or images are fully processed before starting an DOCX export that adds thumbnail images to the document.

bool | WaitForAssetProcessing (WaitForAssetProcessingArgs aArgs)
Blocking call that waits until the asset system has processed all assets. This has to be completed before partitions can be published or the exclusive mode can be left. After claiming a partition, opening a project in exclusive mode and importing assets, the asset system starts checking the status of each corresponding asset. More...
bool | WaitForAssetProcessing (WaitForAssetProcessingArgs aArgs, IList< String > aMissingAssetFiles)
Blocking call that waits until the asset system has processed all assets. This has to be completed before partitions can be published or the exclusive mode can be left. After claiming a partition, opening a project in exclusive mode and importing assets, the asset system starts checking the status of each corresponding asset. More...
void | ReimportAsset (ObjectProxy aAsset)
Schedules an re-import of an asset from its "OriginalSource" filename. More...
void | ChangeAsset (ObjectProxy aAsset, string aFullFilename)
Schedules an re-import of an asset from a new filename (Change asset source). More...
object creation

The following object creation methods provide overloads for the following cases:

  • The parent is an already known ObjectProxy or only the ID of the Parent is known
  • You want to directly add a template to the newly created object.

The overloads that allow a template technical name also can be used to create an object without template. Just use null or String.Empty for the template parameter.

Providing null or String.Empty for the display name will create objects with the default display name as it is also done in the GUI.

ObjectProxy | CreateFolder (ulong aParentId, string aDisplayName)
Creates a new user folder within the articy project tree. More...
ObjectProxy | CreateFolder (ObjectProxy aParent, string aDisplayName)
Creates a new user folder within the articy project tree. More...
ObjectProxy | CreateEntity (ulong aParentId, string aDisplayName)
Creates a new entity object in the articy project tree. More...
ObjectProxy | CreateEntity (ObjectProxy aParent, string aDisplayName)
Creates a new entity object in the articy project tree. More...
ObjectProxy | CreateEntity (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new entity object in the articy project tree. More...
ObjectProxy | CreateEntity (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new entity object in the articy project tree. More...
ObjectProxy | CreateLocation (ulong aParentId, string aDisplayName)
Creates a new location object in the articy project tree. More...
ObjectProxy | CreateLocation (ObjectProxy aParent, string aDisplayName)
Creates a new location object in the articy project tree. More...
ObjectProxy | CreateLocation (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new location object in the articy project tree. More...
ObjectProxy | CreateLocation (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new location object in the articy project tree. More...
ObjectProxy | CreateLocationGroup (ulong aParentId, string aDisplayName)
Creates a new location group within in an existing location or location group. More...
ObjectProxy | CreateLocationLayerFolder (ObjectProxy aParent, string aDisplayName)
Creates a new location layer folder within in an existing location or location layer folder. More...
ObjectProxy | CreateLink (ulong aParentId, Point aPosition)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ObjectProxy aParent, Point aPosition)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ulong aParentId, string aTemplateTechName, Point aPosition)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ObjectProxy aParent, string aTemplateTechName, Point aPosition)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ulong aParentId, string aTemplateTechName, Point aPosition, ObjectProxy aReferencedModel)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ulong aParentId, string aTemplateTechName, Point aPosition, ulong aReferencedModelId)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ObjectProxy aParent, string aTemplateTechName, Point aPosition, ObjectProxy aReferencedModel)
Creates a new link inside a location. More...
ObjectProxy | CreateLink (ObjectProxy aParent, string aTemplateTechName, Point aPosition, ulong aReferencedModelId)
Creates a new link inside a location. More...
ObjectProxy | CreateSpot (ulong aParentId, string aDisplayName, Point aPosition)
Creates a new spot inside a location. More...
ObjectProxy | CreateSpot (ObjectProxy aParent, string aDisplayName, Point aPosition)
Creates a new spot inside a location. More...
ObjectProxy | CreateSpot (ulong aParentId, string aDisplayName, string aTemplateTechName, Point aPosition)
Creates a new spot inside a location. More...
ObjectProxy | CreateSpot (ObjectProxy aParent, string aDisplayName, string aTemplateTechName, Point aPosition)
Creates a new spot inside a location. More...
ObjectProxy | CreateZoneRect (ulong aParentId, string aDisplayName, Rect aRect)
Creates a new rectangular zone inside a location. More...
ObjectProxy | CreateZoneRect (ObjectProxy aParent, string aDisplayName, Rect aRect)
Creates a new rectangular zone inside a location. More...
ObjectProxy | CreateZoneRect (ulong aParentId, string aDisplayName, string aTemplateTechName, Rect aRect)
Creates a new rectangular zone inside a location. More...
ObjectProxy | CreateZoneRect (ObjectProxy aParent, string aDisplayName, string aTemplateTechName, Rect aRect)
Creates a new rectangular zone inside a location. More...
ObjectProxy | CreateLocationImage (ulong aParentId, string aDisplayName, Point aTopLeft, ulong aImageAssetId)
Creates a new image inside a location. More...
ObjectProxy | CreateLocationImage (ObjectProxy aParent, string aDisplayName, Point aTopLeft, ObjectProxy aImageAsset)
Creates a new image inside a location. More...
ObjectProxy | CreateLocationImage (ulong aParentId, string aDisplayName, Point aTopLeft, ulong aImageAssetId, string aTemplateTechName)
Creates a new image inside a location. More...
ObjectProxy | CreateLocationImage (ObjectProxy aParent, string aDisplayName, Point aTopLeft, ObjectProxy aImageAsset, string aTemplateTechName)
Creates a new image inside a location. More...
ObjectProxy | CreateLocationText (ulong aParentId, Point aTopLeft, string aText, double aWidth, double aHeight)
Creates a new text inside a location. More...
ObjectProxy | CreateLocationText (ObjectProxy aParent, Point aTopLeft, string aText, double aWidth, double aHeight)
Creates a new text inside a location. More...
ObjectProxy | CreateLocationText (ulong aParentId, Point aTopLeft, string aText, double aWidth, double aHeight, string aTemplateTechName)
Creates a new text inside a location. More...
ObjectProxy | CreateLocationText (ObjectProxy aParent, Point aTopLeft, string aText, double aWidth, double aHeight, string aTemplateTechName)
Creates a new text inside a location. More...
ObjectProxy | CreateZoneCircle (ulong aParentId, string aDisplayName, Point aCenter, double aRadius)
Creates a new spherical zone inside a location. More...
ObjectProxy | CreateZoneCircle (ObjectProxy aParent, string aDisplayName, Point aCenter, double aRadius)
Creates a new spherical zone inside a location. More...
ObjectProxy | CreateZoneCircle (ulong aParentId, string aDisplayName, string aTemplateTechName, Point aCenter, double aRadius)
Creates a new spherical zone inside a location. More...
ObjectProxy | CreateZoneCircle (ObjectProxy aParent, string aDisplayName, string aTemplateTechName, Point aCenter, double aRadius)
Creates a new spherical zone inside a location. More...
ObjectProxy | CreateZonePolygon (ulong aParentId, string aDisplayName, params Point[] aVertices)
Creates a new custom-shaped zone inside a location. More...
ObjectProxy | CreateZonePolygon (ObjectProxy aParent, string aDisplayName, params Point[] aVertices)
Creates a new custom-shaped zone inside a location. More...
ObjectProxy | CreateZonePolygon (ulong aParentId, string aDisplayName, string aTemplateTechName, params Point[] aVertices)
Creates a new custom-shaped zone inside a location. More...
ObjectProxy | CreateZonePolygon (ObjectProxy aParent, string aDisplayName, string aTemplateTechName, params Point[] aVertices)
Creates a new custom-shaped zone inside a location. More...
ObjectProxy | CreatePath (ulong aParentId, string aDisplayName, params Point[] aVertices)
Creates a new path inside a location. More...
ObjectProxy | CreatePath (ObjectProxy aParent, string aDisplayName, params Point[] aVertices)
Creates a new path inside a location. More...
ObjectProxy | CreatePath (ulong aParentId, string aDisplayName, string aTemplateTechName, params Point[] aVertices)
Creates a new path inside a location. More...
ObjectProxy | CreatePath (ObjectProxy aParent, string aDisplayName, string aTemplateTechName, params Point[] aVertices)
Creates a new path inside a location. More...
ObjectProxy | CreateFlowFragment (ulong aParentId, string aDisplayName)
Creates a new flow fragment in the flow area. More...
ObjectProxy | CreateFlowFragment (ObjectProxy aParent, string aDisplayName)
Creates a new flow fragment in the flow area. More...
ObjectProxy | CreateFlowFragment (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new flow fragment in the flow area. More...
ObjectProxy | CreateFlowFragment (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new flow fragment in the flow area. More...
ObjectProxy | CreateDialogue (ulong aParentId, string aDisplayName)
Creates a new dialogue in the flow area. More...
ObjectProxy | CreateDialogue (ObjectProxy aParent, string aDisplayName)
Creates a new dialogue in the flow area. More...
ObjectProxy | CreateDialogue (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new dialogue in the flow area. More...
ObjectProxy | CreateDialogue (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new dialogue in the flow area. More...
ObjectProxy | CreateDialogueFragment (ulong aParentId, string aText)
Creates a new dialogue fragment inside a dialog. More...
ObjectProxy | CreateDialogueFragment (ObjectProxy aParent, string aText)
Creates a new dialogue fragment inside a dialog. More...
ObjectProxy | CreateDialogueFragment (ulong aParentId, string aText, string aTemplateTechName)
Creates a new dialogue fragment inside a dialog. More...
ObjectProxy | CreateDialogueFragment (ObjectProxy aParent, string aText, string aTemplateTechName)
Creates a new dialogue fragment inside a dialog. More...
ObjectProxy | CreateJump (ulong aParentId, string aDisplayName)
Creates a new jump in the flow area. More...
ObjectProxy | CreateJump (ObjectProxy aParent, string aDisplayName)
Creates a new jump in the flow area. More...
ObjectProxy | CreateJump (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new jump in the flow area. More...
ObjectProxy | CreateJump (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new jump in the flow area. More...
ObjectProxy | CreateHub (ulong aParentId, string aDisplayName)
Creates a new hub in the flow area. More...
ObjectProxy | CreateHub (ObjectProxy aParent, string aDisplayName)
Creates a new hub in the flow area. More...
ObjectProxy | CreateHub (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new hub in the flow area. More...
ObjectProxy | CreateHub (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new hub in the flow area. More...
ObjectProxy | CreateCondition (ulong aParentId, string aDisplayName)
Creates a new condition node in the flow area. More...
ObjectProxy | CreateCondition (ObjectProxy aParent, string aDisplayName)
Creates a new condition node in the flow area. More...
ObjectProxy | CreateCondition (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new condition node in the flow area. More...
ObjectProxy | CreateCondition (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new condition node in the flow area. More...
ObjectProxy | CreateInstruction (ulong aParentId, string aDisplayName)
Creates a new instruction node in the flow area. More...
ObjectProxy | CreateInstruction (ObjectProxy aParent, string aDisplayName)
Creates a new instruction in the flow area. More...
ObjectProxy | CreateInstruction (ulong aParentId, string aDisplayName, string aTemplateTechName)
Creates a new instruction in the flow area. More...
ObjectProxy | CreateInstruction (ObjectProxy aParent, string aDisplayName, string aTemplateTechName)
Creates a new instruction in the flow area. More...
ObjectProxy | CreateVariableSet (String aScriptingName, String aDescription="")
Creates a new variable set in the "Global Variables" system folder. More...
ObjectProxy | CreateGlobalVariable (ObjectProxy aParentVariableSet, String aScriptingName, VariableType aType=VariableType.Boolean, String aDescription="")
Creates a new variable in the given variable set with the given type. More...
ObjectProxy | CreateGlobalVariable (String aParentVariableSetName, String aScriptingName, VariableType aType=VariableType.Boolean, String aDescription="")
Creates a new variable in the given variable set with the given type. More...
ObjectProxy | CreateGlobalVariable (ObjectProxy aParentVariableSet, String aScriptingName, bool aDefaultValue, String aDescription="")
Creates a new boolean variable in the given namespace with the given type. More...
ObjectProxy | CreateGlobalVariable (ObjectProxy aParentVariableSet, String aScriptingName, int aDefaultValue, String aDescription="")
Creates a new integer variable in the given namespace with the given type. More...
ObjectProxy | CreateGlobalVariable (String aParentVariableSetName, String aScriptingName, bool aDefaultValue, String aDescription="")
Creates a new boolean variable in the given namespace with the given type. More...
ObjectProxy | CreateGlobalVariable (String aFullQualifiedName, bool aDefaultValue, out ObjectProxy aNamespace, string aVariableDescription="")
Creates a new boolean variable via a full qualified name. If the supplied namespace doesn't exist, it will be created. More...
ObjectProxy | CreateGlobalVariable (String aFullQualifiedName, int aDefaultValue, out ObjectProxy aNamespace, string aVariableDescription="")
Creates a new integer variable via a full qualified name. If the supplied namespace doesn't exist, it will be created. More...
ObjectProxy | CreateGlobalVariable (String aFullQualifiedName, bool aDefaultValue, string aVariableDescription="")
Creates a new boolean variable via a full qualified name. If the supplied namespace doesn't exist, it will be created. More...
ObjectProxy | CreateGlobalVariable (String aFullQualifiedName, int aDefaultValue, string aVariableDescription="")
Creates a new integer variable via a full qualified name. If the supplied namespace doesn't exist, it will be created. More...
ObjectProxy | CreateGlobalVariable (String aParentVariableSetName, String aScriptingName, int aDefaultValue, String aDescription="")
Creates a new integer variable in the given variable set with the given type. More...
ObjectProxy | GetGlobalVariable (string aFullQualifiedName)
Gets a global variable whose full qualified name, namespace & variable name, is known. For example "game.IsRunning" More...
ObjectProxy | GetGlobalVariable (ObjectProxy aParentVariableSet, String aScriptingName)
Fetches a variable from a given VariableSet More...
ObjectProxy | GetGlobalVariable (string aVariableSetName, string aScriptingName)
Fetches a variable from a given VariableSet More...
List< ObjectProxy > | RefactorVariableReferences (ObjectProxy aVariableOrSet, bool aOnlyStrayReferences=true)
Searches expression fields for variable that are named like a certain variable but not actually linked to it. A so called stray variable reference is created when a variable is deleted while still in use by an expression field. When creating a new variable by the same name, that old reference is weak-linked to the new variable by its name. Stray references will not react on renaming or moving unless they are linked to the actual variable by using this function. Expression fields containing such stray variables will be modified and are claimed during the course of this function. Objects in partitions that are claimed by other users will be ignored. The affected partitions will not be unclaimed automatically. More...
ObjectProxy | CreateDocument (ulong aParentId, String aDisplayName, String aTemplateTechName=null)
Creates a new Document object as child of the given parent More...
ObjectProxy | CreateDocument (ObjectProxy aParent, String aDisplayName, String aTemplateTechName=null)
Creates a new Document object as child of the given parent More...
ObjectProxy | CreateDocumentText (ulong aContextElementId, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null)
Adds a new Text section to a document More...
ObjectProxy | CreateDocumentText (ObjectProxy aContextElement, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null)
Adds a new Text section to a document More...
ObjectProxy | CreateDocumentDialogue (ulong aContextElementId, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null)
Adds a new dialogue section to a document More...
ObjectProxy | CreateDocumentDialogue (ObjectProxy aContextElement, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null)
Adds a new dialogue section to a document More...
ObjectProxy | CreateDocumentImage (ulong aContextElementId, HierarchyAdjustment aHierarchy, ulong aImageAsset=0LU, String aText="", String aTemplateTechName=null)
Adds a new image section to a document More...
ObjectProxy | CreateDocumentImage (ObjectProxy aContextElement, HierarchyAdjustment aHierarchy, ObjectProxy aImageAsset=null, String aText="", String aTemplateTechName=null)
Adds a new image section to a document More...
ObjectProxy | ImportAsset (ulong aParentId, String aDisplayName, string aAssetFullFilename)
Imports the specified file and creates a new asset object. More...
ObjectProxy | ImportAsset (ObjectProxy aParent, String aDisplayName, string aAssetFullFilename)
Imports the specified file and creates a new asset object. More...
ObjectProxy | ImportAsset (ulong aParentId, String aDisplayName, string aAssetFullFilename, string aTemplateTechName)
Imports the specified file and creates a new asset object. More...
ObjectProxy | ImportAsset (ObjectProxy aParent, String aDisplayName, string aAssetFullFilename, string aTemplateTechName)
Imports the specified file and creates a new asset object. More...
ObjectProxy | ConnectPins (ObjectProxy aOutPin, ObjectProxy aInPin)
Creates a connection between two pins. This function will throw an exception if the connection cannot be created, e.g. when the pins are on different hierarchy levels. More...

Properties

bool | ExclusivelyOpen [get]
returns true when a project is exclusively open, false otherwise More...
bool | ProjectOpen [get]
returns true when a project is currently open, false otherwise More...

articy:server related

The following methods provide the required housekeeping methods for articy:server

void | ConnectToServer (string aHost, int aPort)
Connects to an articy:server More...
void | DisconnectServer ()
Disconnects your application from the currently connected articy:server. More...
void | Login (string aUserName, string aPassword)
Logs a user in to the connected articy:server More...
void | Logout ()
Before logging into as another user, use this method to logout from the articy:server. More...
bool | IsConnected ()
returns true if an active connection to the articy:server exists More...
bool | IsLoggedIn ()
returns true if a user is logged in to the current articy:server More...
List< UserInfo > | GetUsers (bool aForceRequest=false)
Requests the list of all users within the current project from the server. This list is cached in the session for about 5 minutes, but may be forced to be re-read More...
UserInfo | GetUser (Guid aUserGuid, bool aForceRequest=false)
Get a record of a specific user within the project from the server This list this record is fetched from is cached in the session for about 5 minutes, but may be forced to be re-request More...
List< ProjectInfo > | GetProjectList ()
Once logged into an articy:server successfully, a list of available projects can be queried using this method. More...

Partition handling

List< PartitionInfo > | GetPartitionInfos ()
Requests a list of the opened project's partitions and their current states. More...
PartitionInfo | GetPartitionInfo (Guid aPartition)
Request the information object for a single partition. More...
void | ClaimPartition (Guid aPartitionGuid)
Before making any changes to articy objects, your program needs to claim the partition the object in question resides in. More...
void | ClaimPartition (SimplePartitionActionArgs aArgs)
Before making any changes to articy objects, the external program needs to claim the partition the object in question resides in. More...
void | ClaimPartitions (List< ObjectProxy > aObjects)
Claims all distinct partitions required for the given list of objects. More...
void | ClaimPartitions (List< ObjectProxy > aObjects, string aLogName)
Claims all distinct partitions required for the given list of objects. More...
void | ClaimPartitions (List< ObjectProxy > aObjects, string aLogName, ref List< Guid > aClaimedPartitions, ref Dictionary< Guid, Exception > aFailedPartitions)
Claims all distinct partitions required for the given list of objects. More...
void | UnclaimPartition (Guid aPartitionGuid)
Unclaims a single partition which is given by its Guid. More...
void | UnclaimPartition (UnclaimPartitionArgs aArgs)
Unclaims a single partition which is given by its Guid. More...
void | UnclaimPartitions (List< Guid > aPartitionGuids)
Unclaims all partitions in the list of partition guids in one single transaction More...
void | UnclaimPartitions (List< Guid > aPartitionGuids, UnclaimPartitionArgs aArgs)
Unclaims all partitions in the list of partition guids in one single transaction More...
void | UnclaimAllMyPartitions ()
Unclaims all partitions the currently logged-in user has claimed. More...
void | UnclaimAllMyPartitions (UnclaimPartitionArgs aArgs)
Unclaims all partitions the currently logged in user has claimed More...
void | ForcefullyUnclaimPartition (Guid aPartitionGuid)
Forcefully unclaims a partition that was claimed by another user. More...
void | ForcefullyUnclaimPartition (SimplePartitionActionArgs aArgs)
Forcefully unclaims a partition that was claimed by another user. More...
void | DiscardChangesToPartition (Guid aPartitionGuid)
Discard changes in a single partition which is given by its Guid. More...
void | DiscardChangesToPartition (SimplePartitionActionArgs aArgs)
Discard changes in a single partition which is given by its Guid. More...
void | UpdatePartition (Guid aPartitionGuid)
Updates the given partition. More...
void | UpdatePartition (SimplePartitionActionArgs aArgs)
Updates the given partition. Using this overload you can add the output to a log More...
void | UpdatePartitions (List< Guid > aPartitionGuids)
Updates all partitions in the given list. Is just a convenience method that calls the UpdatePartition method for each guid More...
void | UpdatePartitions (List< Guid > aPartitionGuids, string aLogSourceName)
Updates all partitions in the given list. Is just a convenience method that calls the UpdatePartition method for each guid More...
void | Repartition (IList< ObjectProxy > aObjects, RepartitionMode aMode, bool aKeepPartitons=false)
Changes the partition configuration of a project. The changes will be published and the project will be saved during this function. Only certain objects can be passed to this function. Invalid objects will cause an exception. See ObjectProxy.CanBePartitioned. More...

Detailed Description

Once the session is created successfully, all further API calls are invoked on this session object.

Member Function Documentation

void Dispose ( )
inline

Dispose the session object.

This method automatically tries to close an open project and disconnects from a potential connected server. When a project is opened exclusively the exclusive mode remains intact. This behavior was chosen to cope with scope loss scenarios in case of an exception that was not handled. Under normal instructions you should already called the CloseProject & Disconnect methods yourself.

void ConnectToServer | ( | string | aHost,
 |  | int | aPort
 | ) |  |
inline

Connects to an articy:server

Parameters
aHost | This is the name of the computer that runs the articy:server.
aPort | The port, the articy:server is listening on. By default this is 16707.

Just like when working with the articy:draft GUI your program needs to connect to an articy:server. You will be disconnected from a previous server when this method is called in a connected state.

void DisconnectServer ( )
inline

Disconnects your application from the currently connected articy:server.

Before connecting to a different server, disconnect from the current server using this method. This method simply returns if not currently connected.

void Login | ( | string | aUserName,
 |  | string | aPassword
 | ) |  |
inline

Logs a user in to the connected articy:server

Parameters
aUserName | The name of the user account. Ask your articy:server administrator for account credentials.
aPassword | The password of the user account.
Exceptions
ArticyApiException NotConnected is thrown when you are not connected to an articy:server

Once the connection to an articy:server has been established successfully, your program needs to login. In order to achieve this, the username and password of a regular articy:draft user is needed. All limitations that apply to this user (available projects, rights within the projects) also apply to your program using this user account.

void Logout ( )
inline

Before logging into as another user, use this method to logout from the articy:server.

bool IsConnected ( )
inline

returns true if an active connection to the articy:server exists

Returns
bool IsLoggedIn ( )
inline

returns true if a user is logged in to the current articy:server

Returns
List<UserInfo> GetUsers ( bool aForceRequest = false )
inline

Requests the list of all users within the current project from the server. This list is cached in the session for about 5 minutes, but may be forced to be re-read

Parameters
aForceRequest true if you want to enforce a server request
Returns
UserInfo GetUser | ( | Guid | aUserGuid,
 |  | bool | aForceRequest = false
 | ) |  |
inline

Get a record of a specific user within the project from the server This list this record is fetched from is cached in the session for about 5 minutes, but may be forced to be re-request

Parameters
aUserGuid | The guid of the user of interest
aForceRequest | true to force a server request and don't allow an answer from the cache
Returns
the user record or null if the user does not exist.
List<ProjectInfo> GetProjectList ( )
inline

Once logged into an articy:server successfully, a list of available projects can be queried using this method.

Returns
a list of ProjectInfo objects describing the found objects

Only those projects are listed that are available to the account that was used for Login.

void OpenProject ( OpenProjectArgs aArgs )
inline

Once logged into an articy:server successfully, open a project using this method.

Parameters
aArgs This is a data object containing all available parameters. See OpenProjectArgs for more info.
void CloseProject ( CloseProjectArgs aArgs )
inline

Closes the currently opened project.

Parameters
aArgs Parameter object containing additional information

Does nothing if no project is currently opened. May be used to close the project without leaving the exclusive mode for that project.

void SaveProject ( )
inline

Once retrieved objects have been changed via this API, calling this method causes the changes to be written to the local project folder.

Most partition handling methods of this API call this method implicitly upfront. However, if you may want to save changes on your own use this method.

void PublishProject ( )
inline

Saves the project and publishes all partitions that are claimed and contain changes. The partitions will stay claimed.

void ExportData ( GenericExportDataArgs aArgs )
inline

This method starts an export with a generic XML based parameter descriptor.

Parameters
aArgs The instance of an specialized "ExportTo...Args" helper object containing the parameters for each of the supported exports.

You can generate such a XML descriptor text by using GetExportSettings with a given specialized export args object. The configuration must be set as TextConfiguration.

The Filename in the aArgs parameter overrides a possibly present filename if the XML configuration if it contains a non empty or non null string.

void ExportData ( ExportDataArgs aArgs )
inline

Starts an export using the information given in the specialized ExportDataArgs descriptor

Parameters
aArgs a descendant of ExportDataArgs (e.g. like ExportToXlsxArgs)

Look at the ExportTo...Args to get a documentation of parameters for each export. You may look at the descendants of ExportDataArgs to find them.

string GetExportSettings ( ExportDataArgs aArgs )
inline

Gets the XML version of the export settings

Parameters
aArgs the export data args for a specific export
Returns
a string containing an XML representation of the settings
GenericExportDataArgs LoadExportPreset | ( | string | aPresetDisplayName,
 |  | ExporterNames | aExporterName
 | ) |  |
inline

Loads a export preset and constructs a ExportArgs class that can be used with ExportData. You should add the selected objects, set up the Log source an may override the filename paramter.

Parameters
aPresetDisplayName | the (display-)name of the preset
aExporterName | the exporter name
Returns
a pre-filled ExportDataArgs or null when preset is not
void ExportDocument | ( | ObjectProxy | aDocument,
 |  | string | aFilename
 | ) |  |
inline

Exports a document objects using the specific document export. Uses all the defaults from the ExportDocumentToDocxArgs A valid output filename must be given

Parameters
aDocument | the document object to export
aFilename | the filename to use for writing the file into
void ExportDocument | ( | ObjectProxy | aDocument,
 |  | ExportDocumentToDocxArgs | aArgs
 | ) |  |
inline

Exports a document objects using the specific document export

Parameters
aDocument | the document object to export
aArgs | the settings used for exporting
List<ObjectProxy> SimpleFindObjects ( string aTextToSearch )
inline

The simplest form of the search. Searches if any text contains the given string. (not case-sensitive) Search is started at the project root node.

Parameters
aTextToSearch the text to search for
Returns
a list of ObjectProxy objects that match the search criteria
List<ObjectProxy> SimpleFindObjects | ( | ulong | aSearchRoot,
 |  | string | aTextToSearch
 | ) |  |
inline

Searches if any text contains the given string starting at a given node. (not case-sensitive)

Parameters
aSearchRoot | The ID of the containter object to start the search on. Only children of this object and their children are searched. If you want to start at the very top and search the entire project, then use GetProjectRoot.
aTextToSearch | the text to search for
Returns
a list of object proxies that match the search criteria
List<ObjectProxy> SimpleFindObjects | ( | ulong | aSearchRoot,
 |  | string | aTextToSearch,
 |  | TextFilterRelation | aRelation,
 |  | SearchTextIn | aWhereToSearch,
 |  | bool | aCaseSensitive
 | ) |  |
inline

Searches if a text matches under the given compare operator.

Parameters
aSearchRoot | The ID of the container object to start the search on. Only children of this object and their children are searched. If you want to start at the very top and search the entire project, then use GetProjectRoot.
aTextToSearch | The text to search for (or the regex pattern used to search).
aRelation | This is the compare operator for the search text. The TextFilterRelation enumeration contains many operators like Contains, BeginsWith, HasValue and more.
aWhereToSearch | A flag enum where you can specify with properties should be included in the search.
aCaseSensitive | true if the search should be case sensitive, false otherwise.
Returns
a list of object proxies that match the search criteria
List<ObjectProxy> SimpleFindConflicts | ( | ulong | aSearchRoot,
 |  | SearchConflictsIn | aWhereToSearch
 | ) |  |
inline

Searches the project for object that have conflicts.

Parameters
aSearchRoot | The ID of the containter object to start the search on. Only children of this object and their children are searched. If you want to start at the very top and search the entire project, then use GetProjectRoot.
aWhereToSearch | a bit field enumeration to specify for which conflicts should be searched
Returns
a list of object proxies that match the search criteria

This is the API version of the search conflicts tab in the articy:draft client.

ObjectProxy GetProjectRoot ( )
inline

Gets the projects root object.

Returns
the object proxy for the articy object representing the project itself
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.

The ID of this object is NOT the same as the projects guid required to open it. This object only represents the root node in the object tree.

ObjectProxy GetObjectById ( ulong aId )
inline

Gets an an object whose ID is known.

Parameters
aId the ID of the object to get
Returns
either the object proxy or null when the model is not known
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.
ObjectProxy GetObjectByTechName ( string aTechnicalName )
inline

Gets an object whose technical name is known.

Parameters
aTechnicalName the technical name of the object as it can be found in the property view in articy:draft
Returns
either the object proxy or null when the object is not known or the technical name is not unique
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.
ObjectProxy GetVariableSetByName ( string aName )
inline

Gets a variable set with the given name.

Parameters
aName the name of the variable set.
Returns
either the object proxy or null when the variable set is not known
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.
ObjectProxy GetSystemFolder ( SystemFolderNames aFolderName )
inline

Gets on "system folder" object

Parameters
aFolderName One of the predefined system folder identifiers
Returns
an object proxy to the requested system folder
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.
ulong GetSystemFolderId ( SystemFolderNames aFolderName )
inline

Gets the ID of a system folder

Parameters
aFolderName One of the predefined system folder identifiers
Returns
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.
List<PartitionInfo> GetPartitionInfos ( )
inline

Requests a list of the opened project's partitions and their current states.

Returns
the list of partition info objects

Keep in mind that the information in the partition info objects are volatile. Claiming/unclaiming operations of other connected clients may change these information any time.

PartitionInfo GetPartitionInfo ( Guid aPartition )
inline

Request the information object for a single partition.

Parameters
aPartition the Guid of the partition to request the information for
Returns
the information object for the requested partition

Only available for open projects

Keep in mind that the information in the partition info objects are volatile. Claiming/unclaiming operations of other connected clients may change these information any time.

void ClaimPartition ( Guid aPartitionGuid )
inline

Before making any changes to articy objects, your program needs to claim the partition the object in question resides in.

Parameters
aPartitionGuid The Guid of the partition, the to-be-changed-objects resides in.

You can query this Guid by using the method ObjectProxy.GetPartitionId or take it from a PartitionInfo object.

If the partition is already claimed this method returns very fast but without an error. So it is safe and sound to preventively call ClaimPartition() before making a change to an ObjectProxy This overload does not support progress logging

void ClaimPartition ( SimplePartitionActionArgs aArgs )
inline

Before making any changes to articy objects, the external program needs to claim the partition the object in question resides in.

Parameters
aArgs An args record that contains the Guid of the partition, the to-be-changed-objects resides in, and the LogSourceName to be used for logging

You can query this Guid by using the method ObjectProxy.GetPartitionId or take it from a PartitionInfo object.

If the partition is already claimed this method returns very fast but without an error. So it is safe and sound to preventively call ClaimPartition() before making a change to an ObjectProxy.

void ClaimPartitions ( List< ObjectProxy > aObjects )
inline

Claims all distinct partitions required for the given list of objects.

Parameters
aObjects the list of objects whose partitions should be claimed

Tries to claim as most as possible without error, throws the first exception found. It is advised to use the overload that returns list/dictionaries of successful, failed claimings. This overload does not use logging.

void ClaimPartitions | ( | List< ObjectProxy > | aObjects,
 |  | string | aLogName
 | ) |  |
inline

Claims all distinct partitions required for the given list of objects.

Parameters
aObjects | the list of objects whose partitions should be claimed
aLogName | the log source name to be used for progress output

Tries to claim as most as possible without error, throws the first exception found. It is advised to use the overload that returns list/dictionaries of successful, failed claimings.

void ClaimPartitions | ( | List< ObjectProxy > | aObjects,
 |  | string | aLogName,
 |  | ref List< Guid > | aClaimedPartitions,
 |  | ref Dictionary< Guid, Exception > | aFailedPartitions
 | ) |  |
inline

Claims all distinct partitions required for the given list of objects.

Parameters
aObjects | the list of object objects whose partitions should be claimed
aLogName | the log source name to be used for progress output
aClaimedPartitions | the list of successful claimed partitions, in case of an exception these partitions should be unclaimed
aFailedPartitions | a dictionary of partitions whose claiming has failed, including the exception with the reason

Providing null for aClaimedPartition will not record successful claimed partitions.

Providing null for aFailedPartitions will throw an exception on the first partition that could not be claimed.

You should check aFailedPartitions.Count to check if there were any exceptions.

Partitions that are already claimed within the list of objects are reported as claimed, even if there is no data transfer required.

void UnclaimPartition ( Guid aPartitionGuid )
inline

Unclaims a single partition which is given by its Guid.

Parameters
aPartitionGuid The guid of the partition to unclaim.

No progress output is reported.

void UnclaimPartition ( UnclaimPartitionArgs aArgs )
inline

Unclaims a single partition which is given by its Guid.

Parameters
aArgs The arguments for this command containing the parameters see UnclaimPartitionArgs for their meaning.

Progress output is reported to the Log if the LogSourceName is set.

void UnclaimPartitions ( List< Guid > aPartitionGuids )
inline

Unclaims all partitions in the list of partition guids in one single transaction

Parameters
aPartitionGuids The list of partition guids to unclaim
void UnclaimPartitions | ( | List< Guid > | aPartitionGuids,
 |  | UnclaimPartitionArgs | aArgs
 | ) |  |
inline

Unclaims all partitions in the list of partition guids in one single transaction

Parameters
aPartitionGuids | The list of partition guids to unclaim
aArgs | The arguments for this command containing the parameters see UnclaimPartitionArgs for their meaning

Progress output is reported to the Log if the LogSourceName is set.

The PartitionGuid member in the arguments will be ignored for this method

void UnclaimAllMyPartitions ( )
inline

Unclaims all partitions the currently logged-in user has claimed.

No progress output is reported. This method is especially handy to clean up after changing many articy objects and saves your program from keeping track on the claimed partitions.

void UnclaimAllMyPartitions ( UnclaimPartitionArgs aArgs )
inline

Unclaims all partitions the currently logged in user has claimed

Parameters
aArgs The arguments for this command containing the parameters see UnclaimPartitionArgs for their meaning

Progress output is reported to the Log if the LogSourceName is set.

The PartitionGuid member in the arguments will be ignored for this method

void ForcefullyUnclaimPartition ( Guid aPartitionGuid )
inline

Forcefully unclaims a partition that was claimed by another user.

Parameters
aPartitionGuid The Guid of the partition whose claim should be forcefully unclaimed

When claiming a partition has failed, this method could be used to forcefully unclaim the respective partition. WARNING: Use this method with great care because it could destroy changes another user has made to the articy project.

  • Can't be used in exclusive mode
  • Can't be used for own partitions
void ForcefullyUnclaimPartition ( SimplePartitionActionArgs aArgs )
inline

Forcefully unclaims a partition that was claimed by another user.

Parameters
aArgs the argument record used for the action

When claiming a partition has failed, this method could be used to forcefully unclaim the respective partition. WARNING: Use this method with great care because it could destroy changes another user has made to the articy project.

  • Can't be used in exclusive mode
  • Can't be used for own partitions
void DiscardChangesToPartition ( Guid aPartitionGuid )
inline

Discard changes in a single partition which is given by its Guid.

Parameters
aPartitionGuid The guid of the partition whose data should be discarded.

No progress output is reported.

void DiscardChangesToPartition ( SimplePartitionActionArgs aArgs )
inline

Discard changes in a single partition which is given by its Guid.

Parameters
aArgs The arguments for this command containing the parameters see SimplePartitionActionArgs for their meaning.

Progress output is reported to the Log if the LogSourceName is set.

void UpdatePartition ( Guid aPartitionGuid )
inline

Updates the given partition.

Parameters
aPartitionGuid The Guid of the partition to update
Exceptions
ArticyApiException PartitionClaimed is thrown when you already have the partition claimed, so no external changes can be present
void UpdatePartition ( SimplePartitionActionArgs aArgs )
inline

Updates the given partition. Using this overload you can add the output to a log

Parameters
aArgs the argument record containing the partition guid and log source name
Exceptions
ArticyApiException PartitionClaimed is thrown when you already have the partition claimed, so no external changes can be present
void UpdatePartitions ( List< Guid > aPartitionGuids )
inline

Updates all partitions in the given list. Is just a convenience method that calls the UpdatePartition method for each guid

Parameters
aPartitionGuids the list of partition guids to update
void UpdatePartitions | ( | List< Guid > | aPartitionGuids,
 |  | string | aLogSourceName
 | ) |  |
inline

Updates all partitions in the given list. Is just a convenience method that calls the UpdatePartition method for each guid

Parameters
aPartitionGuids | the list of partition guids to update
aLogSourceName | the log source name to post the logging messages to
void Repartition | ( | IList< ObjectProxy > | aObjects,
 |  | RepartitionMode | aMode,
 |  | bool | aKeepPartitons = false
 | ) |  |
inline

Changes the partition configuration of a project. The changes will be published and the project will be saved during this function. Only certain objects can be passed to this function. Invalid objects will cause an exception. See ObjectProxy.CanBePartitioned.

Parameters
aObjects | Objects to convert (create or retire)
aMode | Defines what to do with the objects passed via aObjects
aKeepPartitons | Set to true to keep partitions claimed after conversion
Exceptions
ArticyApiException | ObjectNotPartitionable is thrown when CanBePartitioned of an object is false
ArticyApiException | RepartitioningFailed is thrown when the partitioning process failed (e.g. wrong user rights)
ResultSet RunQuery ( string aQuery )
inline

Searches the opened project for articy objects.

Parameters
aQuery A string containing the query expression. See the "ArticyDraft API-Programmer's Guide.pdf" chapter 4 for details.
Returns
a ResultSet object containing one row for every found articy object

If the API methods SimpleFindObjects(ulong,string,Articy.Api.TextFilterRelation,Articy.Api.SearchTextIn,bool) and SimpleFindConflicts are not sufficient to find the required set of articy objects you need to use this method. RunQuery allows searching for a very specific subset of objects in the opened project using a powerful query language.

ResultSet RunQuery | ( | string | aQuery,
 |  | ObjectProxy | aSelfReference
 | ) |  |
inline

Searches the opened project for articy objects.

Parameters
aQuery | A string containing the query expression. See the "ArticyDraft API-Programmer's Guide.pdf" chapter 4 for details.
aSelfReference | a Object that is used as SELF object reference in the query or the default null if not required/avilable
Returns
a ResultSet object containing one row for every found articy object

If the API methods SimpleFindObjects(ulong,string,Articy.Api.TextFilterRelation,Articy.Api.SearchTextIn,bool) and SimpleFindConflicts are not sufficient to find the required set of articy objects you need to use this method. RunQuery allows searching for a very specific subset of objects in the opened project using a powerful query language.

bool WaitForAssetProcessing ( WaitForAssetProcessingArgs aArgs )
inline

Blocking call that waits until the asset system has processed all assets. This has to be completed before partitions can be published or the exclusive mode can be left. After claiming a partition, opening a project in exclusive mode and importing assets, the asset system starts checking the status of each corresponding asset.

If necessary, it then tries to

  • import the asset from the original source location to the project's working copy,
  • add it so the SCM,
  • compute a thumbnail.
Parameters
aArgs an object containing more parameters
Returns
A boolean indicating if all assets have been processed successfully. Returns false if some asset file is missing in the working copy.
bool WaitForAssetProcessing | ( | WaitForAssetProcessingArgs | aArgs,
 |  | IList< String > | aMissingAssetFiles
 | ) |  |
inline

Blocking call that waits until the asset system has processed all assets. This has to be completed before partitions can be published or the exclusive mode can be left. After claiming a partition, opening a project in exclusive mode and importing assets, the asset system starts checking the status of each corresponding asset.

If necessary, it then tries to

  • import the asset from the original source location to the project's working copy,
  • add it so the SCM,
  • compute a thumbnail.
Parameters
aArgs | an object containing more parameters
aMissingAssetFiles | If not null, this list gets filled with the full display names of all assets whose working copy file is missing. This can be used to prepare an error message hinting at the assets that hinder the partitions to be unclaimed.
Returns
A boolean indicating if all assets have been processed successfully. Returns false if some asset file is missing in the working copy.
void ReimportAsset ( ObjectProxy aAsset )
inline

Schedules an re-import of an asset from its "OriginalSource" filename.

The methods returns immediately. It just enqueues an job that is processing in the background.

Use WaitForAssetProcessing when you need the job(s) to be completed before proceeding

Parameters
aAsset an object proxy whose type is 'Asset'
Exceptions
ArticyApiException | ErrorCode.AssetObjectExpected when aAsset is either null or not an asset
ArticyApiException | ErrorCode.WriteDenied when aAsset is not currently claimed
ArticyApiException | ErrorCode.AssetFileNotFound when the file specified in the property 'OriginalSource' does not exist.
void ChangeAsset | ( | ObjectProxy | aAsset,
 |  | string | aFullFilename
 | ) |  |
inline

Schedules an re-import of an asset from a new filename (Change asset source).

The methods returns immediately. It just enqueues an job that is processing in the background.

Use WaitForAssetProcessing when you need the job(s) to be completed before proceeding

Parameters
aAsset | an object proxy whose type is 'Asset'
aFullFilename | the full filename of the new asset data to be used
Exceptions
ArticyApiException | ErrorCode.AssetObjectExpected when aAsset is either null or not an asset
ArticyApiException | ErrorCode.WriteDenied when aAsset is not currently claimed
ArticyApiException | ErrorCode.AssetFileNotFound when the file specified in the property 'OriginalSource' does not exist.
ApiLocationTools GetLocationToolsFor ( ObjectProxy aLocationObject )
inline

Create an ApiLocationTool object

Parameters
aLocationObject the location to work with or <cc>null</cc> to create a tool object that is not bound to a location and only allows to call methods that don't need the parent context.
Returns
void DeleteObject ( ObjectProxy aObject )
inline

Deletes the given object and all its dependencies.

E.g. when you delete a folder, all elements within will also be deleted; when you delete a FlowFragment, all inner elements will be deleted, all connected pins and connections to this flow fragment get also deleted

Parameters
aObject the object to be deleted
Exceptions
ArticyApiException | WriteDenied when the partition containing the object is not claimed
ArticyApiException | CantDeleteSystemFolder when you try to delete a system folder
ArticyApiException | CantDeletePartitionRoot when you try to delete an object that is the root of an partition
ArticyApiException | DeleteNotAllowed any other objection regarding the delete. Most likely that an inner container is the root of an partition
ObjectProxy CloneObject | ( | ObjectProxy | aObject,
 |  | ObjectProxy | aParent
 | ) |  |
inline

Creates a deep copy of the given object, i.e. all children of that object will be copied, too.

Parameters
aObject | Object to copy
aParent | Parent to copy the object to
Returns
The newly created object
ObjectProxy CloneChildren | ( | ObjectProxy | aObject,
 |  | ObjectProxy | aParent
 | ) |  |
inline

Link CloneObject, but clones all children of aObject instead of just aObject. aObject itself is not cloned. Connections from a child to aObject are not cloned as they cannot necessarily be connected to aParent.

Parameters
aObject | Object holding the children to copy
aParent | Parent to copy the object to
Returns
aParent
void MoveObject | ( | ObjectProxy | aObject,
 |  | ObjectProxy | aNewParent
 | ) |  |
inline

Moves the given object into the given target/parent container. The new parent must already be claimed and must allow the given object. Cross partition moves will also fail

Parameters
aObject | the object to move
aNewParent | the new target/parent container
void MoveObjects | ( | List< ObjectProxy > | aObjects,
 |  | ObjectProxy | aNewParent
 | ) |  |
inline

Moves the given objects into the given target/parent container The new parent must already be claimed and must allow the given objects. Cross partition moves will also fail

Parameters
aObjects | the list of objects to be moved
aNewParent | the new target/parent container
List<FlowListNode> LinearizeFlowSegment | ( | ObjectProxy | aStartingElement,
 |  | FlowToListTraversalType | aTraversalType,
 |  | int | aMaxDepth = 0,
 |  | bool | aIncludeUnconnected = true
 | ) |  |
inline

Create a linear list of a possible branching flow subtree. Tries to keep connected parts together and in linear order. Provides

Parameters
aStartingElement | The container element to start from, can be the Flow system oder or any child of this folder.
aTraversalType | The strategy used when a branching is detected
aMaxDepth | the maximum depth for submerging (0=no limit)
aIncludeUnconnected | true to include unconneced segments, false otherwise
Returns
a list of FlowListNodes in linear "document" order
ObjectProxy CreateFolder | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new user folder within the articy project tree.

Parameters
aParentId | The ID of the parent folder
aDisplayName | The display name of the newly created folder
Returns
an ObjectProxy for the newly created folder
ObjectProxy CreateFolder | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new user folder within the articy project tree.

Parameters
aParent | The ObjectProxy of the parent folder
aDisplayName | The display name of the newly created folder
Returns
an ObjectProxy for the newly created folder
ObjectProxy CreateEntity | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new entity object in the articy project tree.

Parameters
aParentId | the ID of the object that should serve as parent for the new created object
aDisplayName | the display name of the to-be-created entity
Returns
the freshly created object; use this return value to further initialize the properties of the new entity
ObjectProxy CreateEntity | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new entity object in the articy project tree.

Parameters
aParent | the object that should serve as parent for the new created entity
aDisplayName | the display name of the to-be-created entity
Returns
the freshly created object; use this return value to further initialize the properties of the new entity
ObjectProxy CreateEntity | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new entity object in the articy project tree.

Parameters
aParentId | the ID of the object that should serve as parent for the new created entity
aDisplayName | the display name of the to-be-created entity
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created entity or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new entity
ObjectProxy CreateEntity | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new entity object in the articy project tree.

Parameters
aParent | the object that should serve as parent for the new created object
aDisplayName | the display name of the to-be-created entity
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created entity or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new entity
ObjectProxy CreateLocation | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new location object in the articy project tree.

Parameters
aParentId | the ID of the object that should serve as parent for the new created location
aDisplayName | the display name of the to-be-created location
Returns
the freshly created object; use this return value to further initialize the properties of the new location
ObjectProxy CreateLocation | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new location object in the articy project tree.

Parameters
aParent | the object that should serve as parent for the new created location
aDisplayName | the display name of the to-be-created location
Returns
the freshly created object; use this return value to further initialize the properties of the new location
ObjectProxy CreateLocation | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new location object in the articy project tree.

Parameters
aParentId | the ID of the object that should serve as parent for the new created location
aDisplayName | the display name of the to-be-created location
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created location or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new location
ObjectProxy CreateLocation | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new location object in the articy project tree.

Parameters
aParent | the object that should serve as parent for the new created location
aDisplayName | the display name of the to-be-created location
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created location or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new location
ObjectProxy CreateLocationGroup | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new location group within in an existing location or location group.

Parameters
aParentId | the ID of the location or location group
aDisplayName | The display name of the newly created group
Returns
an ObjectProxy for the newly created group
ObjectProxy CreateLocationLayerFolder | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new location layer folder within in an existing location or location layer folder.

Parameters
aParent | the parent location or location layer folder object
aDisplayName | The display name of the newly created folder
Returns
an ObjectProxy for the newly created folder
ObjectProxy CreateLink | ( | ulong | aParentId,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParentId | the ID of the location or location group that should serve as parent for the new created link
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ObjectProxy | aParent,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created link
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ulong | aParentId,
 |  | string | aTemplateTechName,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParentId | the ID of the location or location group that should serve as parent for the new created link
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created link or null to create without assigning a template
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ObjectProxy | aParent,
 |  | string | aTemplateTechName,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created link
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created link or null to create without assigning a template
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ulong | aParentId,
 |  | string | aTemplateTechName,
 |  | Point | aPosition,
 |  | ObjectProxy | aReferencedModel
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParentId | the ID of the location or location group that should serve as parent for the new created link
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created link or null to create without assigning a template
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
aReferencedModel | the articy object that shall serve as target for this link object
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ulong | aParentId,
 |  | string | aTemplateTechName,
 |  | Point | aPosition,
 |  | ulong | aReferencedModelId
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParentId | the ID of the location or location group that should serve as parent for the new created link
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created link or null to create without assigning a template
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
aReferencedModelId | the ID of the articy object that shall serve as target for this link object
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ObjectProxy | aParent,
 |  | string | aTemplateTechName,
 |  | Point | aPosition,
 |  | ObjectProxy | aReferencedModel
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created link
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created link or null to create without assigning a template
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
aReferencedModel | the articy object that shall serve as target for this link object
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLink | ( | ObjectProxy | aParent,
 |  | string | aTemplateTechName,
 |  | Point | aPosition,
 |  | ulong | aReferencedModelId
 | ) |  |
inline

Creates a new link inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created link
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created link or null to create without assigning a template
aPosition | the coordinate of the link as it is displayed in the property view of the articy:draft GUI
aReferencedModelId | the ID of the articy object that shall serve as target for this link object
Returns
the freshly created object; use this return value to further initialize the properties of the new link

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateSpot | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new spot inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created spot
aDisplayName | the display name of the to-be-created spot
aPosition | the coordinate of the spot as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new spot

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateSpot | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new spot inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created spot
aDisplayName | the display name of the to-be-created spot
aPosition | the coordinate of the spot as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new spot

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateSpot | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new spot inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created spot
aDisplayName | the display name of the to-be-created spot
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created spot or null to create without assigning a template
aPosition | the coordinate of the spot as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new spot

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateSpot | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | Point | aPosition
 | ) |  |
inline

Creates a new spot inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created spot
aDisplayName | the display name of the to-be-created spot
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created spot or null to create without assigning a template
aPosition | the coordinate of the spot as it is displayed in the property view of the articy:draft GUI
Returns
the freshly created object; use this return value to further initialize the properties of the new spot

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneRect | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | Rect | aRect
 | ) |  |
inline

Creates a new rectangular zone inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aRect | the coordinates of the new zone inside its location
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneRect | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | Rect | aRect
 | ) |  |
inline

Creates a new rectangular zone inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aRect | the coordinates of the new zone inside its location
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneRect | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | Rect | aRect
 | ) |  |
inline

Creates a new rectangular zone inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created zone or null to create without assigning a template
aRect | the coordinates of the new zone inside its location
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneRect | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | Rect | aRect
 | ) |  |
inline

Creates a new rectangular zone inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created zone or null to create without assigning a template
aRect | the coordinates of the new zone inside its location
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateLocationImage | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | Point | aTopLeft,
 |  | ulong | aImageAssetId
 | ) |  |
inline

Creates a new image inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created image
aDisplayName | the display name of the to-be-created image
aTopLeft | The upper left corner of the image
aImageAssetId | the id of the image asset to be used
Returns
the freshly created object; use this return value to further initialize the properties of the new image

All coordinates are screen/world/pixel

ObjectProxy CreateLocationImage | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | Point | aTopLeft,
 |  | ObjectProxy | aImageAsset
 | ) |  |
inline

Creates a new image inside a location.

Parameters
aParent | the reference to the location or location group object that should serve as parent for the new created image
aDisplayName | the display name of the to-be-created image
aTopLeft | The upper left corner of the image
aImageAsset | the image asset to be used
Returns
the freshly created object; use this return value to further initialize the properties of the new image

All coordinates are screen/world/pixel

ObjectProxy CreateLocationImage | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | Point | aTopLeft,
 |  | ulong | aImageAssetId,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new image inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created image
aDisplayName | the display name of the to-be-created image
aTopLeft | The upper left corner of the image
aImageAssetId | the id of the image asset to be used
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created image or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new image

All coordinates are screen/world/pixel

ObjectProxy CreateLocationImage | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | Point | aTopLeft,
 |  | ObjectProxy | aImageAsset,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new image inside a location.

Parameters
aParent | the reference to the location or location group object that should serve as parent for the new created image
aDisplayName | the display name of the to-be-created image
aTopLeft | The upper left corner of the image
aImageAsset | the image asset to be used
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created image or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new image

All coordinates are screen/world/pixel

ObjectProxy CreateLocationText | ( | ulong | aParentId,
 |  | Point | aTopLeft,
 |  | string | aText,
 |  | double | aWidth,
 |  | double | aHeight
 | ) |  |
inline

Creates a new text inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created text
aTopLeft | The upper left corner of the text
aText | The plain text of the text element
aWidth | The width of the text object
aHeight | The height of the text object
Returns
the freshly created object; use this return value to further initialize the properties of the new text

All coordinates are screen/world/pixel

ObjectProxy CreateLocationText | ( | ObjectProxy | aParent,
 |  | Point | aTopLeft,
 |  | string | aText,
 |  | double | aWidth,
 |  | double | aHeight
 | ) |  |
inline

Creates a new text inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created text
aTopLeft | The upper left corner of the text
aText | The plain text of the text element
aWidth | The width of the text object
aHeight | The height of the text object
Returns
the freshly created object; use this return value to further initialize the properties of the new text

All coordinates are screen/world/pixel

ObjectProxy CreateLocationText | ( | ulong | aParentId,
 |  | Point | aTopLeft,
 |  | string | aText,
 |  | double | aWidth,
 |  | double | aHeight,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new text inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created text
aTopLeft | The upper left corner of the text
aText | The plain text of the text element
aWidth | The width of the text object
aHeight | The height of the text object
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created image or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new text

All coordinates are screen/world/pixel

ObjectProxy CreateLocationText | ( | ObjectProxy | aParent,
 |  | Point | aTopLeft,
 |  | string | aText,
 |  | double | aWidth,
 |  | double | aHeight,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new text inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created text
aTopLeft | The upper left corner of the text
aText | The plain text of the text element
aWidth | The width of the text object
aHeight | The height of the text object
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created image or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new text

All coordinates are screen/world/pixel

ObjectProxy CreateZoneCircle | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | Point | aCenter,
 |  | double | aRadius
 | ) |  |
inline

Creates a new spherical zone inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aCenter | the coordinate of center point of the to-be-created zone
aRadius | the radius of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneCircle | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | Point | aCenter,
 |  | double | aRadius
 | ) |  |
inline

Creates a new spherical zone inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aCenter | the coordinate of center point of the to-be-created zone
aRadius | the radius of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneCircle | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | Point | aCenter,
 |  | double | aRadius
 | ) |  |
inline

Creates a new spherical zone inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created zone or null to create without assigning a template
aCenter | the coordinate of center point of the to-be-created zone
aRadius | the radius of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZoneCircle | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | Point | aCenter,
 |  | double | aRadius
 | ) |  |
inline

Creates a new spherical zone inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created zone or null to create without assigning a template
aCenter | the coordinate of center point of the to-be-created zone
aRadius | the radius of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZonePolygon | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new custom-shaped zone inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aVertices | a list of point coordinates that describe the polygonal shape of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZonePolygon | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new custom-shaped zone inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aVertices | a list of point coordinates that describe the polygonal shape of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZonePolygon | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new custom-shaped zone inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created zone or null to create without assigning a template
aVertices | a list of point coordinates that describe the polygonal shape of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateZonePolygon | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new custom-shaped zone inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created zone
aDisplayName | the display name of the to-be-created zone
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created zone or null to create without assigning a template
aVertices | a list of point coordinates that describe the polygonal shape of the to-be-created zone
Returns
the freshly created object; use this return value to further initialize the properties of the new zone

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreatePath | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new path inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created path
aDisplayName | the display name of the to-be-created path
aVertices | a list of point coordinates that describe the course of the to-be-created path inside the location
Returns
the freshly created object; use this return value to further initialize the properties of the new path

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreatePath | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new path inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created path
aDisplayName | the display name of the to-be-created path
aVertices | a list of point coordinates that describe the course of the to-be-created path inside the location
Returns
the freshly created object; use this return value to further initialize the properties of the new path

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreatePath | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new path inside a location.

Parameters
aParentId | the ID of the location or location group object that should serve as parent for the new created path
aDisplayName | the display name of the to-be-created path
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created path or null to create without assigning a template
aVertices | a list of point coordinates that describe the course of the to-be-created path inside the location
Returns
the freshly created object; use this return value to further initialize the properties of the new path

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreatePath | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName,
 |  | params Point[] | aVertices
 | ) |  |
inline

Creates a new path inside a location.

Parameters
aParent | the location or location group object that should serve as parent for the new created path
aDisplayName | the display name of the to-be-created path
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created path or null to create without assigning a template
aVertices | a list of point coordinates that describe the course of the to-be-created path inside the location
Returns
the freshly created object; use this return value to further initialize the properties of the new path

All coordinates are screen/pixel coordinates of the location's underlying background image.

ObjectProxy CreateFlowFragment | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new flow fragment in the flow area.

Parameters
aParentId | the ID of the flow fragment that should serve as parent for the to-be-created flow fragment
aDisplayName | the display name of the to-be-created flow fragment
Returns
the freshly created object; use this return value to further initialize the properties of the new flow fragment
ObjectProxy CreateFlowFragment | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new flow fragment in the flow area.

Parameters
aParent | the flow fragment that should serve as parent for the new created flow fragment
aDisplayName | the display name of the to-be-created flow fragment
Returns
the freshly created object; use this return value to further initialize the properties of the new flow fragment
ObjectProxy CreateFlowFragment | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new flow fragment in the flow area.

Parameters
aParentId | the ID of the flow fragment that should serve as parent for the to-be-created flow fragment
aDisplayName | the display name of the to-be-created flow fragment
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created flow fragment or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new flow fragment
ObjectProxy CreateFlowFragment | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new flow fragment in the flow area.

Parameters
aParent | the flow fragment that should serve as parent for the new created flow fragment
aDisplayName | the display name of the to-be-created flow fragment
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created flow fragment or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new flow fragment
ObjectProxy CreateDialogue | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new dialogue in the flow area.

Parameters
aParentId | the ID of the flow fragment that should serve as parent for the to-be-created dialogue
aDisplayName | the display name of the to-be-created dialogue
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue
ObjectProxy CreateDialogue | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new dialogue in the flow area.

Parameters
aParent | the flow fragment that should serve as parent for the to-be-created dialog
aDisplayName | the display name of the to-be-created dialog
Returns
the freshly created object; use this return value to further initialize the properties of the new dialog
ObjectProxy CreateDialogue | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new dialogue in the flow area.

Parameters
aParentId | the ID of the flow fragment that should serve as parent for the to-be-created dialogue
aDisplayName | the display name of the to-be-created dialog
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created dialogue or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue
ObjectProxy CreateDialogue | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new dialogue in the flow area.

Parameters
aParent | the flow fragment that should serve as parent for the to-be-created dialogue
aDisplayName | the display name of the to-be-created dialog
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created dialogue or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue
ObjectProxy CreateDialogueFragment | ( | ulong | aParentId,
 |  | string | aText
 | ) |  |
inline

Creates a new dialogue fragment inside a dialog.

Parameters
aParentId | the ID of the dialog that should serve as parent for the to-be-created dialogue fragment
aText | the spoken text of the to-be-created dialogue fragment
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue fragment
ObjectProxy CreateDialogueFragment | ( | ObjectProxy | aParent,
 |  | string | aText
 | ) |  |
inline

Creates a new dialogue fragment inside a dialog.

Parameters
aParent | the dialog that should serve as parent for the to-be-created dialogue fragment
aText | the spoken text of the to-be-created dialogue fragment
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue fragment
ObjectProxy CreateDialogueFragment | ( | ulong | aParentId,
 |  | string | aText,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new dialogue fragment inside a dialog.

Parameters
aParentId | the ID of the dialog that should serve as parent for the to-be-created dialogue fragment
aText | the spoken text of the to-be-created dialog fragment
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created dialogue fragment or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue fragment
ObjectProxy CreateDialogueFragment | ( | ObjectProxy | aParent,
 |  | string | aText,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new dialogue fragment inside a dialog.

Parameters
aParent | the dialog that should serve as parent for the to-be-created dialogue fragment
aText | the spoken text of the to-be-created dialogue fragment
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created dialogue fragment or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new dialogue fragment
ObjectProxy CreateJump | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new jump in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created jump
aDisplayName | the display name of the to-be-created jump
Returns
the freshly created object; use this return value to further initialize the properties of the new jump
ObjectProxy CreateJump | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new jump in the flow area.

Parameters
aParent | the object that should serve as parent for the new created jump
aDisplayName | the display name of the to-be-created jump
Returns
the freshly created object; use this return value to further initialize the properties of the new jump
ObjectProxy CreateJump | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new jump in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created jump
aDisplayName | the display name of the to-be-created jump
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created jump or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new jump
ObjectProxy CreateJump | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new jump in the flow area.

Parameters
aParent | the object that should serve as parent for the new created jump
aDisplayName | the display name of the to-be-created jump
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created jump or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new jump
ObjectProxy CreateHub | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new hub in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created hub
aDisplayName | the display name of the to-be-created hub
Returns
the freshly created object; use this return value to further initialize the properties of the new hub
ObjectProxy CreateHub | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new hub in the flow area.

Parameters
aParent | the object that should serve as parent for the new created hub
aDisplayName | the display name of the to-be-created hub
Returns
the freshly created object; use this return value to further initialize the properties of the new hub
ObjectProxy CreateHub | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new hub in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created hub
aDisplayName | the display name of the to-be-created hub
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created hub or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new hub
ObjectProxy CreateHub | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new hub in the flow area.

Parameters
aParent | the object that should serve as parent for the new created hub
aDisplayName | the display name of the to-be-created hub
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created hub or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new hub
ObjectProxy CreateCondition | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new condition node in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created condition
aDisplayName | the display name of the to-be-created condition
Returns
the freshly created object; use this return value to further initialize the properties of the new condition
ObjectProxy CreateCondition | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new condition node in the flow area.

Parameters
aParent | the object that should serve as parent for the to-be-created condition
aDisplayName | the display name of the to-be-created condition
Returns
the freshly created object; use this return value to further initialize the properties of the new condition
ObjectProxy CreateCondition | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new condition node in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created condition
aDisplayName | the display name of the to-be-created condition
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created condition or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new condition
ObjectProxy CreateCondition | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new condition node in the flow area.

Parameters
aParent | the object that should serve as parent for the to-be-created condition
aDisplayName | the display name of the to-be-created condition
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created condition or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new condition
ObjectProxy CreateInstruction | ( | ulong | aParentId,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new instruction node in the flow area.

Parameters
aParentId | the ID of the object that should serve as parent for the to-be-created instruction
aDisplayName | the display name of the to-be-created instruction
Returns
the freshly created object; use this return value to further initialize the properties of the new instruction
ObjectProxy CreateInstruction | ( | ObjectProxy | aParent,
 |  | string | aDisplayName
 | ) |  |
inline

Creates a new instruction in the flow area.

Parameters
aParent | the object that should serve as parent for the to-be-created instruction
aDisplayName | the display name of the to-be-created instruction
Returns
the freshly created object; use this return value to further initialize the properties of the new instruction
ObjectProxy CreateInstruction | ( | ulong | aParentId,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new instruction in the flow area.

Parameters
aParentId | the ID of the fobject that should serve as parent for the to-be-created instruction
aDisplayName | the display name of the to-be-created instruction
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created instruction or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new instruction
ObjectProxy CreateInstruction | ( | ObjectProxy | aParent,
 |  | string | aDisplayName,
 |  | string | aTemplateTechName
 | ) |  |
inline

Creates a new instruction in the flow area.

Parameters
aParent | the object that should serve as parent for the to-be-created instruction
aDisplayName | the display name of the to-be-created instruction
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-created instruction or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new instruction
ObjectProxy CreateVariableSet | ( | String | aScriptingName,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new variable set in the "Global Variables" system folder.

Parameters
aScriptingName | the name of the new variable set
aDescription | the description of the new namespace
Returns
the freshly created object; use this return value to further initialize the properties of the new namespace
ObjectProxy CreateGlobalVariable | ( | ObjectProxy | aParentVariableSet,
 |  | String | aScriptingName,
 |  | VariableType | aType = VariableType.Boolean,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new variable in the given variable set with the given type.

Parameters
aParentVariableSet | the existing parent variable set of the new variable
aScriptingName | the name of the new variable
aType | the data type of the new variable
aDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aParentVariableSetName,
 |  | String | aScriptingName,
 |  | VariableType | aType = VariableType.Boolean,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new variable in the given variable set with the given type.

Parameters
aParentVariableSetName | the name of parent variable set name for the new variable
aScriptingName | the name of the new variable
aType | the data type of the new variable
aDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | ObjectProxy | aParentVariableSet,
 |  | String | aScriptingName,
 |  | bool | aDefaultValue,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new boolean variable in the given namespace with the given type.

Parameters
aParentVariableSet | the parent variable set for the new variable
aScriptingName | the name of the new variable
aDefaultValue | the default value of the new variable
aDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | ObjectProxy | aParentVariableSet,
 |  | String | aScriptingName,
 |  | int | aDefaultValue,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new integer variable in the given namespace with the given type.

Parameters
aParentVariableSet | the parent variable set for the new variable
aScriptingName | the name of the new variable
aDefaultValue | the default value of the new variable
aDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aParentVariableSetName,
 |  | String | aScriptingName,
 |  | bool | aDefaultValue,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new boolean variable in the given namespace with the given type.

Parameters
aParentVariableSetName | the name of parent variable set for the new variable
aScriptingName | the name of the new variable
aDefaultValue | the default value of the new variable
aDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aFullQualifiedName,
 |  | bool | aDefaultValue,
 |  | out ObjectProxy | aNamespace,
 |  | string | aVariableDescription = ""
 | ) |  |
inline

Creates a new boolean variable via a full qualified name. If the supplied namespace doesn't exist, it will be created.

Parameters
aFullQualifiedName | a full qualified variable name in the form of "variableset.variable"
aDefaultValue | the default value for the new variable
aNamespace | returns the used or newly created namespace
aVariableDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aFullQualifiedName,
 |  | int | aDefaultValue,
 |  | out ObjectProxy | aNamespace,
 |  | string | aVariableDescription = ""
 | ) |  |
inline

Creates a new integer variable via a full qualified name. If the supplied namespace doesn't exist, it will be created.

Parameters
aFullQualifiedName | a full qualified variable name in the form of "variableset.variable"
aDefaultValue | the default value for the new variable
aNamespace | returns the used or newly created namespace
aVariableDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aFullQualifiedName,
 |  | bool | aDefaultValue,
 |  | string | aVariableDescription = ""
 | ) |  |
inline

Creates a new boolean variable via a full qualified name. If the supplied namespace doesn't exist, it will be created.

Parameters
aFullQualifiedName | a full qualified variable name in the form of "variableset.variable"
aDefaultValue | the default value for the new variable
aVariableDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aFullQualifiedName,
 |  | int | aDefaultValue,
 |  | string | aVariableDescription = ""
 | ) |  |
inline

Creates a new integer variable via a full qualified name. If the supplied namespace doesn't exist, it will be created.

Parameters
aFullQualifiedName | a full qualified variable name in the form of "variable.variable"
aDefaultValue | the default value for the new variable
aVariableDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy CreateGlobalVariable | ( | String | aParentVariableSetName,
 |  | String | aScriptingName,
 |  | int | aDefaultValue,
 |  | String | aDescription = ""
 | ) |  |
inline

Creates a new integer variable in the given variable set with the given type.

Parameters
aParentVariableSetName | the name of parent variable set for the new variable
aScriptingName | the name of the new variable
aDefaultValue | the default value of the new variable
aDescription | the description of the new variable
Returns
the freshly created object; use this return value to further initialize the properties of the new variable
ObjectProxy GetGlobalVariable ( string aFullQualifiedName )
inline

Gets a global variable whose full qualified name, namespace & variable name, is known. For example "game.IsRunning"

Parameters
aFullQualifiedName the full qualified variable name, which is the parent namespace and the variable seperated with a dot.
Returns
either the object proxy or null when the variable is not known
Exceptions
ArticyApiException | ProjectNotOpen is thrown when no project is currently loaded.
ArticyApiException | InvalidVariableName is thrown when passing an invalid name.
ObjectProxy GetGlobalVariable | ( | ObjectProxy | aParentVariableSet,
 |  | String | aScriptingName
 | ) |  |
inline

Fetches a variable from a given VariableSet

Parameters
aParentVariableSet | VariableSet
aScriptingName | Name of the variable
Returns
either the object proxy or null when the variable is not known
Exceptions
ArticyApiException | ProjectNotOpen is thrown when no project is currently loaded.
ArticyApiException | UnsupportedObject when passing an invalid aParentVariableSet.
ObjectProxy GetGlobalVariable | ( | string | aVariableSetName,
 |  | string | aScriptingName
 | ) |  |
inline

Fetches a variable from a given VariableSet

Parameters
aVariableSetName | Name of the VariableSet containing the variable
aScriptingName | Name of the variable
Returns
either the object proxy or null when the variable is not known
Exceptions
ArticyApiException ProjectNotOpen is thrown when no project is currently loaded.
List<ObjectProxy> RefactorVariableReferences | ( | ObjectProxy | aVariableOrSet,
 |  | bool | aOnlyStrayReferences = true
 | ) |  |
inline

Searches expression fields for variable that are named like a certain variable but not actually linked to it. A so called stray variable reference is created when a variable is deleted while still in use by an expression field. When creating a new variable by the same name, that old reference is weak-linked to the new variable by its name. Stray references will not react on renaming or moving unless they are linked to the actual variable by using this function. Expression fields containing such stray variables will be modified and are claimed during the course of this function. Objects in partitions that are claimed by other users will be ignored. The affected partitions will not be unclaimed automatically.

Parameters
aVariableOrSet | Variable or VariableSet to refactor
aOnlyStrayReferences | Set to false to modify all usages of aVariableOrSet. Set to true to only modify stray references.
Returns
list of affected objects
ObjectProxy CreateDocument | ( | ulong | aParentId,
 |  | String | aDisplayName,
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Creates a new Document object as child of the given parent

Parameters
aParentId | the parent object (must be the Documents folder or a user-folder within)
aDisplayName | the title of the document
aTemplateTechName | the technical name of a templte the newly created object should get, nullif no template should be set.
Returns
a new object with type 'Document'

the parent object must be claimed

ObjectProxy CreateDocument | ( | ObjectProxy | aParent,
 |  | String | aDisplayName,
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Creates a new Document object as child of the given parent

Parameters
aParent | the parent object (must be the Documents folder or a user-folder within)
aDisplayName | the title of the document
aTemplateTechName | the technical name of a templte the newly created object should get, nullif no template should be set.
Returns
a new object with type 'Document'

the parent object must be claimed

ObjectProxy CreateDocumentText | ( | ulong | aContextElementId,
 |  | HierarchyAdjustment | aHierarchy,
 |  | String | aDisplayName = "",
 |  | String | aText = "",
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Adds a new Text section to a document

Parameters
aContextElementId | the id of the element to be used as reference for placing the new section
aHierarchy | determines where the new element should be placed.
aDisplayName | the chapter caption for this section
aText | the text for the chapter
aTemplateTechName | a template technical name if the section should get a template null otherwise.
Returns
the newly created text section
ObjectProxy CreateDocumentText | ( | ObjectProxy | aContextElement,
 |  | HierarchyAdjustment | aHierarchy,
 |  | String | aDisplayName = "",
 |  | String | aText = "",
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Adds a new Text section to a document

Parameters
aContextElement | the element to be used as reference for placing the new section
aHierarchy | determines where the new element should be placed.
aDisplayName | the chapter caption for this section
aText | the text for the chapter
aTemplateTechName | a template technical name if the section should get a template null otherwise.
Returns
the newly created text section
ObjectProxy CreateDocumentDialogue | ( | ulong | aContextElementId,
 |  | HierarchyAdjustment | aHierarchy,
 |  | String | aDisplayName = "",
 |  | String | aText = "",
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Adds a new dialogue section to a document

Parameters
aContextElementId | the id of the element to be used as reference for placing the new section
aHierarchy | determines where the new element should be placed.
aDisplayName | the chapter caption for this section
aText | the text for the dialogues synopsis
aTemplateTechName | a template technical name if the section should get a template null otherwise.
Returns
the newly created dialog section
ObjectProxy CreateDocumentDialogue | ( | ObjectProxy | aContextElement,
 |  | HierarchyAdjustment | aHierarchy,
 |  | String | aDisplayName = "",
 |  | String | aText = "",
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Adds a new dialogue section to a document

Parameters
aContextElement | the element to be used as reference for placing the new section
aHierarchy | determines where the new element should be placed.
aDisplayName | the chapter caption for this section
aText | the text for the dialogues synopsis
aTemplateTechName | a template technical name if the section should get a template null otherwise.
Returns
the newly created dialog section
ObjectProxy CreateDocumentImage | ( | ulong | aContextElementId,
 |  | HierarchyAdjustment | aHierarchy,
 |  | ulong | aImageAsset = 0LU,
 |  | String | aText = "",
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Adds a new image section to a document

Parameters
aContextElementId | the id of the element to be used as reference for placing the new section
aHierarchy | determines where the new element should be placed.
aImageAsset | the id of the image to use, or 0 when no image should be referenced for now
aText | the description text to be used in front of the image (must be enabled in the show options)
aTemplateTechName | a template technical name if the section should get a template null otherwise.
Returns
the newly created (asset-)link section. This method check of the given asset is an image asset and throws an exception if not.
ObjectProxy CreateDocumentImage | ( | ObjectProxy | aContextElement,
 |  | HierarchyAdjustment | aHierarchy,
 |  | ObjectProxy | aImageAsset = null,
 |  | String | aText = "",
 |  | String | aTemplateTechName = null
 | ) |  |
inline

Adds a new image section to a document

Parameters
aContextElement | the id of the element to be used as reference for placing the new section
aHierarchy | determines where the new element should be placed.
aImageAsset | the the image asset to use, or null when no image should be referenced for now
aText | the description text to be used in front of the image (must be enabled in the show options)
aTemplateTechName | a template technical name if the section should get a template null otherwise.
Returns
the newly created (asset-)link section. This method check of the given asset is an image asset and throws an exception if not.
ObjectProxy ImportAsset | ( | ulong | aParentId,
 |  | String | aDisplayName,
 |  | string | aAssetFullFilename
 | ) |  |
inline

Imports the specified file and creates a new asset object.

Parameters
aParentId | the ID of the user folder that should serve as parent for the to-be-imported asset
aDisplayName | the display name of the to-be-imported asset; if null a default name from the imported filename is generated
aAssetFullFilename | the fully specified filename of the asset file that is to be imported
Returns
the freshly created object; use this return value to further initialize the properties of the new asset
ObjectProxy ImportAsset | ( | ObjectProxy | aParent,
 |  | String | aDisplayName,
 |  | string | aAssetFullFilename
 | ) |  |
inline

Imports the specified file and creates a new asset object.

Parameters
aParent | the user folder that should serve as parent for the to-be-imported asset
aDisplayName | the display name of the to-be-imported asset; if null a default name from the imported filename is generated
aAssetFullFilename | the fully specified filename of the asset file that is to be imported
Returns
the freshly created object; use this return value to further initialize the properties of the new asset
ObjectProxy ImportAsset | ( | ulong | aParentId,
 |  | String | aDisplayName,
 |  | string | aAssetFullFilename,
 |  | string | aTemplateTechName
 | ) |  |
inline

Imports the specified file and creates a new asset object.

Parameters
aParentId | the ID of the user folder that should serve as parent for the to-be-imported asset
aDisplayName | the display name of the to-be-imported asset; if null a default name from the imported filename is generated
aAssetFullFilename | the fully specified filename of the asset file that is to be imported
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-imported asset or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new asset
ObjectProxy ImportAsset | ( | ObjectProxy | aParent,
 |  | String | aDisplayName,
 |  | string | aAssetFullFilename,
 |  | string | aTemplateTechName
 | ) |  |
inline

Imports the specified file and creates a new asset object.

Parameters
aParent | the user folder that should serve as parent for the to-be-imported asset
aDisplayName | the display name of the to-be-imported asset; if null a default name from the imported filename is generated
aAssetFullFilename | the fully specified filename of the asset file that is to be imported
aTemplateTechName | the technical name of a template, that will be assigned to the to-be-imported asset or null to create without assigning a template
Returns
the freshly created object; use this return value to further initialize the properties of the new asset
ObjectProxy ConnectPins | ( | ObjectProxy | aOutPin,
 |  | ObjectProxy | aInPin
 | ) |  |
inline

Creates a connection between two pins. This function will throw an exception if the connection cannot be created, e.g. when the pins are on different hierarchy levels.

Parameters
aOutPin | Output pin to start the connection
aInPin | Input pin to end the connection
Returns
The newly created connection
Exceptions
ArticyApiException | ObjectNull when a parameter is null
ArticyApiException | WrongObjectType when a parameter is not a pin or the output/input constraints are not matched
ArticyApiException | InvalidParentForCreate when a connection is not possible (e.g. different hierarchy levels)

Property Documentation

bool ExclusivelyOpen
get

returns true when a project is exclusively open, false otherwise

bool ProjectOpen
get

returns true when a project is currently open, false otherwise


articy:draft API: ArticyApi Class Reference

  • Api
  • ArticyApi
Static Public Member Functions | Properties | List of all members
ArticyApi Class Reference

This static class the the bootstrapping singleton to startup and shutdown the articy:draft API More...

Static Public Member Functions

static void | Startup (LoggingCallback aLoggingCallback)
Initialize the API and start loading packages More...
static void | Startup (LoggingCallback aLoggingCallback, string[] aAdditionalStartupParameters)
Initialize the API and start loading packages, but use additional "command-line" switches for startup More...
static void | SetLoggingCallback (LoggingCallback aLoggingCallback)
Changes the logging callback that was used when initializing the API More...
static void | Shutdown ()
static ApiSession | CreateSession ()

Properties

static ApiSession CurrentSession [get]
The current session or null when no session is active. May be used to get this object without passing it to all own methods More...

Detailed Description

This static class the the bootstrapping singleton to startup and shutdown the articy:draft API

Member Function Documentation

static void Startup ( LoggingCallback aLoggingCallback )
inlinestatic

Initialize the API and start loading packages

Parameters
aLoggingCallback the logging callback to be used to report events and logs

This is the very first method of the API you need to call.

static void Startup | ( | LoggingCallback | aLoggingCallback,
 |  | string[] | aAdditionalStartupParameters
 | ) |  |
inlinestatic

Initialize the API and start loading packages, but use additional "command-line" switches for startup

Parameters
aLoggingCallback | the callback to be used for reporting logging messages
aAdditionalStartupParameters | additional "command-line" switches used in the startup process

This is the very first method of the API you need to call.

You may find the following parameters useful:

Parameter name and parameter value (if any) must be provided as separate string in the array. (e.g. new string[] {"-forceprofile", "D:\APIProfile" })

  • -forceprofile <ProfilePath> uses the given folder to write logs or recently opened projects information to. Without this parameter the data will be written to the windows user's profile directory (appdata%/Nevigo/Articy). So it will use the same data as the user that starts the GUI. When you use the API for a windows service this parameter will also be very handy to put the information to a place where you can better use it.
  • -syslog automatically creates an file base log with the application's .exe name as base name and extension log. The file will be written to the "Logs" folder of the profile and will preserve a history of the last 20 files. The log file will automatically change daily.
  • -idletime <time in seconds> articy:draft & articy:server send small ping packets when idle to keep the connection up and to respond fast to connection losses. This value changes the time after how many seconds of inactivity the keep alive packages should be send. This value should no exceed 120 seconds.
  • -pingtime <time in seconds> when the keep alive handling starts this value is the number of seconds between two ping packets This value should no exceed 30 seconds.

Increasing ping time and idle time settings can help when debugging an API application to prevent an automatic connection abort. When using these parameters the same values should be set in the articyserver.cfg file of the articy:server installation. Both settings are only for advanced usage.

static void SetLoggingCallback ( LoggingCallback aLoggingCallback )
inlinestatic

Changes the logging callback that was used when initializing the API

Parameters
aLoggingCallback the new logging callback, when setting to null, log message reporing will be suppressed

If the need should arise to change the logger during runtime of your program, this method can be used.

static void Shutdown ( )
inlinestatic

Shutdown API after work. This is the last method that should be called before shutdown the external application.

static ApiSession CreateSession ( )
inlinestatic

Create the session object for further handling.

Returns
the ApiSession object; almost all further calls of the API are methods that need to be called from this instance

After initializing the API you need to create a session object. Almost all API methods need to be called on a valid session object. It is possible to work with the same session object while opening and closing several projects.

Property Documentation

ApiSession CurrentSession
staticget

The current session or null when no session is active. May be used to get this object without passing it to all own methods


articy:draft API: ArticyApiException Class Reference

  • Api
  • ArticyApiException
Public Member Functions | Properties | List of all members
ArticyApiException Class Reference

More...

Inheritance diagram for ArticyApiException:

Public Member Functions

ArticyApiException (int aErrorCode)
Create an API exception with a specific error code More...
ArticyApiException (int aErrorCode, string aMessage)
Create an API exception with a specific error code More...
ArticyApiException (int aErrorCode, Exception aInnerException)
Create an API exception with a specific error code More...
ArticyApiException (int aErrorCode, string aMessage, Exception aInnerException)
Create an API exception with a specific error code More...
ArticyApiException (ErrorCode aErrorCode)
Create an API exception with a specific error code More...
ArticyApiException (ErrorCode aErrorCode, string aMessage)
Create an API exception with a specific error code More...
ArticyApiException (ErrorCode aErrorCode, Exception aInnerException)
Create an API exception with a specific error code More...
ArticyApiException (ErrorCode aErrorCode, string aMessage, Exception aInnerException)
Create an API exception with a specific error code More...

Properties

int | ErrorCode [get]
The error code this exception encapsulates, upper 16 bit are facility code, lower 16 bits are the error number within that facility More...
int | FacilityCode [get]
Getter that extracts the facility from the ErrorCode More...
int | ErrorNumber [get]
Getter that extracts the error number from the ErrorCode More...
override string | Message [get]
The formatted message of this exception More...

Detailed Description

The standard exception used when the API has found an expected error

Constructor & Destructor Documentation

ArticyApiException ( int aErrorCode )
inline

Create an API exception with a specific error code

Parameters
aErrorCode the 32 bit error code with facility and error number
ArticyApiException | ( | int | aErrorCode,
 |  | string | aMessage
 | ) |  |
inline

Create an API exception with a specific error code

Parameters
aErrorCode | the 32 bit error code with facility and error number
aMessage | The message to pass to the exception
ArticyApiException | ( | int | aErrorCode,
 |  | Exception | aInnerException
 | ) |  |
inline

Create an API exception with a specific error code

Parameters
aErrorCode | the 32 bit error code with facility and error number
aInnerException | an catched innter exception
ArticyApiException | ( | int | aErrorCode,
 |  | string | aMessage,
 |  | Exception | aInnerException
 | ) |  |
inline

Create an API exception with a specific error code

Parameters
aErrorCode | the 32 bit error code with facility and error number
aMessage | The message to pass to the exception
aInnerException | an catched innter exception
ArticyApiException ( ErrorCode aErrorCode )
inline

Create an API exception with a specific error code

Parameters
aErrorCode an error code from the API error code enumeration
ArticyApiException | ( | ErrorCode | aErrorCode,
 |  | string | aMessage
 | ) |  |
inline

Create an API exception with a specific error code

Parameters
aErrorCode | an error code from the API error code enumeration
aMessage | The message to pass to the exception
ArticyApiException | ( | ErrorCode | aErrorCode,
 |  | Exception | aInnerException
 | ) |  |
inline

Create an API exception with a specific error code

Parameters
aErrorCode | an error code from the API error code enumeration
aInnerException | an catched innter exception
ArticyApiException | ( | ErrorCode | aErrorCode,
 |  | string | aMessage,
 |  | Exception | aInnerException
 | ) |  |
inline

Create an API exception with a specific error code

Parameters
aErrorCode | an error code from the API error code enumeration
aMessage | The message to pass to the exception
aInnerException | an catched innter exception

Property Documentation

int ErrorCode
get

The error code this exception encapsulates, upper 16 bit are facility code, lower 16 bits are the error number within that facility

int FacilityCode
get

Getter that extracts the facility from the ErrorCode

int ErrorNumber
get

Getter that extracts the error number from the ErrorCode

override string Message
get

The formatted message of this exception


articy:draft API: CloseProjectArgs Class Reference

  • Api
  • CloseProjectArgs
Properties | List of all members
CloseProjectArgs Class Reference

Argument class for ApiSession.CloseProject More...

Inheritance diagram for CloseProjectArgs:
ComplexApiCallArgs

Properties

bool | LeaveExclusiveMode [get, set]
true if an eventual exclusive mode shall be left. If you want to explicitly keep up an exclusive mode when closing the project, set this parameter to false. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Argument class for ApiSession.CloseProject

Property Documentation

bool LeaveExclusiveMode
getset

true if an eventual exclusive mode shall be left. If you want to explicitly keep up an exclusive mode when closing the project, set this parameter to false.


articy:draft API: ComplexApiCallArgs Class Reference

  • Api
  • ComplexApiCallArgs
Properties | List of all members
ComplexApiCallArgs Class Reference

base class for the argument objects used for API calls that have many parameters More...

Inheritance diagram for ComplexApiCallArgs:
CloseProjectArgs ExportDataArgs ExportDocumentToDocxArgs GenericExportDataArgs OpenProjectArgs SimplePartitionActionArgs WaitForAssetProcessingArgs ExportObjectSelectionDataArgs ExportToAccessArgs ExportToFullXmlArgs ExportXlsxForReimportArgs UnclaimPartitionArgs ExportToDocxArgs ExportToXlsxArgs

Properties

string LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

base class for the argument objects used for API calls that have many parameters

Property Documentation

string LogSourceName
getset

The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback


articy:draft API: ExportDataArgs Class Reference

  • Api
  • ExportDataArgs
Properties | List of all members
ExportDataArgs Class Reference

The abstract base class for all specialized export arguments More...

Inheritance diagram for ExportDataArgs:
ComplexApiCallArgs ExportObjectSelectionDataArgs ExportToAccessArgs ExportToFullXmlArgs ExportXlsxForReimportArgs ExportToDocxArgs ExportToXlsxArgs

Properties

abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

The abstract base class for all specialized export arguments

Property Documentation

abstract string ExporterName
get

the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter

string Filename
getset

The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option.


articy:draft API: ExportDocumentToDocxArgs Class Reference

  • Api
  • ExportDocumentToDocxArgs
Properties | List of all members
ExportDocumentToDocxArgs Class Reference

The parameter args to be used for exporting a document object to Word More...

Inheritance diagram for ExportDocumentToDocxArgs:
ComplexApiCallArgs

Properties

string | Filename [get, set]
the output filename to use (the name is not modified in any way, so a .docx extension should be used) More...
bool | ExportCollapsed [get, set]
if false, only sections that are not collapsed get exported. Otherwise all sections are exported. [default: 'true'] More...
bool | ExportPreviewImages [get, set]
if true, the preview images are exported as inlined graphics. [default: 'true'] More...
bool | ExportMarkup [get, set]
if true, the text markup will be used in the export as well. if false, only the plain text conversion will be used. [default: 'true'] More...
bool | CreateCoverPage [get, set]
if true, a cover page will be created and the following content is moved to the next page. [default: 'true'] More...
bool | CreateTableOfContents [get, set]
if true, a table of content is created. [default: 'true'] More...
bool | CreateHeader [get, set]
if true, each page gets the documents display name as header. [default: 'true'] More...
bool | CreateFooter [get, set]
if true, each page gets the current page number as footer. [default: 'true'] More...
PageSize | PageSize [get, set]
Selects either A4 or Letter page size. More...
bool | Portrait [get, set]
if true, the word document gets portrait orientation, landscape otherwise. [default: 'true'] More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

The parameter args to be used for exporting a document object to Word

Property Documentation

string Filename
getset

the output filename to use (the name is not modified in any way, so a .docx extension should be used)

bool ExportCollapsed
getset

if false, only sections that are not collapsed get exported. Otherwise all sections are exported. [default: 'true']

bool ExportPreviewImages
getset

if true, the preview images are exported as inlined graphics. [default: 'true']

bool ExportMarkup
getset

if true, the text markup will be used in the export as well. if false, only the plain text conversion will be used. [default: 'true']

bool CreateCoverPage
getset

if true, a cover page will be created and the following content is moved to the next page. [default: 'true']

bool CreateTableOfContents
getset

if true, a table of content is created. [default: 'true']

bool CreateHeader
getset

if true, each page gets the documents display name as header. [default: 'true']

bool CreateFooter
getset

if true, each page gets the current page number as footer. [default: 'true']

PageSize PageSize
getset

Selects either A4 or Letter page size.

bool Portrait
getset

if true, the word document gets portrait orientation, landscape otherwise. [default: 'true']


articy:draft API: ExportObjectSelectionDataArgs Class Reference

  • Api
  • ExportObjectSelectionDataArgs
Properties | List of all members
ExportObjectSelectionDataArgs Class Reference

Abstract base class for all exports that allow pre-selection of to-be-exported objects. More...

Inheritance diagram for ExportObjectSelectionDataArgs:
ExportDataArgs ComplexApiCallArgs ExportToDocxArgs ExportToXlsxArgs

Properties

List< ObjectProxy > | PreselectedObjects [get, set]
A list of ObjectProxy instances describing the articy objects that shall be part of the export. Usually you just pass the result of a call to SimpleFindObjects, SimpleFindConflicts or ResultSet.Rows to this parameter. More...
- Properties inherited from ExportDataArgs
abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Abstract base class for all exports that allow pre-selection of to-be-exported objects.

Currently this are the office exports (DOCX and XLSX)

Property Documentation

List<ObjectProxy> PreselectedObjects
getset

A list of ObjectProxy instances describing the articy objects that shall be part of the export. Usually you just pass the result of a call to SimpleFindObjects, SimpleFindConflicts or ResultSet.Rows to this parameter.

Not all exports support selective exporting. (e.g. the XML export). Those exports will just ignore this list. The export may further reduce this list when the list contains object types that can't be exported (e.g. Pin objects) All exports allow empty list exports. The result depends on the parameters for the export


articy:draft API: ExportToAccessArgs Class Reference

  • Api
  • ExportToAccessArgs
Properties | List of all members
ExportToAccessArgs Class Reference

Specialized argument class for the articy:access export More...

Inheritance diagram for ExportToAccessArgs:
ExportDataArgs ComplexApiCallArgs

Properties

override string | ExporterName [get]
Fixes the exporter name to "AccessExport" More...
string | PackageFileName [get, set]
Name of the package to use More...
List< string > | CheckedPackages [get, set]
List of package names to export More...
- Properties inherited from ExportDataArgs
abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Specialized argument class for the articy:access export

Property Documentation

override string ExporterName
get

Fixes the exporter name to "AccessExport"

string PackageFileName
getset

Name of the package to use

List<string> CheckedPackages
getset

List of package names to export


articy:draft API: ExportToDocxArgs Class Reference

  • Api
  • ExportToDocxArgs
Properties | List of all members
ExportToDocxArgs Class Reference

Specialized argument class for the DOCX export More...

Inheritance diagram for ExportToDocxArgs:
ExportObjectSelectionDataArgs ExportDataArgs ComplexApiCallArgs

Properties

override string | ExporterName [get]
Fixes the name of that exporter to "DocxExport" More...
PageSize | PageSize [get, set]
The page size for created document. Defaults to "A4" More...
ExportGroupedBy | GroupedBy [get, set]
Determines in which way the objects are grouped. Defaults to "Folder" More...
ExportSortedBy | SortedBy [get, set]
Determines how the groups are sorted. Defaults to "DisplayName" More...
bool | HyperlinkOnReferences [get, set]
When set to true hyperlinks (with the articy:// protocol) are created on objects that can be used to navigate to that object when the project is currently open in an articy:draft client and the protocol is installed properly. Defaults to true More...
ExportMethod | ExportMethod [get, set]
Determines how many documents are created an how they are structured. Defaults to "Single" More...
bool | IncludeImages [get, set]
Determines if thumbnail images should be included in the document(s). Defaults to true More...
bool | SideBySideImages [get, set]
Determines if a bigger version of location images should be placed side by side to the created document(s). Defaults to false More...
bool | InsertTableOfContents [get, set]
Set to true when a table of contents should be included. Defaults to true More...
bool | IncludeTitlePage [get, set]
Set to true when a title page should be included. Defaults to true More...
bool | IncludeTechnicalNames [get, set]
Set to true when the technical names of the objects included. Defaults to false More...
bool | ExportQueries [get, set]
Determines if calculated strips should be exported More...
- Properties inherited from ExportObjectSelectionDataArgs
List< ObjectProxy > | PreselectedObjects [get, set]
A list of ObjectProxy instances describing the articy objects that shall be part of the export. Usually you just pass the result of a call to SimpleFindObjects, SimpleFindConflicts or ResultSet.Rows to this parameter. More...
- Properties inherited from ExportDataArgs
abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Specialized argument class for the DOCX export

Property Documentation

override string ExporterName
get

Fixes the name of that exporter to "DocxExport"

PageSize PageSize
getset

The page size for created document. Defaults to "A4"

ExportGroupedBy GroupedBy
getset

Determines in which way the objects are grouped. Defaults to "Folder"

ExportSortedBy SortedBy
getset

Determines how the groups are sorted. Defaults to "DisplayName"

bool HyperlinkOnReferences
getset

When set to true hyperlinks (with the articy:// protocol) are created on objects that can be used to navigate to that object when the project is currently open in an articy:draft client and the protocol is installed properly. Defaults to true

ExportMethod ExportMethod
getset

Determines how many documents are created an how they are structured. Defaults to "Single"

bool IncludeImages
getset

Determines if thumbnail images should be included in the document(s). Defaults to true

bool SideBySideImages
getset

Determines if a bigger version of location images should be placed side by side to the created document(s). Defaults to false

bool InsertTableOfContents
getset

Set to true when a table of contents should be included. Defaults to true

bool IncludeTitlePage
getset

Set to true when a title page should be included. Defaults to true

bool IncludeTechnicalNames
getset

Set to true when the technical names of the objects included. Defaults to false

bool ExportQueries
getset

Determines if calculated strips should be exported


articy:draft API: ExportToFullXmlArgs Class Reference

  • Api
  • ExportToFullXmlArgs
Properties | List of all members
ExportToFullXmlArgs Class Reference

Specialized argument class for the XML export This export currently has no other configuration options More...

Inheritance diagram for ExportToFullXmlArgs:
ExportDataArgs ComplexApiCallArgs

Properties

bool | ExportMarkup [get, set]
Set to true when the html/css based markup string sould be exported. Defaults to false More...
bool | ExportQueries [get, set]
Determines if calculated strips should be exported More...
bool | WriteNamespace [get, set]
Determines if the default namespace declaration should be written More...
bool | WriteAllVariables [get, set]
Determines if the all variable values should be written for journey points More...
override string | ExporterName [get]
Fixes the exporter name to "XmlContentExport" More...
- Properties inherited from ExportDataArgs
abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Specialized argument class for the XML export This export currently has no other configuration options

Property Documentation

bool ExportMarkup
getset

Set to true when the html/css based markup string sould be exported. Defaults to false

bool ExportQueries
getset

Determines if calculated strips should be exported

bool WriteNamespace
getset

Determines if the default namespace declaration should be written

bool WriteAllVariables
getset

Determines if the all variable values should be written for journey points

override string ExporterName
get

Fixes the exporter name to "XmlContentExport"


articy:draft API: ExportToXlsxArgs Class Reference

  • Api
  • ExportToXlsxArgs
Properties | List of all members
ExportToXlsxArgs Class Reference

Specialized argument class for the XLSX export More...

Inheritance diagram for ExportToXlsxArgs:
ExportObjectSelectionDataArgs ExportDataArgs ComplexApiCallArgs

Properties

override string | ExporterName [get]
Fixes the name of that exporter to "XlsxExport" More...
PageSize | PageSize [get, set]
The page size for created document. Defaults to "A4" More...
ExportGroupedBy | GroupedBy [get, set]
Determines in which way the objects are grouped. Defaults to "ObjectType" More...
bool | TablePerGroup [get, set]
When set to true a separate sheet is created for any group. Defaults to false More...
ExportSortedBy | SortedBy [get, set]
Determines how the groups are sorted. Defaults to "DisplayName" More...
ExportWhichName | WhichName [get, set]
Determines which naming should be used for feature/property names and for object references. Defaults to "TechnicalName" More...
ExportFeatureOrder | FeatureOrder [get, set]
Determines the sorting of features. Defaults to "Alphabetical" More...
bool | CollectStatistics [get, set]
If set to true each group get an additional statistics block with information depending on the data type of the column. Defaults to false More...
bool | ExportMarkup [get, set]
Set to true when the html/css based markup string sould be exported. Defaults to false More...
bool | ExportQueries [get, set]
Determines if calculated strips should be exported More...
- Properties inherited from ExportObjectSelectionDataArgs
List< ObjectProxy > | PreselectedObjects [get, set]
A list of ObjectProxy instances describing the articy objects that shall be part of the export. Usually you just pass the result of a call to SimpleFindObjects, SimpleFindConflicts or ResultSet.Rows to this parameter. More...
- Properties inherited from ExportDataArgs
abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Specialized argument class for the XLSX export

Property Documentation

override string ExporterName
get

Fixes the name of that exporter to "XlsxExport"

PageSize PageSize
getset

The page size for created document. Defaults to "A4"

ExportGroupedBy GroupedBy
getset

Determines in which way the objects are grouped. Defaults to "ObjectType"

bool TablePerGroup
getset

When set to true a separate sheet is created for any group. Defaults to false

ExportSortedBy SortedBy
getset

Determines how the groups are sorted. Defaults to "DisplayName"

ExportWhichName WhichName
getset

Determines which naming should be used for feature/property names and for object references. Defaults to "TechnicalName"

ExportFeatureOrder FeatureOrder
getset

Determines the sorting of features. Defaults to "Alphabetical"

bool CollectStatistics
getset

If set to true each group get an additional statistics block with information depending on the data type of the column. Defaults to false

bool ExportMarkup
getset

Set to true when the html/css based markup string sould be exported. Defaults to false

bool ExportQueries
getset

Determines if calculated strips should be exported


articy:draft API: ExportXlsxForReimportArgs Class Reference

  • Api
  • ExportXlsxForReimportArgs
Public Types | Properties | List of all members
ExportXlsxForReimportArgs Class Reference

Argument class for the XLSX export for Re-Import More...

Inheritance diagram for ExportXlsxForReimportArgs:
ExportDataArgs ComplexApiCallArgs

Public Types

enum SortObjectsBy { DisplayName, TechnicalName, Id, Parent }
Specifies the property that is used to sort the objects to be exported More...

Properties

override string | ExporterName [get]
String | SelectedProperties [get, set]
a semicolon separated list of properties of objects to include in export More...
ExportSortedBy | SortedBy [get, set]
Determines how the groups are sorted. Defaults to "TechnicalName" More...
bool | ExportQueries [get, set]
Determines if calculated strips should be exported More...
- Properties inherited from ExportDataArgs
abstract string | ExporterName [get]
the name of the exporter that is responsible to process these settings. Specialized exporter DataArgs will override this property getter More...
string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Argument class for the XLSX export for Re-Import

Member Enumeration Documentation

enum SortObjectsBy

Specifies the property that is used to sort the objects to be exported

Enumerator
DisplayName | Objects are sorted by their display name
TechnicalName | Objects are sorted by their technical name
Id | Objects are sorted by their ID
Parent | Objects are sorted by the technical name of their parent

Property Documentation

String SelectedProperties
getset

a semicolon separated list of properties of objects to include in export

ExportSortedBy SortedBy
getset

Determines how the groups are sorted. Defaults to "TechnicalName"

bool ExportQueries
getset

Determines if calculated strips should be exported


articy:draft API: FlowListNode Class Reference

  • Api
  • FlowListNode
Properties | List of all members
FlowListNode Class Reference

Contains the information about a single node in the flow linearization More...

Properties

int | IndentionLevel [get]
Indention level of the node when submerging is used More...
int | LocalOrder [get]
the order number of all nodes of the same hierarchy level More...
bool | ApplyNumbering [get]
true if numbering should be used, false otherwise, dialog fragments don't use numbering More...
bool | SkipJumps [get]
true if the there is no jump section required, false otherwise. the following conditions must be met to have the true value:

  • no unconnected thread exist
  • only one following node
  • that is not the EndOfThread marker
  • and is not the last entry in the document and links to the directly following entry
More...
ObjectProxy | Node [get]
The node object in the flow that this object describes More...
List< FlowReference > | JumpTargets [get]
a list of targets to which this object is connected More...
List< FlowReference > | UnconnectedThreads [get]
a list of entry object references that have no connection to this node, but are children More...
FlowListNode | Parent [get]
The parent object for this node, to be used for example to ascend to create a hierarchical document numbering. for the first element this property is null More...

Detailed Description

Contains the information about a single node in the flow linearization

Property Documentation

int IndentionLevel
get

Indention level of the node when submerging is used

int LocalOrder
get

the order number of all nodes of the same hierarchy level

bool ApplyNumbering
get

true if numbering should be used, false otherwise, dialog fragments don't use numbering

bool SkipJumps
get

true if the there is no jump section required, false otherwise. the following conditions must be met to have the true value:

  • no unconnected thread exist
  • only one following node
  • that is not the EndOfThread marker
  • and is not the last entry in the document and links to the directly following entry

ObjectProxy Node
get

The node object in the flow that this object describes

List<FlowReference> JumpTargets
get

a list of targets to which this object is connected

List<FlowReference> UnconnectedThreads
get

a list of entry object references that have no connection to this node, but are children

FlowListNode Parent
get

The parent object for this node, to be used for example to ascend to create a hierarchical document numbering. for the first element this property is null


articy:draft API: FlowReference Class Reference

  • Api
  • FlowReference
Public Types | Public Member Functions | Properties | List of all members
FlowReference Class Reference

Contains the information about a reference in the flow linearization More...

Public Types

enum RefType {
Local, Submerging, Emerging, Jump,
EndOfThread
}
the different types of references More...

Public Member Functions

override string ToString ()

Properties

bool | IsInternalReference [get]
true when the referenced target object is part of the created list, so an "internal" link could be created
ObjectProxy | ReferencedTarget [get]
the flow node object that is referenced (use this to create text marks or cross ref names)
ObjectProxy | ContextTarget [get]
contains the pin that is connected on the ReferencedTarget (use this to create the info of a hyperlink)
ObjectProxy | Connection [get]
the connection object used to reach the element (this may be used later for collecting the label)
RefType | ReferenceType [get]
describes thy type of reference
bool | IsInnerReference [get]
this property is true if the reference is either a local or submerging reference

Detailed Description

Contains the information about a reference in the flow linearization

Member Enumeration Documentation

enum RefType

the different types of references


articy:draft API: GenericExportDataArgs Class Reference

  • Api
  • GenericExportDataArgs
Properties | List of all members
GenericExportDataArgs Class Reference

When using the method ApiSession.ExportData an instance of this object needs to be passed along. More...

Inheritance diagram for GenericExportDataArgs:
ComplexApiCallArgs

Properties

string | Filename [get, set]
The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option. More...
List< ObjectProxy > | PreselectedObjects [get, set]
A list of ObjectProxy instances describing the articy objects that shall be part of the export. Usually you just pass the result of a call to SimpleFindObjects, SimpleFindConflicts or ResultSet.Rows to this parameter. More...
string | TextConfiguration [get, set]
Configuration of detailed export parameter as XML-snippet. These parameters reflect those of the right side of the export dialog in articy:draft. More...
XmlDocument | XmlConfiguration [get, set]
Same as TextConfiguration but already as parsed XML object More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

When using the method ApiSession.ExportData an instance of this object needs to be passed along.

Property Documentation

string Filename
getset

The fully qualified filename (or path name) of the export file that is to be written. The word export for example interprets this member as path name if you use the "one file per object" option.

List<ObjectProxy> PreselectedObjects
getset

A list of ObjectProxy instances describing the articy objects that shall be part of the export. Usually you just pass the result of a call to SimpleFindObjects, SimpleFindConflicts or ResultSet.Rows to this parameter.

Not all exports support selective exporting. (e.g. the XML export). Those exports will just ignore this list. The export may further reduce this list when the list contains object types that can't be exported (e.g. Pin objects) All exports allow empty list exports. The result depends on the parameters for the export

string TextConfiguration
getset

Configuration of detailed export parameter as XML-snippet. These parameters reflect those of the right side of the export dialog in articy:draft.

Sample XML files with configurations for the different exports can be found in the samples dir of the API installation or in the programmers guide.

XmlDocument XmlConfiguration
getset

Same as TextConfiguration but already as parsed XML object


articy:draft API: JourneyPointAction Class Reference

  • Api
  • JourneyPointAction
Properties | List of all members
JourneyPointAction Class Reference

Properties

ObjectProxy | Target [get]
JourneyActionTypes | Action [get]


articy:draft API: ObjectPropertyInfo Class Reference

  • Api
  • ObjectPropertyInfo
Public Member Functions | Properties | List of all members
ObjectPropertyInfo Class Reference

This class aggregates information about a single property that is exposed from ObjectProxy More...

Public Member Functions

string | GetNameOfEnumValue (object aVal)
Convenience method to convert a value from an enum property (as returned from the get indexer) to its technical name of the enumeration. More...
bool | TryGetEnumValueByName (string aName, out int aIndex)

Properties

PropertyDataType | DataType [get]
The data type of the object More...
PropertyDataSubType | DataSubType [get]
The data type of the object More...
bool | ReadOnly [get]
Denotes if the property can be changed. This member is fixed for a property an never changes. More...
bool | IsCustomProperty [get]
Denotes if the property was introduced by an feature (true) or is a property that is exposed by the object itself (false) More...
bool | IsCalculated [get]
Denotes if the property is calculated from other properties. More...
bool | SupportsExpressoScript [get]
Denotes if the property can be parsed as expresso-script (only used by text properties) More...
string | Name [get, set]
the name of the property More...
Dictionary< int, String > | EnumValues [get]
if the property is an enum, this member is not null and contains an dictionary to look up technical/symbol names for given enum values More...

Detailed Description

This class aggregates information about a single property that is exposed from ObjectProxy

Member Function Documentation

string GetNameOfEnumValue ( object aVal )
inline

Convenience method to convert a value from an enum property (as returned from the get indexer) to its technical name of the enumeration.

Parameters
aVal the value taken from the object
Returns
the technical name of the enum value or null if no name exists for the given value.

Property Documentation

PropertyDataType DataType
get

The data type of the object

PropertyDataSubType DataSubType
get

The data type of the object

bool ReadOnly
get

Denotes if the property can be changed. This member is fixed for a property an never changes.

The ReadOnly member of Articy.Api.ObjectProxy can change its state when the object is claimed. All calculated or synthetic properties are always readonly, some other properties might be readonly to preserve data consistency.

bool IsCustomProperty
get

Denotes if the property was introduced by an feature (true) or is a property that is exposed by the object itself (false)

bool IsCalculated
get

Denotes if the property is calculated from other properties.

bool SupportsExpressoScript
get

Denotes if the property can be parsed as expresso-script (only used by text properties)

string Name
getset

the name of the property

Dictionary<int, String> EnumValues
get

if the property is an enum, this member is not null and contains an dictionary to look up technical/symbol names for given enum values


articy:draft API: ObjectPropertyNames Class Reference

  • Api
  • ObjectPropertyNames
List of all members
ObjectPropertyNames Class Reference

This class contains constants for all properties that are introduced by the base objects of articy:draft. More...

Public Attributes

Common property names

These are the properties that many objects have in common.

const string | ObjectType = "ObjectType"
The objects type name [enum, non empty] More...
const string | TemplateName = "TemplateName"
The technical name of an objects template or an empty string if not template was set [string] More...
const string | Parent = "Parent"
The object reference to the objects parent or null when object has no parent (like the project's root object). More...
const string | DisplayName = "DisplayName"
The display name as it can be seen in the navigator [string, non empty] More...
const string | TechnicalName = "TechnicalName"
The TechnicalName as it can be found in the objects property sheet [string, valid identifier names only] More...
const string | Text = "Text"
The Text/Description/Spoken text element of most objects [string] More...
const string | MarkupText = "MarkupText"
The Text/Description/Spoken text element of most objects including all markup [string] More...
const string | BBCodeText = "BBCodeText"
The Text/Description/Spoken text element of most objects as bb markup text [string] More...
const string | Color = "Color"
The color of the object [System.Windows.Media.Color] More...
const string | Url = "Url"
the articy:// protocol Url of the object More...
const string | Attachments = "Attachments"
The name of the property containing the object's attachments. This property can only be used with the object list management methods. The list returned from ObjectProxy.GetAttachments is only a read-only list containing current objects. [IList<ObjectProxy>] More...
const string | PreviewImageAsset = "PreviewImageAsset"
some objects like zones or locations offer a preview image, you can set it using this parameter. [ObjectProxy, only Assets of type Image] More...
const string | ShortId = "ShortId"
The short/articy:access Id as it can be found in the objects property sheet. [int] More...
const string | ExternalId = "ExternalId"
The external Id as it can be found in the objects property sheet. [string] More...
const string | PosX = "PosX"
X position of a flow-item. More...
const string | PosY = "PosY"
Y position of a flow-item. More...
const string | ZIndex = "ZIndex"
the z-index of a flow-item More...
const string | Width = "Width"
the width of a flow-item. More...
const string | Height = "Height"
the Height of a flow-item. More...
const string | Id = "Id"
The Id of an asset. [ulong, read-only] More...
const string | ShowCalculatedDisplayName = "ShowCalculatedDisplayName"
Determines if the calculated display name of an object should be shown. [boolean] More...
const string | Expression = "Expression"
A text field which is used as an expression. More...
const string | Target = "Target"
The target object of a connection. [ObjectProxy, read-only] More...
const string | TargetPin = "TargetPin"
The Pin object of the referenced target object of the connection. [ObjectProxy, read-only] More...
const string | Visibility = "Visibility"
Determines if an object is visible. [Enum (int), e.g. Invisible, Visible] More...
const string | Selectability = "Selectability"
Determines if an object is selectable. [Enum (int), e.g. Unselectable, Selectable] More...
const string | LinkStyleType = "LinkStyleType"
Determines the style type for a link. [Enum (int), e.g. Inherited, PreviewImage, IconOnly, Minimal] More...
const string | LinkStyleSize = "LinkStyleSize"
Determines the style size for a link. [Enum (int), e.g. Inherited, Large, Medium, Small] More...
const string | ShowDisplayName = "ShowDisplayName"
Determines if the display name of an object should be shown. [boolean] More...
const string | DisplayNameColor = "DisplayNameColor"
The color of an object's display name. [System.Windows.Media.Color] More...
const string | DisplayNameSize = "DisplayNameSize"
The size of an object's display name. [int] More...
const string | DropShadow = "DropShadow"
Determines if the drop shadow of an object's display name should be shown. [boolean] More...
const string | SpotStyleType = "SpotStyleType"
Determines the style type for a spot. [Enum (int), e.g. Inherited, Flag, Cross] More...
const string | SpotStyleSize = "SpotStyleSize"
Determines the style type for a link. [Enum (int), e.g. Inherited, Large, Medium, Small] More...
const string | ShapeType = "ShapeType"
The type of a zone. [Enum (int) e.g. Invalid, Spot, Circle, Rectangle, Path, Polygon, Link ] More...
const string | DisplayNamePosX = "DisplayNamePosX"
The X coordinate of a display name's position. [double] More...
const string | DisplayNamePosY = "DisplayNamePosY"
The Y coordinate of a display name's position. [double] More...
const string | AutoDisplayNamePosition = "AutoDisplayNamePosition"
Determines if the display name of an object should be positioned automatically. [boolean] More...
const string | TransformRotation = "TransformRotation"
The value of a transform's rotation in degrees. [double] More...
const string | TransformXAxisX = "TransformXAxisX"
The X value of a transform's X-Axis vector. [double] More...
const string | TransformXAxisY = "TransformXAxisY"
The Y value of a transform's X-Axis vector. [double] More...
const string | TransformYAxisX = "TransformYAxisX"
The X value of a transform's Y-Axis vector. [double] More...
const string | TransformYAxisY = "TransformYAxisY"
The Y value of a transform's Y-Axis vector. [double] More...
const string | TransformPivotX = "TransformPivotX"
The X coordinate of a transform's pivot position. [double] More...
const string | TransformPivotY = "TransformPivotY"
The Y coordinate of a transform's pivot position. [double] More...
const string | OutlineColor = "OutlineColor"
The outline color of an object. [System.Windows.Media.Color] More...
const string | OutlineSize = "OutlineSize"
The outline size of an object. [double] More...
const string | OutlineStyle = "OutlineStyle"
The outline style of an object. [Enum (int), e.g. Solid, Dot, Dash, DashDot, DashDotDot] More...
const string | FillColor = "FillColor"
The fill color of an object. [System.Windows.Media.Color] More...
const string | ScriptingName = "ScriptingName"
The scripting name of an object. [string] More...
properties for "DialogFragment" only
const string | StageDirections = "StageDirections"
the stage directions of a dialog fragment [string] More...
const string | Speaker = "Speaker"
the speaking entity of the dialog fragment. [ObjectProxy, "Entity" objects only] More...
const string | MenuText = "MenuText"
the preview/menu text of the dialog fragment. [string] More...
properties for "Asset" only
const string | FileSize = "FileSize"
The size of the asset on disk. [long, read-only] More...
const string | FileType = "FileType"
The file type as reported by the shell. [string, read-only] More...
const string | FileExtension = "FileExtension"
The file's extension. [string, read-only] More...
const string | FilePath = "FilePath"
the asset's relative file path relative to the currently used project folder. [string, read-only] More...
const string | AbsoluteFilePath = "AbsoluteFilePath"
the asset's qualified absolute file path including the currently used project folder. [string, read-only] More...
const string | Filename = "Filename"
The filename of the asset in the project dir. only contains the name [string, read-only] More...
const string | AssetFilename = "Filename"
The filename of the asset in the project dir. only contains the name [string, read-only] deprecated use "Filename" instead More...
const string | AssetCategory = "AssetCategory"
The category of the asset. [Enum (int), read-only] More...
const string | AssetState = "AssetState"
The state of the asset (Ready, Importing, ...) When using one the ApiSession.ImportAsset overloads you will discover state changes on the returned object [enum (int), read-only, volatile] More...
const string | OriginalSource = "OriginalSource"
The full filename of the location this asset was initially imported. [string, read-only] More...
properties for "Comment" only
const string | CreatedOn = "CreatedOn"
The timestamp of the creation of the comment in UTC time. [DateTime, read-only] More...
const string | CreatedBy = "CreatedBy"
The name of the creator of the comment [string, read-only] More...
properties for "Connection" only
const string | Label = "Label"
The label text for the connection [string] More...
const string | ShowLabel = "ShowLabel"
Determines if the label should be shown [boolean] More...
const string | Source = "Source"
The source object of the connection [ObjectProxy, read-only] More...
const string | SourcePin = "SourcePin"
The Pin object of the referenced source object of the connection [ObjectProxy, read-only] More...
properties for "Note" only
const string | Content = "Content"
The content of a Note in the XML markup notation. The XML conforms the ScratchpadDocument.xsd. [string, read-only, XML markup] More...
properties for "Pin" only
const string | PinIndex = "PinIndex"
The index of the pin in a top down order as it is connected to an element of the flow. [int, read-only] More...
const string | PinType = "PinType"
The type of the pin. [Enum (int) e.g. Invalid, Input, Output] More...
properties for "Zone/Path" only
const string | StartCap = "StartCap"
Defines the starting element of a path. [Enum (int), e.g. ColoredDot, None, LineArrowHead, FilledArrowHead, Diamond, Square, Disc] More...
const string | EndCap = "EndCap"
Defines the ending element of a path. [Enum (int), e.g. ColoredDot, None, LineArrowHead, FilledArrowHead, Diamond, Square, Disc] More...
const string | LineWidth = "LineWidth"
Defines the line thickness of a path. [double] More...
properties for "Location" only

The properties are additionally available for Location objects

const string | ShowDisplayNameForLink = "ShowDisplayNameForLink"
Determines if the display name of a link should be shown. [boolean] More...
const string | ShowDisplayNameForSpot = "ShowDisplayNameForSpot"
Determines if the display name of a spot should be shown. [boolean] More...
const string | ShowDisplayNameForZone = "ShowDisplayNameForZone"
Determines if the display name of a zone should be shown. [boolean] More...
const string | ShowDisplayNameForPath = "ShowDisplayNameForPath"
Determines if the display name of a path should be shown. [boolean] More...
const string | ShowDisplayNameForImage = "ShowDisplayNameForImage"
Determines if the display name of an image should be shown. [boolean] More...
const string | DisplayNameColorForLink = "DisplayNameColorForLink"
The color of a link's display name. [System.Windows.Media.Color] More...
const string | DisplayNameColorForSpot = "DisplayNameColorForSpot"
The color of a spot's display name. [System.Windows.Media.Color] More...
const string | DisplayNameColorForZone = "DisplayNameColorForZone"
The color of a zone's display name. [System.Windows.Media.Color] More...
const string | DisplayNameColorForPath = "DisplayNameColorForPath"
The color of a path's display name. [System.Windows.Media.Color] More...
const string | DisplayNameColorForImage = "DisplayNameColorForImage"
The color of an image's display name. [System.Windows.Media.Color] More...
const string | DisplayNameSizeForLink = "DisplayNameSizeForLink"
The size of a link's display name. [int] More...
const string | DisplayNameSizeForSpot = "DisplayNameSizeForSpot"
The size of a spot's display name. [int] More...
const string | DisplayNameSizeForZone = "DisplayNameSizeForZone"
The size of a zone's display name. [int] More...
const string | DisplayNameSizeForPath = "DisplayNameSizeForPath"
The size of a path's display name. [int] More...
const string | DisplayNameSizeForImage = "DisplayNameSizeForImage"
The size of an image's display name. [int] More...
const string | DropShadowForLink = "DropShadowForLink"
Determines if the display name drop shadow of a link should be shown. [boolean] More...
const string | DropShadowForSpot = "DropShadowForSpot"
Determines if the display name drop shadow of a spot should be shown. [boolean] More...
const string | DropShadowForZone = "DropShadowForZone"
Determines if the display name drop shadow of a zone should be shown. [boolean] More...
const string | DropShadowForPath = "DropShadowForPath"
const string | DropShadowForImage = "DropShadowForImage"
const string | DropShadowForText = "DropShadowForText"
properties for "Location Image" only

These properties are additionally present in Location Image objects

const string | ImageOpacity = "ImageOpacity"
The opacity of a location image. [double, 0.0 - 1.0] More...
const string | ImageAsset = "ImageAsset"
The asset of a location image. [ObjectProxy] More...
properties for "Location Text" only

These properties are additionally present in Location Text objects

const string | ForcedWidth = "ForcedWidth"
Determines the fixed width of a location text object. [double] More...
const string | ForcedHeight = "ForcedHeight"
Determines the fixed height of a location text object. [double] More...
properties for "Journey" only

These properties are additionally present in Journey objects

const string | JourneyState = "JourneyState"
the state of the journey [Enum (int)] More...
const string | JourneyPoints = "JourneyPoints"
a read-only list of JouneyPoint objects. [IList<ObjectProxy>, read-only] More...
const string | Namespaces = "Namespaces"
a read-only list of Journey namespaces. [IList<ObjectProxy>, read-only] More...
properties for "JourneyPoints" only

These properties are additionally present in JourneyPoint objects

const string | JourneyPointType = "JourneyPointType"
The type of this point in the journey. [Enum (int), read-only] More...
const string | IdxInJourney = "IdxInJourney"
The index this journey point has in the list of points in the Journey [int, read-only] More...
const string | ReachedByActionType = "ReachedByActionType"
describes by what action this journey point was reached [Enum (int), read-only] More...
const string | ObjectReference = "ObjectReference"
describes which object is referenced by this journey point. When "JourneyPointType" is one of "InputPinSelection", "OutputPinSelection" or "Pin", the referenced object is a pin (whose parent is the owning object) otherwise its an "normal" flow object. [ObjectProxy, read-only] More...
properties for "Variable" only

These properties are additionally present in Variable objects

const string | Description = "Description"
The description of a variable. [string] More...
const string | DataType = "DataType"
The data type of a variable. [Enum (int), e.g. Integer, Boolean] More...
const string | DefaultValue = "DefaultValue"
the string representation of the default value of a variable More...
const string | BooleanValue = "BooleanValue"
A boolean evaluation of the default value. If the variable has integer type, 0 evaluates to false, any other to true More...
const string | NumericValue = "NumericValue"
A numeric (double) evaluation of the default value. If the variable has boolean type, false evaluates to 0.0, true to 1.0 More...
properties for "VariableSet" only

These properties are additionally present in Variable objects

const string | Variables = "Variables"
A read-only list of the variables of a variable set. [IList<ObjectProxy>, read-only] More...

Detailed Description

This class contains constants for all properties that are introduced by the base objects of articy:draft.

You can find type infos and restrictions in braces after the name

Member Data Documentation

const string ObjectType = "ObjectType"

The objects type name [enum, non empty]

const string TemplateName = "TemplateName"

The technical name of an objects template or an empty string if not template was set [string]

const string Parent = "Parent"

The object reference to the objects parent or null when object has no parent (like the project's root object).

Connections are rooted in the container that also contain the other flow objects. The parent of a Pin object is the flow object it is connected to

const string DisplayName = "DisplayName"

The display name as it can be seen in the navigator [string, non empty]

Check ObjectProxy.HasDisplayName to check whether an object has this property. (E.g. Connections do not have a DisplayName)

const string TechnicalName = "TechnicalName"

The TechnicalName as it can be found in the objects property sheet [string, valid identifier names only]

Check ObjectProxy.HasTechnicalName to check whether an object has this property. (E.g. SystemFolder objects like "Entities" do not have technical names)

const string Text = "Text"

The Text/Description/Spoken text element of most objects [string]

Check ObjectProxy.HasText to check whether an object has this property. (E.g. Pin or Connections do not have this property)

const string MarkupText = "MarkupText"

The Text/Description/Spoken text element of most objects including all markup [string]

Check ObjectProxy.HasText to check whether an object has this property. (E.g. Pin or Connections do not have this property)

const string BBCodeText = "BBCodeText"

The Text/Description/Spoken text element of most objects as bb markup text [string]

Check ObjectProxy.HasText to check whether an object has this property. (E.g. Pin or Connections do not have this property)

const string Color = "Color"

The color of the object [System.Windows.Media.Color]

Check ObjectProxy.HasColor to check whether an object has this property. (E.g. Pin or Connections do not have this property)

const string Url = "Url"

the articy:// protocol Url of the object

const string Attachments = "Attachments"

The name of the property containing the object's attachments. This property can only be used with the object list management methods. The list returned from ObjectProxy.GetAttachments is only a read-only list containing current objects. [IList<ObjectProxy>]

Check ObjectProxy.CanHaveAttachments to check whether an object has this property. (E.g. Pin or Connections do not have this property)

const string PreviewImageAsset = "PreviewImageAsset"

some objects like zones or locations offer a preview image, you can set it using this parameter. [ObjectProxy, only Assets of type Image]

Check ObjectProxy.HasPreviewImage to check whether an object has this property. (E.g. Pin or Connections do not have this property)

const string ShortId = "ShortId"

The short/articy:access Id as it can be found in the objects property sheet. [int]

Write with care to keep these Ids unique.

const string ExternalId = "ExternalId"

The external Id as it can be found in the objects property sheet. [string]

const string PosX = "PosX"

X position of a flow-item.

const string PosY = "PosY"

Y position of a flow-item.

const string ZIndex = "ZIndex"

the z-index of a flow-item

const string Width = "Width"

the width of a flow-item.

const string Height = "Height"

the Height of a flow-item.

const string Id = "Id"

The Id of an asset. [ulong, read-only]

const string ShowCalculatedDisplayName = "ShowCalculatedDisplayName"

Determines if the calculated display name of an object should be shown. [boolean]

const string Expression = "Expression"

A text field which is used as an expression.

const string Target = "Target"

The target object of a connection. [ObjectProxy, read-only]

const string TargetPin = "TargetPin"

The Pin object of the referenced target object of the connection. [ObjectProxy, read-only]

const string Visibility = "Visibility"

Determines if an object is visible. [Enum (int), e.g. Invisible, Visible]

const string Selectability = "Selectability"

Determines if an object is selectable. [Enum (int), e.g. Unselectable, Selectable]

const string LinkStyleType = "LinkStyleType"

Determines the style type for a link. [Enum (int), e.g. Inherited, PreviewImage, IconOnly, Minimal]

const string LinkStyleSize = "LinkStyleSize"

Determines the style size for a link. [Enum (int), e.g. Inherited, Large, Medium, Small]

const string ShowDisplayName = "ShowDisplayName"

Determines if the display name of an object should be shown. [boolean]

const string DisplayNameColor = "DisplayNameColor"

The color of an object's display name. [System.Windows.Media.Color]

const string DisplayNameSize = "DisplayNameSize"

The size of an object's display name. [int]

const string DropShadow = "DropShadow"

Determines if the drop shadow of an object's display name should be shown. [boolean]

const string SpotStyleType = "SpotStyleType"

Determines the style type for a spot. [Enum (int), e.g. Inherited, Flag, Cross]

const string SpotStyleSize = "SpotStyleSize"

Determines the style type for a link. [Enum (int), e.g. Inherited, Large, Medium, Small]

const string ShapeType = "ShapeType"

The type of a zone. [Enum (int) e.g. Invalid, Spot, Circle, Rectangle, Path, Polygon, Link ]

const string DisplayNamePosX = "DisplayNamePosX"

The X coordinate of a display name's position. [double]

const string DisplayNamePosY = "DisplayNamePosY"

The Y coordinate of a display name's position. [double]

const string AutoDisplayNamePosition = "AutoDisplayNamePosition"

Determines if the display name of an object should be positioned automatically. [boolean]

const string TransformRotation = "TransformRotation"

The value of a transform's rotation in degrees. [double]

const string TransformXAxisX = "TransformXAxisX"

The X value of a transform's X-Axis vector. [double]

const string TransformXAxisY = "TransformXAxisY"

The Y value of a transform's X-Axis vector. [double]

const string TransformYAxisX = "TransformYAxisX"

The X value of a transform's Y-Axis vector. [double]

const string TransformYAxisY = "TransformYAxisY"

The Y value of a transform's Y-Axis vector. [double]

const string TransformPivotX = "TransformPivotX"

The X coordinate of a transform's pivot position. [double]

const string TransformPivotY = "TransformPivotY"

The Y coordinate of a transform's pivot position. [double]

const string OutlineColor = "OutlineColor"

The outline color of an object. [System.Windows.Media.Color]

const string OutlineSize = "OutlineSize"

The outline size of an object. [double]

const string OutlineStyle = "OutlineStyle"

The outline style of an object. [Enum (int), e.g. Solid, Dot, Dash, DashDot, DashDotDot]

const string FillColor = "FillColor"

The fill color of an object. [System.Windows.Media.Color]

const string ScriptingName = "ScriptingName"

The scripting name of an object. [string]

const string StageDirections = "StageDirections"

the stage directions of a dialog fragment [string]

const string Speaker = "Speaker"

the speaking entity of the dialog fragment. [ObjectProxy, "Entity" objects only]

const string MenuText = "MenuText"

the preview/menu text of the dialog fragment. [string]

const string FileSize = "FileSize"

The size of the asset on disk. [long, read-only]

const string FileType = "FileType"

The file type as reported by the shell. [string, read-only]

const string FileExtension = "FileExtension"

The file's extension. [string, read-only]

const string FilePath = "FilePath"

the asset's relative file path relative to the currently used project folder. [string, read-only]

const string AbsoluteFilePath = "AbsoluteFilePath"

the asset's qualified absolute file path including the currently used project folder. [string, read-only]

const string Filename = "Filename"

The filename of the asset in the project dir. only contains the name [string, read-only]

const string AssetFilename = "Filename"

The filename of the asset in the project dir. only contains the name [string, read-only] deprecated use "Filename" instead

const string AssetCategory = "AssetCategory"

The category of the asset. [Enum (int), read-only]

const string AssetState = "AssetState"

The state of the asset (Ready, Importing, ...) When using one the ApiSession.ImportAsset overloads you will discover state changes on the returned object [enum (int), read-only, volatile]

const string OriginalSource = "OriginalSource"

The full filename of the location this asset was initially imported. [string, read-only]

const string CreatedOn = "CreatedOn"

The timestamp of the creation of the comment in UTC time. [DateTime, read-only]

const string CreatedBy = "CreatedBy"

The name of the creator of the comment [string, read-only]

const string Label = "Label"

The label text for the connection [string]

const string ShowLabel = "ShowLabel"

Determines if the label should be shown [boolean]

const string Source = "Source"

The source object of the connection [ObjectProxy, read-only]

const string SourcePin = "SourcePin"

The Pin object of the referenced source object of the connection [ObjectProxy, read-only]

const string Content = "Content"

The content of a Note in the XML markup notation. The XML conforms the ScratchpadDocument.xsd. [string, read-only, XML markup]

const string PinIndex = "PinIndex"

The index of the pin in a top down order as it is connected to an element of the flow. [int, read-only]

const string PinType = "PinType"

The type of the pin. [Enum (int) e.g. Invalid, Input, Output]

const string StartCap = "StartCap"

Defines the starting element of a path. [Enum (int), e.g. ColoredDot, None, LineArrowHead, FilledArrowHead, Diamond, Square, Disc]

const string EndCap = "EndCap"

Defines the ending element of a path. [Enum (int), e.g. ColoredDot, None, LineArrowHead, FilledArrowHead, Diamond, Square, Disc]

const string LineWidth = "LineWidth"

Defines the line thickness of a path. [double]

const string ShowDisplayNameForLink = "ShowDisplayNameForLink"

Determines if the display name of a link should be shown. [boolean]

const string ShowDisplayNameForSpot = "ShowDisplayNameForSpot"

Determines if the display name of a spot should be shown. [boolean]

const string ShowDisplayNameForZone = "ShowDisplayNameForZone"

Determines if the display name of a zone should be shown. [boolean]

const string ShowDisplayNameForPath = "ShowDisplayNameForPath"

Determines if the display name of a path should be shown. [boolean]

const string ShowDisplayNameForImage = "ShowDisplayNameForImage"

Determines if the display name of an image should be shown. [boolean]

const string DisplayNameColorForLink = "DisplayNameColorForLink"

The color of a link's display name. [System.Windows.Media.Color]

const string DisplayNameColorForSpot = "DisplayNameColorForSpot"

The color of a spot's display name. [System.Windows.Media.Color]

const string DisplayNameColorForZone = "DisplayNameColorForZone"

The color of a zone's display name. [System.Windows.Media.Color]

const string DisplayNameColorForPath = "DisplayNameColorForPath"

The color of a path's display name. [System.Windows.Media.Color]

const string DisplayNameColorForImage = "DisplayNameColorForImage"

The color of an image's display name. [System.Windows.Media.Color]

const string DisplayNameSizeForLink = "DisplayNameSizeForLink"

The size of a link's display name. [int]

const string DisplayNameSizeForSpot = "DisplayNameSizeForSpot"

The size of a spot's display name. [int]

const string DisplayNameSizeForZone = "DisplayNameSizeForZone"

The size of a zone's display name. [int]

const string DisplayNameSizeForPath = "DisplayNameSizeForPath"

The size of a path's display name. [int]

const string DisplayNameSizeForImage = "DisplayNameSizeForImage"

The size of an image's display name. [int]

const string DropShadowForLink = "DropShadowForLink"

Determines if the display name drop shadow of a link should be shown. [boolean]

const string DropShadowForSpot = "DropShadowForSpot"

Determines if the display name drop shadow of a spot should be shown. [boolean]

const string DropShadowForZone = "DropShadowForZone"

Determines if the display name drop shadow of a zone should be shown. [boolean]

const string DropShadowForPath = "DropShadowForPath"

Determines if the display name drop shadow of a path should be shown. [boolean]

const string DropShadowForImage = "DropShadowForImage"

Determines if the display name drop shadow of an image should be shown. [boolean]

const string DropShadowForText = "DropShadowForText"

Determines if a text's drop shadow should be shown. [boolean]

const string ImageOpacity = "ImageOpacity"

The opacity of a location image. [double, 0.0 - 1.0]

const string ImageAsset = "ImageAsset"

The asset of a location image. [ObjectProxy]

const string ForcedWidth = "ForcedWidth"

Determines the fixed width of a location text object. [double]

const string ForcedHeight = "ForcedHeight"

Determines the fixed height of a location text object. [double]

const string JourneyState = "JourneyState"

the state of the journey [Enum (int)]

const string JourneyPoints = "JourneyPoints"

a read-only list of JouneyPoint objects. [IList<ObjectProxy>, read-only]

const string Namespaces = "Namespaces"

a read-only list of Journey namespaces. [IList<ObjectProxy>, read-only]

const string JourneyPointType = "JourneyPointType"

The type of this point in the journey. [Enum (int), read-only]

const string IdxInJourney = "IdxInJourney"

The index this journey point has in the list of points in the Journey [int, read-only]

const string ReachedByActionType = "ReachedByActionType"

describes by what action this journey point was reached [Enum (int), read-only]

const string ObjectReference = "ObjectReference"

describes which object is referenced by this journey point. When "JourneyPointType" is one of "InputPinSelection", "OutputPinSelection" or "Pin", the referenced object is a pin (whose parent is the owning object) otherwise its an "normal" flow object. [ObjectProxy, read-only]

const string Description = "Description"

The description of a variable. [string]

const string DataType = "DataType"

The data type of a variable. [Enum (int), e.g. Integer, Boolean]

const string DefaultValue = "DefaultValue"

the string representation of the default value of a variable

const string BooleanValue = "BooleanValue"

A boolean evaluation of the default value. If the variable has integer type, 0 evaluates to false, any other to true

const string NumericValue = "NumericValue"

A numeric (double) evaluation of the default value. If the variable has boolean type, false evaluates to 0.0, true to 1.0

const string Variables = "Variables"

A read-only list of the variables of a variable set. [IList<ObjectProxy>, read-only]


articy:draft API: ObjectProxy Class Reference

  • Api
  • ObjectProxy
Public Member Functions | Properties | List of all members
ObjectProxy Class Reference

Represents one articy:draft object like it is shown in the articy:draft GUI. More...

Public Member Functions

int | GetColumnIndex (string aPropertyName)
Returns the column index of a property with the specified name. More...
IList< ObjectProxy > | GetInputPins ()
Returns a list of ObjectProxy objects, each representing an input pin. More...
ObjectProxy | GetInputPin (int aIndex)
returns the input pin with the given index More...
IList< ObjectProxy > | GetOutputPins ()
Returns a list of ObjectProxy objects, each representing an output pin. More...
ObjectProxy | GetOutputPin (int aIndex)
returns the output pin with the given index More...
ObjectProxy | AddInputPin ()
void | RemoveInputPin (int aPinIndex)
ObjectProxy | AddOutputPin ()
void | RemoveOutputPin (int aPinIndex)
IList< ObjectProxy > | GetChildren ()
Returns a list ob ObjectProxy objects, each representing a child as can be seen in the articy:draft navigator tree. More...
IList< ObjectProxy > | GetAttachments ()
Returns a list ob ObjectProxy objects, each representing an attachment as can be seen in the articy:draft reference strip of the respective object. More...
ObjectProxy GetParent ()
Returns an ObjectProxy object representing the direct parent in the object tree as displayed in the articy:draft navigator. More...
string | GetDisplayName ()
Returns the name the object is typically displayed with in the articy:draft GUI (navigator, tiles/list view). More...
void | SetDisplayName (string aDisplayName)
Sets the display name of the object to the specified value. More...
string | GetTechnicalName ()
Returns the technical name of the object. More...
void | SetTechnicalName (string aTechnicalName)
Sets the technical name of the object to the specified value. More...
string | GetText ()
Returns the object's property "Text". More...
void | SetText (string aText)
Sets the value of the property with the name "Text". More...
string | GetExternalId ()
Returns the object's property "ExternalId". More...
void | SetExternalId (string aExternalId)
Sets the object's "ExternalId" property to the specified value. More...
int | GetShortId ()
Returns the object's property "ShortId". More...
void | SetShortId (int aShortId)
Sets the object's "ShortId" property to the specified value. More...
System.Windows.Media.Color | GetColor ()
Returns the object's "Color" property to the specified value. More...
void | SetColor (System.Windows.Media.Color aColor)
Sets the object's "Color" property to the specified value. More...
ObjectProxy GetPreviewImage ()
Returns the asset that is set as preview image for this object. More...
void | SetPreviewImage (ObjectProxy aPreviewImage)
Sets the preview image of this object to the specified value. More...
ulong | GetTemplateId ()
Returns the template that is set for this object. More...
string | GetTemplateTechnicalName ()
Returns the technical name of the template that was assigned to this object. More...
void | SetTemplate (ulong aId)
Sets a new template for this object. More...
void | SetTemplate (string aTechnicalName)
Sets a new template for this object. More...
Guid | GetPartitionId ()
Returns the Guid of the partition, this object belongs to. More...
Point | GetFlowPosition ()
Gets the current position of a flow-item object More...
void | SetFlowPosition (Point aPosition)
Sets the current position of a flow-item object More...
void | SetFlowPosition (double aPosX, double aPosY)
Sets the current position of a flow-item object More...
Size | GetFlowSize ()
Gets the size of a flow flow-item object More...
void | SetFlowSize (Size aSize)
Sets the size of a flow-item object. The given size if coerces to obey min/max size values for an object More...
void | SetFlowSize (double aWidth, double aHeigt)
Sets the size of a flow-item object. The given size if coerces to obey min/max size values for an object More...
bool | HasProperty (string aProperty)
Checks if the object contains a property with the specified name. More...
PropertyDataType | GetDataType (string aProperty)
Returns the data type of the property with the specified name. More...
ObjectPropertyInfo | GetPropertyInfo (string aProperty)
Queries for extended property infos. More...
List< string > | GetAvailableProperties ()
Returns a list of all property names (type string), this object contains. More...
List< string > | GetAvailableProperties (PropertyFilter aPropFilter)
Returns a list of all property names (type string), this object contains. More...
string | GetObjectUrl ()
Gets the Url of the object More...
bool | MaySetObjectReference (string aPropertyName, ObjectProxy aAttachment)
void | AddAttachmentToStrip (string aPropertyName, ObjectProxy aAttachment)
Adds an attachment to a reference strip of the object. More...
bool | MayAddAttachmentToStrip (string aPropertyName, ObjectProxy aAttachment)
Checks if an attachment is allowed to be added to a reference strip of the object. More...
void | RemoveAttachmentFromStrip (string aPropertyName, ObjectProxy aAttachment)
Removes the specified attachment from the specified reference strip. More...
void | RemoveAttachmentFromStripAtIndex (string aPropertyName, int aIndex)
Removes the specified attachment from the specified reference strip. More...
void | InsertAttachmentIntoStrip (string aPropertyName, ObjectProxy aAttachment, int aIndex)
Inserts the specified attachment into the specified reference strip More...
bool | MayInsertAttachmentIntoStrip (string aPropertyName, ObjectProxy aAttachment, int aIndex)
Checks if the specified attachment is allowed to by inserted into the specified reference strip More...
void | ClearStrip (string aPropertyName)
Removes all attachments from the specified reference strip. More...
int | FindIndex (string aPropertyName, ObjectProxy aAttachment)
Returns the column index of an attachment inside a certain reference strip. More...
ResultSet | RunQuery (string aQuery)
Searches the opened project for articy objects. The object on which this query is executed can be referenced by the "self" query keyword More...
void | ValidateExpressoScript (string aScriptText)
Checks if the given string is a valid value for the property "Expression" of the object. More...
void | ValidateExpressoScript (string aPropertyName, string aScriptText)
Checks if the given string is a valid value for the named property (either object or feature property name) of the object More...
bool | IsValidExpressoScript (string aScriptText)
Checks if the given string is a valid value for the property "Expression" of the object More...
bool | IsValidExpressoScript (string aPropertyName, string aScriptText)
Checks if the given string is a valid value for the named property (either object or feature property name) of the object More...

Properties

ulong | Id [get, set]
the ID of this object More...
bool | IsCustomizeable [get]
true if this kind of object can have a template assigned, false otherwise More...
bool | IsConnectable [get]
true for all object types that can be displayed (and therefore connected) in the articy:draft flow editor (flow fragments, dialogs, dialog fragments, jumps and hubs), false for all other types of objects More...
bool | CanHaveAttachments [get]
All articy object types that can receive attachments inside a reference strip return true. More...
bool | HasTechnicalName [get]
true for all articy objects, that have a technical name More...
bool | HasPreviewImage [get]
true if the tiles view of the articy:draft GUI displays this object with an preview image, otherweise false More...
bool | IsDisplayNameCalculated [get]
true if the display name is calculated using the values of other properties and therefore is read-only, otherwise false More...
bool | HasDisplayName [get]
true for all articy objects that have a display name, otherwise false More...
bool | CanHaveChildren [get]
true for all object types that can have children as visible in the articy:draft navigator tree, otherwise false More...
bool | IsFolder [get]
User folders and system folders return true all other articy object types return false. More...
bool | IsUserFolder [get]
User folders return true all other articy object types return false. More...
bool | IsSystemFolder [get]
System folders return true all other articy object types return false. More...
bool | HasText [get]
true if the object has the "Text" property, otherwise false More...
bool | HasColor [get]
true if the object has the "Color" property, otherwise false More...
bool | HasShortId [get]
true if the object has the "ShortId" property, otherwise false More...
bool | HasExternalId [get]
true if the object has the "ExternalId" property, otherwise false More...
string | TypeName [get]
An untyped string that describes the object type. See ObjectType for details. More...
ObjectType | ObjectType [get]
This property tells, what type the encapsulated articy object really is. More...
bool | IsValid [get]
true if the object is a valid object with all properties and functionalities, false if it is a so-called 'broken reference' More...
bool | IsReadOnly [get]
Determines if the object can be written. More...
bool | CanBePartitioned [get]
Returns true if this object is a toggleable partition (can be created or retired). Will return false in case of system folders as those are always a partition and cannot be retired. More...
bool | HoldsPartition [get]
Returns true if the object is used as a partition root. More...
object | this[string aPropertyName] [get, set]
This indexer returns the property with the specified property/column name. More...
object | this[int aColumnIndex] [get, set]
This indexer returns the property with the specified column index. More...

Detailed Description

Represents one articy:draft object like it is shown in the articy:draft GUI.

This is the most important data class of the articy:draft API. It encapsulates one single articy object regardless of its actual type. All object getting methods of the API return either an instance of this class (or a list of such instances) or an ID. Use the members of this class to learn about what actual type of object is encapsulated or to read or even change the properties of the object.

Member Function Documentation

int GetColumnIndex ( string aPropertyName )
inline

Returns the column index of a property with the specified name.

Parameters
aPropertyName property name e.g. "DisplayName"
Returns
the column index

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

IList<ObjectProxy> GetInputPins ( )
inline

Returns a list of ObjectProxy objects, each representing an input pin.

Returns
the list of input pins ordered from top to bottom as displayed in the articy:draft flow editor
Exceptions
ArticyApiException If this method is called on an non-flow object the error code ErrorCode.ObjectIsNotConnectable is thrown.
ObjectProxy GetInputPin ( int aIndex )
inline

returns the input pin with the given index

Parameters
aIndex the pin index counted from top to bottom, starting with 0
Returns
the given Pin ObjectProxy object
IList<ObjectProxy> GetOutputPins ( )
inline

Returns a list of ObjectProxy objects, each representing an output pin.

Returns
the list of output pins ordered from top to bottom as displayed in the articy:draft flow editor
Exceptions
ArticyApiException If this method is called on an non-flow object the error code ErrorCode.ObjectIsNotConnectable is thrown.
ObjectProxy GetOutputPin ( int aIndex )
inline

returns the output pin with the given index

Parameters
aIndex the pin index counted from top to bottom, starting with 0
Returns
the given Pin ObjectProxy object
IList<ObjectProxy> GetChildren ( )
inline

Returns a list ob ObjectProxy objects, each representing a child as can be seen in the articy:draft navigator tree.

Returns
a list of children or null if the object is unable to have children
IList<ObjectProxy> GetAttachments ( )
inline

Returns a list ob ObjectProxy objects, each representing an attachment as can be seen in the articy:draft reference strip of the respective object.

Returns
a list of attachments or null if the object cannot have attachments
ObjectProxy GetParent ( )
inline

Returns an ObjectProxy object representing the direct parent in the object tree as displayed in the articy:draft navigator.

Returns
the parent object or null if it is the project node
string GetDisplayName ( )
inline

Returns the name the object is typically displayed with in the articy:draft GUI (navigator, tiles/list view).

Returns
the object's display name or null if the object has no display name
void SetDisplayName ( string aDisplayName )
inline

Sets the display name of the object to the specified value.

Parameters
aDisplayName the new display name that replaces the old one
Exceptions
ArticyApiException If the object does not have a display name, the ErrorCode.PropertyNotFound is thrown.
string GetTechnicalName ( )
inline

Returns the technical name of the object.

Returns
the object's technical name or null if the object does not have a technical name

Technical names can be seen and edited in the property view of most articy:draft objects.

void SetTechnicalName ( string aTechnicalName )
inline

Sets the technical name of the object to the specified value.

Parameters
aTechnicalName the new technical name for the object
Exceptions
ArticyApiException If the object does not have a technical name the ErrorCode.PropertyNotFound is thrown.
string GetText ( )
inline

Returns the object's property "Text".

Returns
the value of the Text property

This is a convenience wrapper for return this[ ObjectPropertyNames.Text ].

void SetText ( string aText )
inline

Sets the value of the property with the name "Text".

Parameters
aText the next value for the Text property

This is a convenience wrapper for this[ ObjectPropertyNames.Text ] = aText.

string GetExternalId ( )
inline

Returns the object's property "ExternalId".

Returns
the value of the ExternalId property or null if no such property exists for this object
void SetExternalId ( string aExternalId )
inline

Sets the object's "ExternalId" property to the specified value.

Parameters
aExternalId the new value for the ExternalId property
Exceptions
ArticyApiException If the object does not have the "ExternalId" property, error code ErrorCode.PropertyNotFound is thrown.
int GetShortId ( )
inline

Returns the object's property "ShortId".

Returns
the value of the ShortId property
Exceptions
ArticyApiException If the object does not have a ShortId property, error code ErrorCode.PropertyNotFound is thrown.
void SetShortId ( int aShortId )
inline

Sets the object's "ShortId" property to the specified value.

Parameters
aShortId the new value for the ShortId property
Exceptions
ArticyApiException If the object does not have a ShortId property, error code ErrorCode.PropertyNotFound is thrown.
System.Windows.Media.Color GetColor ( )
inline

Returns the object's "Color" property to the specified value.

Returns
the current value of the "Color" property
Exceptions
ArticyApiException If the object does not have a Color property, error code ErrorCode.PropertyNotFound is thrown.
void SetColor ( System.Windows.Media.Color aColor )
inline

Sets the object's "Color" property to the specified value.

Parameters
aColor the new value for the "Color" property
Exceptions
ArticyApiException If the object does not have a Color property, error code ErrorCode.PropertyNotFound is thrown.
ObjectProxy GetPreviewImage ( )
inline

Returns the asset that is set as preview image for this object.

Returns
the asset object, that serves as preview image for this object
Exceptions
ArticyApiException If the object does not have a PreviewImage property, error code ErrorCode.PropertyNotFound is thrown.
void SetPreviewImage ( ObjectProxy aPreviewImage )
inline

Sets the preview image of this object to the specified value.

Parameters
aPreviewImage the (image) asset object that is to become the new preview image of this object
Exceptions
ArticyApiException | If the object does not have a PreviewImage property, error code ErrorCode.PropertyNotFound is thrown.
ArticyApiException | If the new value is no asset, error code ErrorCode.InvalidValue is thrown.
ulong GetTemplateId ( )
inline

Returns the template that is set for this object.

Returns
the ID of the used template or InstanceIdManager.InvalidIid if no template was used or the object is not customizable at all
string GetTemplateTechnicalName ( )
inline

Returns the technical name of the template that was assigned to this object.

Returns
the technical name of the object's template or null if no template was set or the object is not customizable at all
void SetTemplate ( ulong aId )
inline

Sets a new template for this object.

Parameters
aId the ID of the new template or InstanceIdManager.InvalidIid to remove an already set template
Exceptions
ArticyApiException | if the the specified ID is no valid template, ErrorCode.UnknownTemplate is thrown
ArticyApiException | if the object is read-only, ErrorCode.WriteDenied is thrown
ArticyApiException | if the object is not customizable, ErrorCode.ObjectNotCustomizeable is thrown
ArticyApiException | if the the specified template is not allowed for this type of object, ErrorCode.TemplateNotAllowedForObject is thrown
void SetTemplate ( string aTechnicalName )
inline

Sets a new template for this object.

Parameters
aTechnicalName the technical name of the new template or null or "" to remove an already set template
Exceptions
ArticyApiException | if the the specified technical name belongs to no valid template, ErrorCode.UnknownTemplate is thrown
ArticyApiException | if the object is read-only, ErrorCode.WriteDenied is thrown
ArticyApiException | if the object is not customizable, ErrorCode.ObjectNotCustomizeable is thrown
ArticyApiException | if the the specified template is not allowed for this type of object, ErrorCode.TemplateNotAllowedForObject is thrown
Guid GetPartitionId ( )
inline

Returns the Guid of the partition, this object belongs to.

Returns
the partition GUID

The partition GUID is needed for methods like Articy.Api.ApiSession.ClaimPartition or Articy.Api.ApiSession.UnclaimPartition. The partition GUID and the object ID is not the same value, even if the object itself is also its own partition.

Point GetFlowPosition ( )
inline

Gets the current position of a flow-item object

Returns
the position

<throws>PropertyNotFound if the object down not have a position</throws>

void SetFlowPosition ( Point aPosition )
inline

Sets the current position of a flow-item object

Parameters
aPosition the new position as Point struct

<throws>PropertyNotFound if the object down not have a position</throws>

void SetFlowPosition | ( | double | aPosX,
 |  | double | aPosY
 | ) |  |
inline

Sets the current position of a flow-item object

Parameters
aPosX | the x-position of the flow-item
aPosY | the y-position of the flow-item
Size GetFlowSize ( )
inline

Gets the size of a flow flow-item object

Returns
the current size of the object in the flow-view

<throws>PropertyNotFound if the object down not have a size</throws>

void SetFlowSize ( Size aSize )
inline

Sets the size of a flow-item object. The given size if coerces to obey min/max size values for an object

Parameters
aSize the new size of the flow item given as Size struct
void SetFlowSize | ( | double | aWidth,
 |  | double | aHeigt
 | ) |  |
inline

Sets the size of a flow-item object. The given size if coerces to obey min/max size values for an object

Parameters
aWidth | the new desired width of the object
aHeigt | the new desired height of the object
bool HasProperty ( string aProperty )
inline

Checks if the object contains a property with the specified name.

Parameters
aProperty the name of the property to check
Returns
true if the object has the specified property, otherwise false

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

PropertyDataType GetDataType ( string aProperty )
inline

Returns the data type of the property with the specified name.

Parameters
aProperty the name of the property whose data type is to be queried
Returns
the data type

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

ObjectPropertyInfo GetPropertyInfo ( string aProperty )
inline

Queries for extended property infos.

Parameters
aProperty the name of the property whose information should be returned
Returns
a class containing information about the property
Exceptions
ArticyApiException a PropertyNotFound error code may be thrown
List<string> GetAvailableProperties ( )
inline

Returns a list of all property names (type string), this object contains.

Returns
a list of strings containing the names of all properties this object provides

The class ObjectPropertyNames contains string constants for the property names of the various articy object types. The elements of this list can be used to call GetDataType or this[ string ].

List<string> GetAvailableProperties ( PropertyFilter aPropFilter )
inline

Returns a list of all property names (type string), this object contains.

Parameters
aPropFilter a filter that allows to show only base properties, template properties or all properties
Returns
a list of strings containing the names of all properties this object provides

The class ObjectPropertyNames contains string constants for the property names of the various articy object types. The elements of this list can be used to call GetDataType or this[ string ].

string GetObjectUrl ( )
inline

Gets the Url of the object

Returns
the absolute object url using the articy:// protocol
void AddAttachmentToStrip | ( | string | aPropertyName,
 |  | ObjectProxy | aAttachment
 | ) |  |
inline

Adds an attachment to a reference strip of the object.

Parameters
aPropertyName | the name of the property of the type PropertyDataType.ObjectList
aAttachment | the object that is to be attached at the end of the specified reference strip

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

bool MayAddAttachmentToStrip | ( | string | aPropertyName,
 |  | ObjectProxy | aAttachment
 | ) |  |
inline

Checks if an attachment is allowed to be added to a reference strip of the object.

Parameters
aPropertyName | the name of the property of the type PropertyDataType.ObjectList
aAttachment | the object that is to be attached at the end of the specified reference strip
Returns
True if adding is allowed.

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

void RemoveAttachmentFromStrip | ( | string | aPropertyName,
 |  | ObjectProxy | aAttachment
 | ) |  |
inline

Removes the specified attachment from the specified reference strip.

Parameters
aPropertyName | the name of the reference strip type property
aAttachment | the articy object that is to be removed from the reference strip

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

void RemoveAttachmentFromStripAtIndex | ( | string | aPropertyName,
 |  | int | aIndex
 | ) |  |
inline

Removes the specified attachment from the specified reference strip.

Parameters
aPropertyName | the name of the reference strip type property
aIndex | the index of the object inside the reference strip

Attachments in a reference strips have an index. The most left (as displayed in the articy:draft API) has index 0.

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

void InsertAttachmentIntoStrip | ( | string | aPropertyName,
 |  | ObjectProxy | aAttachment,
 |  | int | aIndex
 | ) |  |
inline

Inserts the specified attachment into the specified reference strip

Parameters
aPropertyName | the name of the reference strip type property
aAttachment | the attachment object to insert
aIndex | the new index of the to-be-inserted attachment; 0 means, the attachment becomes the new first (leftmost) attachment moving all other attachments to the right

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

bool MayInsertAttachmentIntoStrip | ( | string | aPropertyName,
 |  | ObjectProxy | aAttachment,
 |  | int | aIndex
 | ) |  |
inline

Checks if the specified attachment is allowed to by inserted into the specified reference strip

Parameters
aPropertyName | the name of the reference strip type property
aAttachment | the attachment object to insert
aIndex | the new index of the to-be-inserted attachment; 0 means, the attachment becomes the new first (leftmost) attachment moving all other attachments to the right
Returns
True if inserting is allowed.

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

void ClearStrip ( string aPropertyName )
inline

Removes all attachments from the specified reference strip.

Parameters
aPropertyName the name of the reference strip type property

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

int FindIndex | ( | string | aPropertyName,
 |  | ObjectProxy | aAttachment
 | ) |  |
inline

Returns the column index of an attachment inside a certain reference strip.

Parameters
aPropertyName | the name of the reference strip type property
aAttachment | the attachment, whose index is to be queried
Returns
the index of the specified attachment inside the reference strip

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

Attachments in a reference strips have an index. The most left (as displayed in the articy:draft API) has index 0.

ResultSet RunQuery ( string aQuery )
inline

Searches the opened project for articy objects. The object on which this query is executed can be referenced by the "self" query keyword

Parameters
aQuery A string containing the query expression. See the "ArticyDraft API-Programmer's Guide.pdf" chapter 4 for details.
Returns
a ResultSet object containing one row for every found articy object

If the API methods SimpleFindObjects(ulong,string,Articy.Api.TextFilterRelation,Articy.Api.SearchTextIn,bool) and SimpleFindConflicts are not sufficient to find the required set of articy objects you need to use this method. RunQuery allows searching for a very specific subset of objects in the opened project using a powerful query language.

void ValidateExpressoScript ( string aScriptText )
inline

Checks if the given string is a valid value for the property "Expression" of the object.

Parameters
aScriptText the new text

<throws>an ArticyApiException with ErrorCode 'ExpressionError' when there is a parsing error. The exception text contains a hint where the (first) error is located</throws>

void ValidateExpressoScript | ( | string | aPropertyName,
 |  | string | aScriptText
 | ) |  |
inline

Checks if the given string is a valid value for the named property (either object or feature property name) of the object

Parameters
aPropertyName | the name of the property to check
aScriptText | the new text

<throws>an ArticyApiException with ErrorCode 'ExpressionError' when there is a parsing error. the exception text contains a hint where the (first) error is located</throws> <throws>an ArticyApiException with ErrorCode 'NonScriptableProperty' when it is called for a property that is not capable of handling script text (e.g DisplayName)</throws>

bool IsValidExpressoScript ( string aScriptText )
inline

Checks if the given string is a valid value for the property "Expression" of the object

Parameters
aScriptText the new text
Returns
true if the string is valid or expresso script support is disabled for the project, false otherwise
bool IsValidExpressoScript | ( | string | aPropertyName,
 |  | string | aScriptText
 | ) |  |
inline

Checks if the given string is a valid value for the named property (either object or feature property name) of the object

Parameters
aPropertyName | the name of the property to check
aScriptText | the new text
Returns
true if the string is valid or expresso script support is disabled for the project, false otherwise

Property Documentation

ulong Id
getset

the ID of this object

bool IsCustomizeable
get

true if this kind of object can have a template assigned, false otherwise

bool IsConnectable
get

true for all object types that can be displayed (and therefore connected) in the articy:draft flow editor (flow fragments, dialogs, dialog fragments, jumps and hubs), false for all other types of objects

bool CanHaveAttachments
get

All articy object types that can receive attachments inside a reference strip return true.

Currently this is the case for flow fragments, dialogs, entities and locations. All other types of objects return false.

bool HasTechnicalName
get

true for all articy objects, that have a technical name

Currently only system folders (displayed with an orange name in articy:draft) have no technical name.

bool HasPreviewImage
get

true if the tiles view of the articy:draft GUI displays this object with an preview image, otherweise false

Currently this is the case for flow fragments, dialogs, dialog fragments, entities, locations, zone, path, spot and asset.

bool IsDisplayNameCalculated
get

true if the display name is calculated using the values of other properties and therefore is read-only, otherwise false

Some objects do not allow to change their display name because it is calculated. Such objects are dialog fragments, links and jumps. Query this property before trying to change a display name.

bool HasDisplayName
get

true for all articy objects that have a display name, otherwise false

Currently only connection objects have no display name. Connection objects represent the lines that connect flow elements with each other.

bool CanHaveChildren
get

true for all object types that can have children as visible in the articy:draft navigator tree, otherwise false

bool IsFolder
get

User folders and system folders return true all other articy object types return false.

bool IsUserFolder
get

User folders return true all other articy object types return false.

In articy:draft user folders are displayed with a blue font and icon.

bool IsSystemFolder
get

System folders return true all other articy object types return false.

In articy:draft system folders are displayed with an orange font and icon.

bool HasText
get

true if the object has the "Text" property, otherwise false

bool HasColor
get

true if the object has the "Color" property, otherwise false

bool HasShortId
get

true if the object has the "ShortId" property, otherwise false

bool HasExternalId
get

true if the object has the "ExternalId" property, otherwise false

string TypeName
get

An untyped string that describes the object type. See ObjectType for details.

ObjectType ObjectType
get

This property tells, what type the encapsulated articy object really is.

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

bool IsValid
get

true if the object is a valid object with all properties and functionalities, false if it is a so-called 'broken reference'

'Broken references' are ObjectProxy instances that were created e.g. by calling GetAttachments while the partition was not claimed. A later ClaimPartition of this partition impicitly retrieves the latest partition data from the repository where the retrieved attachment object has been deleted by another user. Now our instance is invalid, it is a 'broken reference' to an already deleted object.

bool IsReadOnly
get

Determines if the object can be written.

An object gets read-only if

  • the partition is not claimed by the current API user
  • the object does not exist any more (e.g. an instance was created before an partition update that deleted this object)
bool CanBePartitioned
get

Returns true if this object is a toggleable partition (can be created or retired). Will return false in case of system folders as those are always a partition and cannot be retired.

bool HoldsPartition
get

Returns true if the object is used as a partition root.

object this[string aPropertyName]
getset

This indexer returns the property with the specified property/column name.

Parameters
aPropertyName name of the requested property e.g. "DisplayName" or "Text"
Returns
The type of the return value depends on the type of property requested.

The class ObjectPropertyNames contains string constants for the property names of the various articy object types.

object this[int aColumnIndex]
getset

This indexer returns the property with the specified column index.

Parameters
aColumnIndex the index of the requested property's column
Returns
The type of the return value depends on the type of property requested.

To learn the column index of a specific property, the method GetColumnIndex can be used.


articy:draft API: OpenProjectArgs Class Reference

  • Api
  • OpenProjectArgs
Properties | List of all members
OpenProjectArgs Class Reference

This argument object contains all parameters for the ApiSession.OpenProject method More...

Inheritance diagram for OpenProjectArgs:
ComplexApiCallArgs

Properties

Guid | ProjectGuid [get, set]
The Guid of the project to open. This guid can be found in the property sheet of the project node in articy:draft or you can use it from the enumeration method ApiSession.GetProjectList More...
string | ProjectFolder [get, set]
This is the fully qualified name of the path articy:draft uses as local project folder. All Subersion/Perforce operations exchange data between this local folder and their repository/depot. When a project is opened for the very first time on a computer or with a specific user account a new project folder needs to be specified and the complete project data is download locally. More...
bool | CleanCheckout [get, set]
Default false. When set to true opening the project copies the whole project data to the project folder regardless if it is needed or not. All data in the folder is deleted before the Project folder is used. You might want to make sure you have all necessary files locally before starting an extensive API operation. However this could take more time before the project is ready to be worked with. More...
bool | ForceProjectFolder [get, set]
Defaults to false. This causes the articy:draft API to use the project folder that was used the last time this project was opened by the current user/machine. This could have also been a GUI rather than an API session. More...
string | ScmUsername [get, set]
The username of the Subversion/Perforce account that is to be used for opening this project. More...
string | ScmPassword [get, set]
The password of the Subversion/Perforce account that is to be used for opening this project. More...
bool | OpenExclusively [get, set]
If false the project is opened in normal mode, if true it is opened in exclusive mode. Implications are the same as when using the GUI of articy:draft. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

This argument object contains all parameters for the ApiSession.OpenProject method

Property Documentation

Guid ProjectGuid
getset

The Guid of the project to open. This guid can be found in the property sheet of the project node in articy:draft or you can use it from the enumeration method ApiSession.GetProjectList

string ProjectFolder
getset

This is the fully qualified name of the path articy:draft uses as local project folder. All Subersion/Perforce operations exchange data between this local folder and their repository/depot. When a project is opened for the very first time on a computer or with a specific user account a new project folder needs to be specified and the complete project data is download locally.

bool CleanCheckout
getset

Default false. When set to true opening the project copies the whole project data to the project folder regardless if it is needed or not. All data in the folder is deleted before the Project folder is used. You might want to make sure you have all necessary files locally before starting an extensive API operation. However this could take more time before the project is ready to be worked with.

bool ForceProjectFolder
getset

Defaults to false. This causes the articy:draft API to use the project folder that was used the last time this project was opened by the current user/machine. This could have also been a GUI rather than an API session.

If this property is set to true however, the project folder of the last opening session is ignored and the project data is copied to the folder specified by the ProjectFolder property in this class.

string ScmUsername
getset

The username of the Subversion/Perforce account that is to be used for opening this project.

string ScmPassword
getset

The password of the Subversion/Perforce account that is to be used for opening this project.

bool OpenExclusively
getset

If false the project is opened in normal mode, if true it is opened in exclusive mode. Implications are the same as when using the GUI of articy:draft.


articy:draft API: ResultSet Class Reference

  • Api
  • ResultSet
Public Member Functions | Properties | List of all members
ResultSet Class Reference

This object is the container of objects that were found from a query. It is also internally used to cache meta/schema data for all accessed properties from elements in the row collection. This reduces the memory footprint and gives some extra speed when having many object of the same type in the result set. More...

Public Member Functions

void | DumpToCSV (String aFileName)
string | GetValue (int aRowIndex, int aColIndex)
void | CalculateColumns ()

Properties

List< ObjectProxy > | Rows [get]
all rows found by the query that has produced this result set More...
ListDictionary< string, ApiFieldDescriptor > | Columns [get]
the descriptors for the columns More...

Detailed Description

This object is the container of objects that were found from a query. It is also internally used to cache meta/schema data for all accessed properties from elements in the row collection. This reduces the memory footprint and gives some extra speed when having many object of the same type in the result set.

Property Documentation

List<ObjectProxy> Rows
get

all rows found by the query that has produced this result set

ListDictionary<string, ApiFieldDescriptor> Columns
get

the descriptors for the columns


articy:draft API: SimplePartitionActionArgs Class Reference

  • Api
  • SimplePartitionActionArgs
Properties | List of all members
SimplePartitionActionArgs Class Reference

Base class for arguments that require a partition Guid. Some methods only need these arguments with no additional parameters More...

Inheritance diagram for SimplePartitionActionArgs:
ComplexApiCallArgs UnclaimPartitionArgs

Properties

Guid | PartitionGuid [get, set]
the Guid of the partition that should be used. Leave this parameter empty when using a partition action that affects multiple partitions More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Base class for arguments that require a partition Guid. Some methods only need these arguments with no additional parameters

Property Documentation

Guid PartitionGuid
getset

the Guid of the partition that should be used. Leave this parameter empty when using a partition action that affects multiple partitions


articy:draft API: Transformer Class Reference

  • Api
  • Transformer
Public Types | Properties | List of all members
Transformer Class Reference

This class contains methods to transform a selection of location objects. This object can only be created from an ApiLocationTools that is bound to a specific location. More...

Public Types

enum TransformMode { Unknown, ObjectAligned, AxisAligned }
enum AnchorPosition {
TopLeft = 0x00, TopMiddle = 0x01, TopRight = 0x02, CenterLeft = 0x10,
CenterMiddle = 0x11, CenterRight = 0x12, BottomLeft = 0x20, BottomMiddle = 0x21,
BottomRight = 0x22, CustomPosition = 0xff
}

Public Member Functions

Selection handling

The following methods provide actions to transform objects and to request information about the objects

void | Clear ()
Clear the selection to work with More...
void | Add (ObjectProxy aObject)
Adds the given object to the transformation list More...
void | AddResultSet (ResultSet aResultSet)
Adds all objects from a query result, the result set must only contain objects of the bound location that can be transformed More...
void | AddRange (IEnumerable< ObjectProxy > aObjects)
Adds a list of objects to the transformation selection. Only shapes, images, texts, spots & links are allowed. This method can only be called when the transformation is not active. More...
void | Remove (ObjectProxy aObject)
remove the given object from the transform selection More...
void | RemoveResultSet (ResultSet aResultSet)
Remove all objects from a query result from the transform selection More...
void | RemoveRange (IEnumerable< ObjectProxy > aObjects)
Removes a list IEnumerable list of objects from the transform selection. Invalid objects in the list are ignored. This method can only be called when the transformation is not active. More...
Point | GetPosition ()
Gets the current position of the selected transform object as a point More...
void | SetPosition (Point aPosition)
Sets the position of the selected transform object to a new point More...
double | GetWidth ()
Gets the width length of the currently selected transform object as a double value More...
double | GetHeight ()
Gets the height length of the currently selected transform object as a double value More...
void | SetWidth (double aNewWidth, bool aKeepAspect=false)
Sets the width length of the currently selected transform object with a specified value and a possibility to keep the current aspect ratio More...
void | SetHeight (double aNewHeight, bool aKeepAspect=false)
Sets the height length of the currently selected transform object with a specified value and a possibility to keep the current aspect ratio More...
void | SetSize (Size aNewSize)
Sets the size of the currently selected transform object to a specified value More...
double | GetRotation ()
Gets the rotation as a double value of the currently selected transform object More...
void | SetRotation (double aNewAngle)
Sets the rotation angle of the currently selected transform object with a specified double value More...
Point | GetPivot ()
Gets the pivot position of the currently selected transform object as a point More...
void | RecenterPivot ()
Resets the pivot position to the center middle of the currently selected transform object More...
void | SetPivot (AnchorPosition aAnchor)
Sets the pivot of the currently selected transform object to a specific anchor position with the option to snap More...
void | SetPivot (Point aPivot)
Sets the pivot of the currently selected transform object to a specific point with the option to snap More...
void | FlipHorizontal ()
Flips the currently selected transform object on the global horizontal axis if it is a custom shape, on the local horizontal axis if it is not More...
void | FlipVertical ()
Flips the currently selected transform object on the global vertical axis if it is a custom shape, on the local vertical axis if it is not More...
life cycle methods

The following methods provide actions of life cycle of the transform

void | SetTransformMode (TransformMode aTransformMode)
Sets the transform mode of the currently selected transform object to object aligned or axis aligned (or unknown) Only allowed if no transformation is currently active. Object aligned transformation is only available for single shape, text or image objects. More...
void | BeginTransform ()
Begins the transformation of the currently selected transform object with the selected transform mode More...
void | EndTransform ()
If there is a current transformation and it is not unknown, end it More...
void | CancelTransform ()
If there is a current transformation and it is not unknown, restore the values from the initial snapshot and then end it More...
void | Undo ()
If there is an undoable action, restore the last snapshot More...
void | Redo ()
If there is a redoable action, restore the next snapshot More...

Properties

int Count [get]

Detailed Description

This class contains methods to transform a selection of location objects. This object can only be created from an ApiLocationTools that is bound to a specific location.

Member Function Documentation

void Clear ( )
inline

Clear the selection to work with

void Add ( ObjectProxy aObject )
inline

Adds the given object to the transformation list

Parameters
aObject The object to add
void AddResultSet ( ResultSet aResultSet )
inline

Adds all objects from a query result, the result set must only contain objects of the bound location that can be transformed

Parameters
aResultSet The ResultSet whose objects should be added
void AddRange ( IEnumerable< ObjectProxy > aObjects )
inline

Adds a list of objects to the transformation selection. Only shapes, images, texts, spots & links are allowed. This method can only be called when the transformation is not active.

Parameters
aObjects The IEnumerable of objects to add.
void Remove ( ObjectProxy aObject )
inline

remove the given object from the transform selection

Parameters
aObject the object that should be removed
void RemoveResultSet ( ResultSet aResultSet )
inline

Remove all objects from a query result from the transform selection

Parameters
aResultSet the query result to be removed
void RemoveRange ( IEnumerable< ObjectProxy > aObjects )
inline

Removes a list IEnumerable list of objects from the transform selection. Invalid objects in the list are ignored. This method can only be called when the transformation is not active.

Parameters
aObjects
void SetTransformMode ( TransformMode aTransformMode )
inline

Sets the transform mode of the currently selected transform object to object aligned or axis aligned (or unknown) Only allowed if no transformation is currently active. Object aligned transformation is only available for single shape, text or image objects.

Parameters
aTransformMode The specified transform mode to enter
void BeginTransform ( )
inline

Begins the transformation of the currently selected transform object with the selected transform mode

Only allowed if no transformation is currently active

void EndTransform ( )
inline

If there is a current transformation and it is not unknown, end it

void CancelTransform ( )
inline

If there is a current transformation and it is not unknown, restore the values from the initial snapshot and then end it

void Undo ( )
inline

If there is an undoable action, restore the last snapshot

void Redo ( )
inline

If there is a redoable action, restore the next snapshot

Point GetPosition ( )
inline

Gets the current position of the selected transform object as a point

Returns
Point containing the coordinates of the currently selected object's position
void SetPosition ( Point aPosition )
inline

Sets the position of the selected transform object to a new point

Parameters
aPosition The point the selected transform object is supposed to move to
double GetWidth ( )
inline

Gets the width length of the currently selected transform object as a double value

Returns
Double value of the width length of the selected object
double GetHeight ( )
inline

Gets the height length of the currently selected transform object as a double value

Returns
Double value of the height length of the selected object
void SetWidth | ( | double | aNewWidth,
 |  | bool | aKeepAspect = false
 | ) |  |
inline

Sets the width length of the currently selected transform object with a specified value and a possibility to keep the current aspect ratio

Parameters
aNewWidth | Specified double value for the new width length
aKeepAspect | Determines whether the current aspect ratio is to be kept or not
void SetHeight | ( | double | aNewHeight,
 |  | bool | aKeepAspect = false
 | ) |  |
inline

Sets the height length of the currently selected transform object with a specified value and a possibility to keep the current aspect ratio

Parameters
aNewHeight | Specified double value for the new height length
aKeepAspect | Determines whether the current aspect ratio is to be kept or not
void SetSize ( Size aNewSize )
inline

Sets the size of the currently selected transform object to a specified value

Parameters
aNewSize The specified size value the selected object is to be set to
double GetRotation ( )
inline

Gets the rotation as a double value of the currently selected transform object

Returns
Double value for the current rotation of the selected object
void SetRotation ( double aNewAngle )
inline

Sets the rotation angle of the currently selected transform object with a specified double value

Parameters
aNewAngle The specified double value for the new rotation angle
Point GetPivot ( )
inline

Gets the pivot position of the currently selected transform object as a point

Returns
Point containing the coordinates of the pivot of the selected object
void RecenterPivot ( )
inline

Resets the pivot position to the center middle of the currently selected transform object

void SetPivot ( AnchorPosition aAnchor )
inline

Sets the pivot of the currently selected transform object to a specific anchor position with the option to snap

Parameters
aAnchor The specified anchor position for the pivot
void SetPivot ( Point aPivot )
inline

Sets the pivot of the currently selected transform object to a specific point with the option to snap

Parameters
aPivot The specified point the pivot should be moved to
void FlipHorizontal ( )
inline

Flips the currently selected transform object on the global horizontal axis if it is a custom shape, on the local horizontal axis if it is not

void FlipVertical ( )
inline

Flips the currently selected transform object on the global vertical axis if it is a custom shape, on the local vertical axis if it is not


articy:draft API: UnclaimPartitionArgs Class Reference

  • Api
  • UnclaimPartitionArgs
Properties | List of all members
UnclaimPartitionArgs Class Reference

Argument class for unclaiming partition(s) More...

Inheritance diagram for UnclaimPartitionArgs:
SimplePartitionActionArgs ComplexApiCallArgs

Properties

bool | KeepClaim [get, set]
Set this member to true to only publish the changes but keep the claim More...
string | CommitMessage [get, set]
A custom message that should be used when commiting/submitting the partition's data to the repository/depot More...
- Properties inherited from SimplePartitionActionArgs
Guid | PartitionGuid [get, set]
the Guid of the partition that should be used. Leave this parameter empty when using a partition action that affects multiple partitions More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Argument class for unclaiming partition(s)

Property Documentation

bool KeepClaim
getset

Set this member to true to only publish the changes but keep the claim

string CommitMessage
getset

A custom message that should be used when commiting/submitting the partition's data to the repository/depot


articy:draft API: WaitForAssetProcessingArgs Class Reference

  • Api
  • WaitForAssetProcessingArgs
Properties | List of all members
WaitForAssetProcessingArgs Class Reference

Argument class for the ApiSession.WaitForAssetProcessing method. The main purpose is to be able to specify a log source name where progress messages should be reported More...

Inheritance diagram for WaitForAssetProcessingArgs:
ComplexApiCallArgs

Properties

bool | WaitForThumbnails [get, set]
If set to true, it is waited until a thumbnail has been generated for all assets or the generation has failed. More...
- Properties inherited from ComplexApiCallArgs
string | LogSourceName [get, set]
The "source" name that should be used when the action that receives the arguments wants to report Progress or other logging output. You will encounter this name as "aMessageSource" within you logging callback More...

Detailed Description

Argument class for the ApiSession.WaitForAssetProcessing method. The main purpose is to be able to specify a log source name where progress messages should be reported

Property Documentation

bool WaitForThumbnails
getset

If set to true, it is waited until a thumbnail has been generated for all assets or the generation has failed.


articy:draft API: Class Index

Class Index
A | C | E | F | G | J | O | R | S | T | U | W
A
ComplexApiCallArgs (Articy.Api)
F
ObjectPropertyNames (Articy.Api)
U
E
ObjectProxy (Articy.Api)
ApiCollaborativeHelper (Articy.Api) FlowListNode (Articy.Api) OpenProjectArgs (Articy.Api) UnclaimPartitionArgs (Articy.Api)
ApiConsts (Articy.Api) ExportDataArgs (Articy.Api) FlowReference (Articy.Api)
R
W
ApiJourneyBuilder (Articy.Api) ExportDocumentToDocxArgs (Articy.Api)
G
ApiLocationTools (Articy.Api) ExportObjectSelectionDataArgs (Articy.Api) ResultSet (Articy.Api) WaitForAssetProcessingArgs (Articy.Api)
ApiSession (Articy.Api) ExportToAccessArgs (Articy.Api) GenericExportDataArgs (Articy.Api)
S
ArticyApi (Articy.Api) ExportToDocxArgs (Articy.Api)
J
ArticyApiException (Articy.Api) ExportToFullXmlArgs (Articy.Api) SimplePartitionActionArgs (Articy.Api)
C
ExportToXlsxArgs (Articy.Api) JourneyPointAction (Articy.Api)
T
ExportXlsxForReimportArgs (Articy.Api)
O
CloseProjectArgs (Articy.Api) Transformer (Articy.Api)
ObjectPropertyInfo (Articy.Api)
A | C | E | F | G | J | O | R | S | T | U | W


articy:draft API: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
C ApiCollaborativeHelper |
C ApiConsts | static class that contains some constants and a error code helper method
C ApiLocationTools |
C ArticyApi | This static class the the bootstrapping singleton to startup and shutdown the articy:draft API
▼C ComplexApiCallArgs | base class for the argument objects used for API calls that have many parameters
C CloseProjectArgs | Argument class for ApiSession.CloseProject
▼C ExportDataArgs | The abstract base class for all specialized export arguments
▼C ExportObjectSelectionDataArgs | Abstract base class for all exports that allow pre-selection of to-be-exported objects
C ExportToDocxArgs | Specialized argument class for the DOCX export
C ExportToXlsxArgs | Specialized argument class for the XLSX export
C ExportToAccessArgs | Specialized argument class for the articy:access export
C ExportToFullXmlArgs | Specialized argument class for the XML export This export currently has no other configuration options
C ExportXlsxForReimportArgs | Argument class for the XLSX export for Re-Import
C ExportDocumentToDocxArgs | The parameter args to be used for exporting a document object to Word
C GenericExportDataArgs | When using the method ApiSession.ExportData an instance of this object needs to be passed along.
C OpenProjectArgs | This argument object contains all parameters for the ApiSession.OpenProject method
▼C SimplePartitionActionArgs | Base class for arguments that require a partition Guid. Some methods only need these arguments with no additional parameters
C UnclaimPartitionArgs | Argument class for unclaiming partition(s)
C WaitForAssetProcessingArgs | Argument class for the ApiSession.WaitForAssetProcessing method. The main purpose is to be able to specify a log source name where progress messages should be reported
▼C Exception |
C ArticyApiException |
C FlowListNode | Contains the information about a single node in the flow linearization
C FlowReference | Contains the information about a reference in the flow linearization
▼C IDisposable |
C ApiJourneyBuilder |
C ApiSession | Once the session is created successfully, all further API calls are invoked on this session object.
C JourneyPointAction |
C ObjectPropertyInfo | This class aggregates information about a single property that is exposed from ObjectProxy
C ObjectPropertyNames | This class contains constants for all properties that are introduced by the base objects of articy:draft
C ObjectProxy | Represents one articy:draft object like it is shown in the articy:draft GUI.
C ResultSet | This object is the container of objects that were found from a query. It is also internally used to cache meta/schema data for all accessed properties from elements in the row collection. This reduces the memory footprint and gives some extra speed when having many object of the same type in the result set.
C Transformer | This class contains methods to transform a selection of location objects. This object can only be created from an ApiLocationTools that is bound to a specific location.


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AbsoluteFilePath : ObjectPropertyNames
  • Add() : Transformer
  • AddAttachmentToStrip() : ObjectProxy
  • AddRange() : Transformer
  • AddResultSet() : Transformer
  • ApiFacility : ApiConsts
  • ApplyNumbering : FlowListNode
  • ArticyApiException() : ArticyApiException
  • AssetCategory : ObjectPropertyNames
  • AssetFilename : ObjectPropertyNames
  • AssetState : ObjectPropertyNames
  • Attachments : ObjectPropertyNames
  • AutoDisplayNamePosition : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BBCodeText : ObjectPropertyNames
  • BeginTransform() : Transformer
  • BooleanValue : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • CanBePartitioned : ObjectProxy
  • CancelTransform() : Transformer
  • CanHaveAttachments : ObjectProxy
  • CanHaveChildren : ObjectProxy
  • ChangeAsset() : ApiSession
  • CheckedPackages : ExportToAccessArgs
  • CircleToPolygon() : ApiLocationTools
  • CircleToRectangle() : ApiLocationTools
  • ClaimPartition() : ApiSession
  • ClaimPartitions() : ApiSession
  • CleanCheckout : OpenProjectArgs
  • Clear() : Transformer
  • ClearCropRect() : ApiLocationTools
  • ClearStrip() : ObjectProxy
  • CloneChildren() : ApiSession
  • CloneObject() : ApiSession
  • CloseProject() : ApiSession
  • CollectStatistics : ExportToXlsxArgs
  • Color : ObjectPropertyNames
  • Columns : ResultSet
  • CommitMessage : UnclaimPartitionArgs
  • Connection : FlowReference
  • ConnectPins() : ApiSession
  • ConnectToServer() : ApiSession
  • Content : ObjectPropertyNames
  • ContextTarget : FlowReference
  • CreateAnchor() : ApiLocationTools
  • CreateCondition() : ApiSession
  • CreateCoverPage : ExportDocumentToDocxArgs
  • CreatedBy : ObjectPropertyNames
  • CreateDialogue() : ApiSession
  • CreateDialogueFragment() : ApiSession
  • CreateDocument() : ApiSession
  • CreateDocumentDialogue() : ApiSession
  • CreateDocumentImage() : ApiSession
  • CreateDocumentText() : ApiSession
  • CreatedOn : ObjectPropertyNames
  • CreateEntity() : ApiSession
  • CreateFlowFragment() : ApiSession
  • CreateFolder() : ApiSession
  • CreateFooter : ExportDocumentToDocxArgs
  • CreateGlobalVariable() : ApiSession
  • CreateHeader : ExportDocumentToDocxArgs
  • CreateHub() : ApiSession
  • CreateInstruction() : ApiSession
  • CreateJump() : ApiSession
  • CreateLink() : ApiSession
  • CreateLocation() : ApiSession
  • CreateLocationGroup() : ApiSession
  • CreateLocationImage() : ApiSession
  • CreateLocationLayerFolder() : ApiSession
  • CreateLocationText() : ApiSession
  • CreatePath() : ApiSession
  • CreateSession() : ArticyApi
  • CreateSpot() : ApiSession
  • CreateTableOfContents : ExportDocumentToDocxArgs
  • CreateTransformer() : ApiLocationTools
  • CreateVariableSet() : ApiSession
  • CreateZoneCircle() : ApiSession
  • CreateZonePolygon() : ApiSession
  • CreateZoneRect() : ApiSession
  • CurrentSession : ArticyApi


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DataSubType : ObjectPropertyInfo
  • DataType : ObjectPropertyInfo , ObjectPropertyNames
  • DefaultValue : ObjectPropertyNames
  • DeleteObject() : ApiSession
  • Description : ObjectPropertyNames
  • DiscardChangesToPartition() : ApiSession
  • DisconnectServer() : ApiSession
  • DisplayName : ExportXlsxForReimportArgs , ObjectPropertyNames
  • DisplayNameColor : ObjectPropertyNames
  • DisplayNameColorForImage : ObjectPropertyNames
  • DisplayNameColorForLink : ObjectPropertyNames
  • DisplayNameColorForPath : ObjectPropertyNames
  • DisplayNameColorForSpot : ObjectPropertyNames
  • DisplayNameColorForZone : ObjectPropertyNames
  • DisplayNamePosX : ObjectPropertyNames
  • DisplayNamePosY : ObjectPropertyNames
  • DisplayNameSize : ObjectPropertyNames
  • DisplayNameSizeForImage : ObjectPropertyNames
  • DisplayNameSizeForLink : ObjectPropertyNames
  • DisplayNameSizeForPath : ObjectPropertyNames
  • DisplayNameSizeForSpot : ObjectPropertyNames
  • DisplayNameSizeForZone : ObjectPropertyNames
  • Dispose() : ApiSession
  • DropShadow : ObjectPropertyNames
  • DropShadowForImage : ObjectPropertyNames
  • DropShadowForLink : ObjectPropertyNames
  • DropShadowForPath : ObjectPropertyNames
  • DropShadowForSpot : ObjectPropertyNames
  • DropShadowForText : ObjectPropertyNames
  • DropShadowForZone : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EndCap : ObjectPropertyNames
  • EndTransform() : Transformer
  • EnumValues : ObjectPropertyInfo
  • ErrorCode : ArticyApiException
  • ErrorCodeMask : ApiConsts
  • ErrorNumber : ArticyApiException
  • ExclusivelyOpen : ApiSession
  • ExportCollapsed : ExportDocumentToDocxArgs
  • ExportData() : ApiSession
  • ExportDocument() : ApiSession
  • ExporterName : ExportDataArgs , ExportToAccessArgs , ExportToDocxArgs , ExportToFullXmlArgs , ExportToXlsxArgs
  • ExportMarkup : ExportDocumentToDocxArgs , ExportToFullXmlArgs , ExportToXlsxArgs
  • ExportMethod : ExportToDocxArgs
  • ExportPreviewImages : ExportDocumentToDocxArgs
  • ExportQueries : ExportToDocxArgs , ExportToFullXmlArgs , ExportToXlsxArgs , ExportXlsxForReimportArgs
  • Expression : ObjectPropertyNames
  • ExternalId : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • FacilityCode : ArticyApiException
  • FacilityMask : ApiConsts
  • FacilityShift : ApiConsts
  • FeatureOrder : ExportToXlsxArgs
  • FileExtension : ObjectPropertyNames
  • Filename : ExportDataArgs , ExportDocumentToDocxArgs , GenericExportDataArgs , ObjectPropertyNames
  • FilePath : ObjectPropertyNames
  • FileSize : ObjectPropertyNames
  • FileType : ObjectPropertyNames
  • FillColor : ObjectPropertyNames
  • FindIndex() : ObjectProxy
  • FlipHorizontal() : Transformer
  • FlipVertical() : Transformer
  • ForcedHeight : ObjectPropertyNames
  • ForcedWidth : ObjectPropertyNames
  • ForcefullyUnclaimPartition() : ApiSession
  • ForceProjectFolder : OpenProjectArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GetAttachments() : ObjectProxy
  • GetAvailableProperties() : ObjectProxy
  • GetChildren() : ObjectProxy
  • GetColor() : ObjectProxy
  • GetColumnIndex() : ObjectProxy
  • GetDataType() : ObjectProxy
  • GetDisplayName() : ObjectProxy
  • GetExportSettings() : ApiSession
  • GetExternalId() : ObjectProxy
  • GetFlowPosition() : ObjectProxy
  • GetFlowSize() : ObjectProxy
  • GetGlobalVariable() : ApiSession
  • GetHeight() : Transformer
  • GetImageCropRect() : ApiLocationTools
  • GetInputPin() : ObjectProxy
  • GetInputPins() : ObjectProxy
  • GetLocalBoundingBox() : ApiLocationTools
  • GetLocalVertices() : ApiLocationTools
  • GetLocationBitmap() : ApiLocationTools
  • GetLocationToolsFor() : ApiSession
  • GetNameOfEnumValue() : ObjectPropertyInfo
  • GetObjectById() : ApiSession
  • GetObjectByTechName() : ApiSession
  • GetObjectUrl() : ObjectProxy
  • GetOutputPin() : ObjectProxy
  • GetOutputPins() : ObjectProxy
  • GetParent() : ObjectProxy
  • GetPartitionId() : ObjectProxy
  • GetPartitionInfo() : ApiSession
  • GetPartitionInfos() : ApiSession
  • GetPivot() : Transformer
  • GetPosition() : ApiLocationTools , Transformer
  • GetPreviewImage() : ObjectProxy
  • GetProjectList() : ApiSession
  • GetProjectRoot() : ApiSession
  • GetPropertyInfo() : ObjectProxy
  • GetRotation() : Transformer
  • GetShortId() : ObjectProxy
  • GetSystemFolder() : ApiSession
  • GetSystemFolderId() : ApiSession
  • GetTechnicalName() : ObjectProxy
  • GetTemplateId() : ObjectProxy
  • GetTemplateTechnicalName() : ObjectProxy
  • GetText() : ObjectProxy
  • GetTransformedBoundingBox() : ApiLocationTools
  • GetTransformedVertices() : ApiLocationTools
  • GetTransformMatrix() : ApiLocationTools
  • GetUser() : ApiSession
  • GetUsers() : ApiSession
  • GetVariableSetByName() : ApiSession
  • GetWidth() : Transformer
  • GroupedBy : ExportToDocxArgs , ExportToXlsxArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HasColor : ObjectProxy
  • HasDisplayName : ObjectProxy
  • HasExternalId : ObjectProxy
  • HasPreviewImage : ObjectProxy
  • HasProperty() : ObjectProxy
  • HasShortId : ObjectProxy
  • HasTechnicalName : ObjectProxy
  • HasText : ObjectProxy
  • Height : ObjectPropertyNames
  • HoldsPartition : ObjectProxy
  • HyperlinkOnReferences : ExportToDocxArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • Id : ExportXlsxForReimportArgs , ObjectPropertyNames , ObjectProxy
  • IdxInJourney : ObjectPropertyNames
  • ImageAsset : ObjectPropertyNames
  • ImageOpacity : ObjectPropertyNames
  • ImportAsset() : ApiSession
  • IncludeImages : ExportToDocxArgs
  • IncludeTechnicalNames : ExportToDocxArgs
  • IncludeTitlePage : ExportToDocxArgs
  • IndentionLevel : FlowListNode
  • InsertAttachmentIntoStrip() : ObjectProxy
  • InsertTableOfContents : ExportToDocxArgs
  • IsCalculated : ObjectPropertyInfo
  • IsConnectable : ObjectProxy
  • IsConnected() : ApiSession
  • IsCustomizeable : ObjectProxy
  • IsCustomProperty : ObjectPropertyInfo
  • IsDisplayNameCalculated : ObjectProxy
  • IsFolder : ObjectProxy
  • IsInnerReference : FlowReference
  • IsInternalReference : FlowReference
  • IsLoggedIn() : ApiSession
  • IsReadOnly : ObjectProxy
  • IsSystemFolder : ObjectProxy
  • IsUserFolder : ObjectProxy
  • IsValid : ObjectProxy
  • IsValidExpressoScript() : ObjectProxy


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • JourneyPoints : ObjectPropertyNames
  • JourneyPointType : ObjectPropertyNames
  • JourneyState : ObjectPropertyNames
  • JumpTargets : FlowListNode


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • KeepClaim : UnclaimPartitionArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • Label : ObjectPropertyNames
  • LeaveExclusiveMode : CloseProjectArgs
  • LinearizeFlowSegment() : ApiSession
  • LineWidth : ObjectPropertyNames
  • LinkStyleSize : ObjectPropertyNames
  • LinkStyleType : ObjectPropertyNames
  • LoadExportPreset() : ApiSession
  • LocalOrder : FlowListNode
  • Login() : ApiSession
  • Logout() : ApiSession
  • LogSourceName : ComplexApiCallArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MakeErrorCode() : ApiConsts
  • MarkupText : ObjectPropertyNames
  • MayAddAttachmentToStrip() : ObjectProxy
  • MayInsertAttachmentIntoStrip() : ObjectProxy
  • MenuText : ObjectPropertyNames
  • Message : ArticyApiException
  • MoveObject() : ApiSession
  • MoveObjects() : ApiSession
  • MsgSrcApi : ApiConsts
  • MsgSrcSystem : ApiConsts


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • Name : ObjectPropertyInfo
  • Namespaces : ObjectPropertyNames
  • Node : FlowListNode
  • NumericValue : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • ObjectReference : ObjectPropertyNames
  • ObjectType : ObjectPropertyNames , ObjectProxy
  • OpenExclusively : OpenProjectArgs
  • OpenProject() : ApiSession
  • OriginalSource : ObjectPropertyNames
  • OutlineColor : ObjectPropertyNames
  • OutlineSize : ObjectPropertyNames
  • OutlineStyle : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PackageFileName : ExportToAccessArgs
  • PageSize : ExportDocumentToDocxArgs , ExportToDocxArgs , ExportToXlsxArgs
  • Parent : ExportXlsxForReimportArgs , FlowListNode , ObjectPropertyNames
  • PartitionGuid : SimplePartitionActionArgs
  • PinIndex : ObjectPropertyNames
  • PinType : ObjectPropertyNames
  • PolygonToCircle() : ApiLocationTools
  • PolygonToRectangle() : ApiLocationTools
  • Portrait : ExportDocumentToDocxArgs
  • PosX : ObjectPropertyNames
  • PosY : ObjectPropertyNames
  • PreselectedObjects : ExportObjectSelectionDataArgs , GenericExportDataArgs
  • PreviewImageAsset : ObjectPropertyNames
  • ProjectFolder : OpenProjectArgs
  • ProjectGuid : OpenProjectArgs
  • ProjectOpen : ApiSession
  • PublishProject() : ApiSession


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • ReachedByActionType : ObjectPropertyNames
  • ReadOnly : ObjectPropertyInfo
  • RecenterPivot() : Transformer
  • Redo() : Transformer
  • RefactorVariableReferences() : ApiSession
  • ReferencedTarget : FlowReference
  • ReferenceType : FlowReference
  • RefType : FlowReference
  • ReimportAsset() : ApiSession
  • Remove() : Transformer
  • RemoveAllAnchors() : ApiLocationTools
  • RemoveAnchor() : ApiLocationTools
  • RemoveAttachmentFromStrip() : ObjectProxy
  • RemoveAttachmentFromStripAtIndex() : ObjectProxy
  • RemoveRange() : Transformer
  • RemoveResultSet() : Transformer
  • Repartition() : ApiSession
  • ResetAspectHorizontal() : ApiLocationTools
  • ResetAspectVertical() : ApiLocationTools
  • ResetTransformation() : ApiLocationTools
  • Rows : ResultSet
  • RunQuery() : ApiSession , ObjectProxy


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SaveLocationAsJpeg() : ApiLocationTools
  • SaveLocationAsPng() : ApiLocationTools
  • SaveLocationAsXps() : ApiLocationTools
  • SaveProject() : ApiSession
  • ScmPassword : OpenProjectArgs
  • ScmUsername : OpenProjectArgs
  • ScriptingName : ObjectPropertyNames
  • Selectability : ObjectPropertyNames
  • SelectedProperties : ExportXlsxForReimportArgs
  • ServerFacility : ApiConsts
  • SetColor() : ObjectProxy
  • SetDisplayName() : ObjectProxy
  • SetExternalId() : ObjectProxy
  • SetFlowPosition() : ObjectProxy
  • SetFlowSize() : ObjectProxy
  • SetHeight() : Transformer
  • SetImage() : ApiLocationTools
  • SetImageCropRect() : ApiLocationTools
  • SetLoggingCallback() : ArticyApi
  • SetPivot() : Transformer
  • SetPosition() : ApiLocationTools , Transformer
  • SetPreviewImage() : ObjectProxy
  • SetRotation() : Transformer
  • SetShortId() : ObjectProxy
  • SetSize() : Transformer
  • SetTechnicalName() : ObjectProxy
  • SetTemplate() : ObjectProxy
  • SetText() : ObjectProxy
  • SetTransformMode() : Transformer
  • SetWidth() : Transformer
  • ShapeType : ObjectPropertyNames
  • ShortId : ObjectPropertyNames
  • ShowCalculatedDisplayName : ObjectPropertyNames
  • ShowDisplayName : ObjectPropertyNames
  • ShowDisplayNameForImage : ObjectPropertyNames
  • ShowDisplayNameForLink : ObjectPropertyNames
  • ShowDisplayNameForPath : ObjectPropertyNames
  • ShowDisplayNameForSpot : ObjectPropertyNames
  • ShowDisplayNameForZone : ObjectPropertyNames
  • ShowLabel : ObjectPropertyNames
  • Shutdown() : ArticyApi
  • SideBySideImages : ExportToDocxArgs
  • SimpleFindConflicts() : ApiSession
  • SimpleFindObjects() : ApiSession
  • SimplifyPath() : ApiLocationTools
  • SkipJumps : FlowListNode
  • SortedBy : ExportToDocxArgs , ExportToXlsxArgs , ExportXlsxForReimportArgs
  • SortObjectsBy : ExportXlsxForReimportArgs
  • Source : ObjectPropertyNames
  • SourcePin : ObjectPropertyNames
  • Speaker : ObjectPropertyNames
  • SpotStyleSize : ObjectPropertyNames
  • SpotStyleType : ObjectPropertyNames
  • StageDirections : ObjectPropertyNames
  • StartCap : ObjectPropertyNames
  • Startup() : ArticyApi
  • SupportsExpressoScript : ObjectPropertyInfo


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TablePerGroup : ExportToXlsxArgs
  • Target : ObjectPropertyNames
  • TargetPin : ObjectPropertyNames
  • TechnicalName : ExportXlsxForReimportArgs , ObjectPropertyNames
  • TemplateName : ObjectPropertyNames
  • Text : ObjectPropertyNames
  • TextConfiguration : GenericExportDataArgs
  • this[int aColumnIndex] : ObjectProxy
  • this[string aPropertyName] : ObjectProxy
  • TransformPivotX : ObjectPropertyNames
  • TransformPivotY : ObjectPropertyNames
  • TransformRotation : ObjectPropertyNames
  • TransformXAxisX : ObjectPropertyNames
  • TransformXAxisY : ObjectPropertyNames
  • TransformYAxisX : ObjectPropertyNames
  • TransformYAxisY : ObjectPropertyNames
  • TypeName : ObjectProxy


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UnclaimAllMyPartitions() : ApiSession
  • UnclaimPartition() : ApiSession
  • UnclaimPartitions() : ApiSession
  • UnconnectedThreads : FlowListNode
  • Undo() : Transformer
  • UpdatePartition() : ApiSession
  • UpdatePartitions() : ApiSession
  • Url : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidateExpressoScript() : ObjectProxy
  • Variables : ObjectPropertyNames
  • Visibility : ObjectPropertyNames


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WaitForAssetProcessing() : ApiSession
  • WaitForThumbnails : WaitForAssetProcessingArgs
  • WhichName : ExportToXlsxArgs
  • Width : ObjectPropertyNames
  • WriteAllVariables : ExportToFullXmlArgs
  • WriteNamespace : ExportToFullXmlArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • XmlConfiguration : GenericExportDataArgs


articy:draft API: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • ZIndex : ObjectPropertyNames


articy:draft API: Class Members - Functions

- a -

  • Add() : Transformer
  • AddAttachmentToStrip() : ObjectProxy
  • AddRange() : Transformer
  • AddResultSet() : Transformer
  • ArticyApiException() : ArticyApiException


articy:draft API: Class Members - Functions

- b -

  • BeginTransform() : Transformer


articy:draft API: Class Members - Functions

- c -

  • CancelTransform() : Transformer
  • ChangeAsset() : ApiSession
  • CircleToPolygon() : ApiLocationTools
  • CircleToRectangle() : ApiLocationTools
  • ClaimPartition() : ApiSession
  • ClaimPartitions() : ApiSession
  • Clear() : Transformer
  • ClearCropRect() : ApiLocationTools
  • ClearStrip() : ObjectProxy
  • CloneChildren() : ApiSession
  • CloneObject() : ApiSession
  • CloseProject() : ApiSession
  • ConnectPins() : ApiSession
  • ConnectToServer() : ApiSession
  • CreateAnchor() : ApiLocationTools
  • CreateCondition() : ApiSession
  • CreateDialogue() : ApiSession
  • CreateDialogueFragment() : ApiSession
  • CreateDocument() : ApiSession
  • CreateDocumentDialogue() : ApiSession
  • CreateDocumentImage() : ApiSession
  • CreateDocumentText() : ApiSession
  • CreateEntity() : ApiSession
  • CreateFlowFragment() : ApiSession
  • CreateFolder() : ApiSession
  • CreateGlobalVariable() : ApiSession
  • CreateHub() : ApiSession
  • CreateInstruction() : ApiSession
  • CreateJump() : ApiSession
  • CreateLink() : ApiSession
  • CreateLocation() : ApiSession
  • CreateLocationGroup() : ApiSession
  • CreateLocationImage() : ApiSession
  • CreateLocationLayerFolder() : ApiSession
  • CreateLocationText() : ApiSession
  • CreatePath() : ApiSession
  • CreateSession() : ArticyApi
  • CreateSpot() : ApiSession
  • CreateTransformer() : ApiLocationTools
  • CreateVariableSet() : ApiSession
  • CreateZoneCircle() : ApiSession
  • CreateZonePolygon() : ApiSession
  • CreateZoneRect() : ApiSession


articy:draft API: Class Members - Functions

- d -

  • DeleteObject() : ApiSession
  • DiscardChangesToPartition() : ApiSession
  • DisconnectServer() : ApiSession
  • Dispose() : ApiSession


articy:draft API: Class Members - Functions

- e -

  • EndTransform() : Transformer
  • ExportData() : ApiSession
  • ExportDocument() : ApiSession


articy:draft API: Class Members - Functions

- f -

  • FindIndex() : ObjectProxy
  • FlipHorizontal() : Transformer
  • FlipVertical() : Transformer
  • ForcefullyUnclaimPartition() : ApiSession


articy:draft API: Class Members - Functions

- g -

  • GetAttachments() : ObjectProxy
  • GetAvailableProperties() : ObjectProxy
  • GetChildren() : ObjectProxy
  • GetColor() : ObjectProxy
  • GetColumnIndex() : ObjectProxy
  • GetDataType() : ObjectProxy
  • GetDisplayName() : ObjectProxy
  • GetExportSettings() : ApiSession
  • GetExternalId() : ObjectProxy
  • GetFlowPosition() : ObjectProxy
  • GetFlowSize() : ObjectProxy
  • GetGlobalVariable() : ApiSession
  • GetHeight() : Transformer
  • GetImageCropRect() : ApiLocationTools
  • GetInputPin() : ObjectProxy
  • GetInputPins() : ObjectProxy
  • GetLocalBoundingBox() : ApiLocationTools
  • GetLocalVertices() : ApiLocationTools
  • GetLocationBitmap() : ApiLocationTools
  • GetLocationToolsFor() : ApiSession
  • GetNameOfEnumValue() : ObjectPropertyInfo
  • GetObjectById() : ApiSession
  • GetObjectByTechName() : ApiSession
  • GetObjectUrl() : ObjectProxy
  • GetOutputPin() : ObjectProxy
  • GetOutputPins() : ObjectProxy
  • GetParent() : ObjectProxy
  • GetPartitionId() : ObjectProxy
  • GetPartitionInfo() : ApiSession
  • GetPartitionInfos() : ApiSession
  • GetPivot() : Transformer
  • GetPosition() : ApiLocationTools , Transformer
  • GetPreviewImage() : ObjectProxy
  • GetProjectList() : ApiSession
  • GetProjectRoot() : ApiSession
  • GetPropertyInfo() : ObjectProxy
  • GetRotation() : Transformer
  • GetShortId() : ObjectProxy
  • GetSystemFolder() : ApiSession
  • GetSystemFolderId() : ApiSession
  • GetTechnicalName() : ObjectProxy
  • GetTemplateId() : ObjectProxy
  • GetTemplateTechnicalName() : ObjectProxy
  • GetText() : ObjectProxy
  • GetTransformedBoundingBox() : ApiLocationTools
  • GetTransformedVertices() : ApiLocationTools
  • GetTransformMatrix() : ApiLocationTools
  • GetUser() : ApiSession
  • GetUsers() : ApiSession
  • GetVariableSetByName() : ApiSession
  • GetWidth() : Transformer


articy:draft API: Class Members - Functions

- h -

  • HasProperty() : ObjectProxy


articy:draft API: Class Members - Functions

- i -

  • ImportAsset() : ApiSession
  • InsertAttachmentIntoStrip() : ObjectProxy
  • IsConnected() : ApiSession
  • IsLoggedIn() : ApiSession
  • IsValidExpressoScript() : ObjectProxy


articy:draft API: Class Members - Functions

- l -

  • LinearizeFlowSegment() : ApiSession
  • LoadExportPreset() : ApiSession
  • Login() : ApiSession
  • Logout() : ApiSession


articy:draft API: Class Members - Functions

- m -

  • MakeErrorCode() : ApiConsts
  • MayAddAttachmentToStrip() : ObjectProxy
  • MayInsertAttachmentIntoStrip() : ObjectProxy
  • MoveObject() : ApiSession
  • MoveObjects() : ApiSession


articy:draft API: Class Members - Functions

- o -

  • OpenProject() : ApiSession


articy:draft API: Class Members - Functions

- p -

  • PolygonToCircle() : ApiLocationTools
  • PolygonToRectangle() : ApiLocationTools
  • PublishProject() : ApiSession


articy:draft API: Class Members - Functions

- r -

  • RecenterPivot() : Transformer
  • Redo() : Transformer
  • RefactorVariableReferences() : ApiSession
  • ReimportAsset() : ApiSession
  • Remove() : Transformer
  • RemoveAllAnchors() : ApiLocationTools
  • RemoveAnchor() : ApiLocationTools
  • RemoveAttachmentFromStrip() : ObjectProxy
  • RemoveAttachmentFromStripAtIndex() : ObjectProxy
  • RemoveRange() : Transformer
  • RemoveResultSet() : Transformer
  • Repartition() : ApiSession
  • ResetAspectHorizontal() : ApiLocationTools
  • ResetAspectVertical() : ApiLocationTools
  • ResetTransformation() : ApiLocationTools
  • RunQuery() : ApiSession , ObjectProxy


articy:draft API: Class Members - Functions

- s -

  • SaveLocationAsJpeg() : ApiLocationTools
  • SaveLocationAsPng() : ApiLocationTools
  • SaveLocationAsXps() : ApiLocationTools
  • SaveProject() : ApiSession
  • SetColor() : ObjectProxy
  • SetDisplayName() : ObjectProxy
  • SetExternalId() : ObjectProxy
  • SetFlowPosition() : ObjectProxy
  • SetFlowSize() : ObjectProxy
  • SetHeight() : Transformer
  • SetImage() : ApiLocationTools
  • SetImageCropRect() : ApiLocationTools
  • SetLoggingCallback() : ArticyApi
  • SetPivot() : Transformer
  • SetPosition() : ApiLocationTools , Transformer
  • SetPreviewImage() : ObjectProxy
  • SetRotation() : Transformer
  • SetShortId() : ObjectProxy
  • SetSize() : Transformer
  • SetTechnicalName() : ObjectProxy
  • SetTemplate() : ObjectProxy
  • SetText() : ObjectProxy
  • SetTransformMode() : Transformer
  • SetWidth() : Transformer
  • Shutdown() : ArticyApi
  • SimpleFindConflicts() : ApiSession
  • SimpleFindObjects() : ApiSession
  • SimplifyPath() : ApiLocationTools
  • Startup() : ArticyApi


articy:draft API: Class Members - Functions

- u -

  • UnclaimAllMyPartitions() : ApiSession
  • UnclaimPartition() : ApiSession
  • UnclaimPartitions() : ApiSession
  • Undo() : Transformer
  • UpdatePartition() : ApiSession
  • UpdatePartitions() : ApiSession


articy:draft API: Class Members - Functions

- v -

  • ValidateExpressoScript() : ObjectProxy


articy:draft API: Class Members - Functions

- w -

  • WaitForAssetProcessing() : ApiSession


articy:draft API: Class Members - Variables

- a -

  • AbsoluteFilePath : ObjectPropertyNames
  • ApiFacility : ApiConsts
  • AssetCategory : ObjectPropertyNames
  • AssetFilename : ObjectPropertyNames
  • AssetState : ObjectPropertyNames
  • Attachments : ObjectPropertyNames
  • AutoDisplayNamePosition : ObjectPropertyNames

- b -

  • BBCodeText : ObjectPropertyNames
  • BooleanValue : ObjectPropertyNames

- c -

  • Color : ObjectPropertyNames
  • Content : ObjectPropertyNames
  • CreatedBy : ObjectPropertyNames
  • CreatedOn : ObjectPropertyNames

- d -

  • DataType : ObjectPropertyNames
  • DefaultValue : ObjectPropertyNames
  • Description : ObjectPropertyNames
  • DisplayName : ObjectPropertyNames
  • DisplayNameColor : ObjectPropertyNames
  • DisplayNameColorForImage : ObjectPropertyNames
  • DisplayNameColorForLink : ObjectPropertyNames
  • DisplayNameColorForPath : ObjectPropertyNames
  • DisplayNameColorForSpot : ObjectPropertyNames
  • DisplayNameColorForZone : ObjectPropertyNames
  • DisplayNamePosX : ObjectPropertyNames
  • DisplayNamePosY : ObjectPropertyNames
  • DisplayNameSize : ObjectPropertyNames
  • DisplayNameSizeForImage : ObjectPropertyNames
  • DisplayNameSizeForLink : ObjectPropertyNames
  • DisplayNameSizeForPath : ObjectPropertyNames
  • DisplayNameSizeForSpot : ObjectPropertyNames
  • DisplayNameSizeForZone : ObjectPropertyNames
  • DropShadow : ObjectPropertyNames
  • DropShadowForImage : ObjectPropertyNames
  • DropShadowForLink : ObjectPropertyNames
  • DropShadowForPath : ObjectPropertyNames
  • DropShadowForSpot : ObjectPropertyNames
  • DropShadowForText : ObjectPropertyNames
  • DropShadowForZone : ObjectPropertyNames

- e -

  • EndCap : ObjectPropertyNames
  • ErrorCodeMask : ApiConsts
  • Expression : ObjectPropertyNames
  • ExternalId : ObjectPropertyNames

- f -

  • FacilityMask : ApiConsts
  • FacilityShift : ApiConsts
  • FileExtension : ObjectPropertyNames
  • Filename : ObjectPropertyNames
  • FilePath : ObjectPropertyNames
  • FileSize : ObjectPropertyNames
  • FileType : ObjectPropertyNames
  • FillColor : ObjectPropertyNames
  • ForcedHeight : ObjectPropertyNames
  • ForcedWidth : ObjectPropertyNames

- h -

  • Height : ObjectPropertyNames

- i -

  • Id : ObjectPropertyNames
  • IdxInJourney : ObjectPropertyNames
  • ImageAsset : ObjectPropertyNames
  • ImageOpacity : ObjectPropertyNames

- j -

  • JourneyPoints : ObjectPropertyNames
  • JourneyPointType : ObjectPropertyNames
  • JourneyState : ObjectPropertyNames

- l -

  • Label : ObjectPropertyNames
  • LineWidth : ObjectPropertyNames
  • LinkStyleSize : ObjectPropertyNames
  • LinkStyleType : ObjectPropertyNames

- m -

  • MarkupText : ObjectPropertyNames
  • MenuText : ObjectPropertyNames
  • MsgSrcApi : ApiConsts
  • MsgSrcSystem : ApiConsts

- n -

  • Namespaces : ObjectPropertyNames
  • NumericValue : ObjectPropertyNames

- o -

  • ObjectReference : ObjectPropertyNames
  • ObjectType : ObjectPropertyNames
  • OriginalSource : ObjectPropertyNames
  • OutlineColor : ObjectPropertyNames
  • OutlineSize : ObjectPropertyNames
  • OutlineStyle : ObjectPropertyNames

- p -

  • Parent : ObjectPropertyNames
  • PinIndex : ObjectPropertyNames
  • PinType : ObjectPropertyNames
  • PosX : ObjectPropertyNames
  • PosY : ObjectPropertyNames
  • PreviewImageAsset : ObjectPropertyNames

- r -

  • ReachedByActionType : ObjectPropertyNames

- s -

  • ScriptingName : ObjectPropertyNames
  • Selectability : ObjectPropertyNames
  • ServerFacility : ApiConsts
  • ShapeType : ObjectPropertyNames
  • ShortId : ObjectPropertyNames
  • ShowCalculatedDisplayName : ObjectPropertyNames
  • ShowDisplayName : ObjectPropertyNames
  • ShowDisplayNameForImage : ObjectPropertyNames
  • ShowDisplayNameForLink : ObjectPropertyNames
  • ShowDisplayNameForPath : ObjectPropertyNames
  • ShowDisplayNameForSpot : ObjectPropertyNames
  • ShowDisplayNameForZone : ObjectPropertyNames
  • ShowLabel : ObjectPropertyNames
  • Source : ObjectPropertyNames
  • SourcePin : ObjectPropertyNames
  • Speaker : ObjectPropertyNames
  • SpotStyleSize : ObjectPropertyNames
  • SpotStyleType : ObjectPropertyNames
  • StageDirections : ObjectPropertyNames
  • StartCap : ObjectPropertyNames

- t -

  • Target : ObjectPropertyNames
  • TargetPin : ObjectPropertyNames
  • TechnicalName : ObjectPropertyNames
  • TemplateName : ObjectPropertyNames
  • Text : ObjectPropertyNames
  • TransformPivotX : ObjectPropertyNames
  • TransformPivotY : ObjectPropertyNames
  • TransformRotation : ObjectPropertyNames
  • TransformXAxisX : ObjectPropertyNames
  • TransformXAxisY : ObjectPropertyNames
  • TransformYAxisX : ObjectPropertyNames
  • TransformYAxisY : ObjectPropertyNames

- u -

  • Url : ObjectPropertyNames

- v -

  • Variables : ObjectPropertyNames
  • Visibility : ObjectPropertyNames

- w -

  • Width : ObjectPropertyNames

- z -

  • ZIndex : ObjectPropertyNames


articy:draft API: Class Members - Enumerations

  • RefType : FlowReference
  • SortObjectsBy : ExportXlsxForReimportArgs


articy:draft API: Class Members - Enumerator

  • DisplayName : ExportXlsxForReimportArgs
  • Id : ExportXlsxForReimportArgs
  • Parent : ExportXlsxForReimportArgs
  • TechnicalName : ExportXlsxForReimportArgs


articy:draft API: Class Members - Properties

- a -

  • ApplyNumbering : FlowListNode

- c -

  • CanBePartitioned : ObjectProxy
  • CanHaveAttachments : ObjectProxy
  • CanHaveChildren : ObjectProxy
  • CheckedPackages : ExportToAccessArgs
  • CleanCheckout : OpenProjectArgs
  • CollectStatistics : ExportToXlsxArgs
  • Columns : ResultSet
  • CommitMessage : UnclaimPartitionArgs
  • Connection : FlowReference
  • ContextTarget : FlowReference
  • CreateCoverPage : ExportDocumentToDocxArgs
  • CreateFooter : ExportDocumentToDocxArgs
  • CreateHeader : ExportDocumentToDocxArgs
  • CreateTableOfContents : ExportDocumentToDocxArgs
  • CurrentSession : ArticyApi

- d -

  • DataSubType : ObjectPropertyInfo
  • DataType : ObjectPropertyInfo

- e -

  • EnumValues : ObjectPropertyInfo
  • ErrorCode : ArticyApiException
  • ErrorNumber : ArticyApiException
  • ExclusivelyOpen : ApiSession
  • ExportCollapsed : ExportDocumentToDocxArgs
  • ExporterName : ExportDataArgs , ExportToAccessArgs , ExportToDocxArgs , ExportToFullXmlArgs , ExportToXlsxArgs
  • ExportMarkup : ExportDocumentToDocxArgs , ExportToFullXmlArgs , ExportToXlsxArgs
  • ExportMethod : ExportToDocxArgs
  • ExportPreviewImages : ExportDocumentToDocxArgs
  • ExportQueries : ExportToDocxArgs , ExportToFullXmlArgs , ExportToXlsxArgs , ExportXlsxForReimportArgs

- f -

  • FacilityCode : ArticyApiException
  • FeatureOrder : ExportToXlsxArgs
  • Filename : ExportDataArgs , ExportDocumentToDocxArgs , GenericExportDataArgs
  • ForceProjectFolder : OpenProjectArgs

- g -

  • GroupedBy : ExportToDocxArgs , ExportToXlsxArgs

- h -

  • HasColor : ObjectProxy
  • HasDisplayName : ObjectProxy
  • HasExternalId : ObjectProxy
  • HasPreviewImage : ObjectProxy
  • HasShortId : ObjectProxy
  • HasTechnicalName : ObjectProxy
  • HasText : ObjectProxy
  • HoldsPartition : ObjectProxy
  • HyperlinkOnReferences : ExportToDocxArgs

- i -

  • Id : ObjectProxy
  • IncludeImages : ExportToDocxArgs
  • IncludeTechnicalNames : ExportToDocxArgs
  • IncludeTitlePage : ExportToDocxArgs
  • IndentionLevel : FlowListNode
  • InsertTableOfContents : ExportToDocxArgs
  • IsCalculated : ObjectPropertyInfo
  • IsConnectable : ObjectProxy
  • IsCustomizeable : ObjectProxy
  • IsCustomProperty : ObjectPropertyInfo
  • IsDisplayNameCalculated : ObjectProxy
  • IsFolder : ObjectProxy
  • IsInnerReference : FlowReference
  • IsInternalReference : FlowReference
  • IsReadOnly : ObjectProxy
  • IsSystemFolder : ObjectProxy
  • IsUserFolder : ObjectProxy
  • IsValid : ObjectProxy

- j -

  • JumpTargets : FlowListNode

- k -

  • KeepClaim : UnclaimPartitionArgs

- l -

  • LeaveExclusiveMode : CloseProjectArgs
  • LocalOrder : FlowListNode
  • LogSourceName : ComplexApiCallArgs

- m -

  • Message : ArticyApiException

- n -

  • Name : ObjectPropertyInfo
  • Node : FlowListNode

- o -

  • ObjectType : ObjectProxy
  • OpenExclusively : OpenProjectArgs

- p -

  • PackageFileName : ExportToAccessArgs
  • PageSize : ExportDocumentToDocxArgs , ExportToDocxArgs , ExportToXlsxArgs
  • Parent : FlowListNode
  • PartitionGuid : SimplePartitionActionArgs
  • Portrait : ExportDocumentToDocxArgs
  • PreselectedObjects : ExportObjectSelectionDataArgs , GenericExportDataArgs
  • ProjectFolder : OpenProjectArgs
  • ProjectGuid : OpenProjectArgs
  • ProjectOpen : ApiSession

- r -

  • ReadOnly : ObjectPropertyInfo
  • ReferencedTarget : FlowReference
  • ReferenceType : FlowReference
  • Rows : ResultSet

- s -

  • ScmPassword : OpenProjectArgs
  • ScmUsername : OpenProjectArgs
  • SelectedProperties : ExportXlsxForReimportArgs
  • SideBySideImages : ExportToDocxArgs
  • SkipJumps : FlowListNode
  • SortedBy : ExportToDocxArgs , ExportToXlsxArgs , ExportXlsxForReimportArgs
  • SupportsExpressoScript : ObjectPropertyInfo

- t -

  • TablePerGroup : ExportToXlsxArgs
  • TextConfiguration : GenericExportDataArgs
  • this[int aColumnIndex] : ObjectProxy
  • this[string aPropertyName] : ObjectProxy
  • TypeName : ObjectProxy

- u -

  • UnconnectedThreads : FlowListNode

- w -

  • WaitForThumbnails : WaitForAssetProcessingArgs
  • WhichName : ExportToXlsxArgs
  • WriteAllVariables : ExportToFullXmlArgs
  • WriteNamespace : ExportToFullXmlArgs

- x -

  • XmlConfiguration : GenericExportDataArgs


articy:draft API: QueryLayer Directory Reference

  • Managed
  • QueryLayer
QueryLayer Directory Reference

Directories

directory Data

Files

file | ObjectProxy.cs
file | ResultSet.cs


articy:draft API: PublicApiTypes Directory Reference

  • Managed
  • PublicApiTypes
PublicApiTypes Directory Reference

Files

file | ApiConsts.cs
file | ApiNames.cs
file | ApiTypes.cs
file | ArticyApiException.cs
file | ErrorCode.cs
file | OfficeExportTypes.cs


articy:draft API: Data Directory Reference

  • Managed
  • QueryLayer
  • Data
Data Directory Reference

Files

file ObjectPropertyInfo.cs


articy:draft API: ArticyAPI Directory Reference

  • Managed
  • ArticyAPI
ArticyAPI Directory Reference

Files

file | ActionArgs.cs
file | ApiCollaborativeHelper.cs
file | ApiFlowLinearizerTypes.cs
file | ApiJourneyBuilder.cs
file | ApiJourneyBuilder.Privates.cs
file | ApiLauncher.cs
file | ApiLocationTools.cs
file | ApiLocationTools.Private.cs
file | ApiSession.cs
file | ApiSession.ObjectCreation.cs
file | ApiSession.Privates.cs
file | ArticyApi.cs
file | ExportArgs.cs
file | Transformer.cs
file | Transformer.Privates.cs


articy:draft API: Managed Directory Reference

  • Managed
Managed Directory Reference

Directories

directory | ArticyAPI
directory | PublicApiTypes
directory | QueryLayer


articy:draft API: Member List

  • Api
  • GenericExportDataArgs
GenericExportDataArgs Member List

This is the complete list of members for GenericExportDataArgs, including all inherited members.

Filename | GenericExportDataArgs
LogSourceName | ComplexApiCallArgs
PreselectedObjects | GenericExportDataArgs
TextConfiguration | GenericExportDataArgs
XmlConfiguration | GenericExportDataArgs


articy:draft API: Member List

  • Api
  • CloseProjectArgs
CloseProjectArgs Member List

This is the complete list of members for CloseProjectArgs, including all inherited members.

CloseProjectArgs() (defined in CloseProjectArgs) | CloseProjectArgs | inline
LeaveExclusiveMode | CloseProjectArgs |
LogSourceName | ComplexApiCallArgs |


articy:draft API: Member List

  • Api
  • ArticyApiException
ArticyApiException Member List

This is the complete list of members for ArticyApiException, including all inherited members.

ArticyApiException(int aErrorCode) | ArticyApiException | inline
ArticyApiException(int aErrorCode, string aMessage) | ArticyApiException | inline
ArticyApiException(int aErrorCode, Exception aInnerException) | ArticyApiException | inline
ArticyApiException(int aErrorCode, string aMessage, Exception aInnerException) | ArticyApiException | inline
ArticyApiException(ErrorCode aErrorCode) | ArticyApiException | inline
ArticyApiException(ErrorCode aErrorCode, string aMessage) | ArticyApiException | inline
ArticyApiException(ErrorCode aErrorCode, Exception aInnerException) | ArticyApiException | inline
ArticyApiException(ErrorCode aErrorCode, string aMessage, Exception aInnerException) | ArticyApiException | inline
ErrorCode | ArticyApiException |
ErrorNumber | ArticyApiException |
FacilityCode | ArticyApiException |
Message | ArticyApiException |


articy:draft API: Member List

  • Api
  • ExportDocumentToDocxArgs
ExportDocumentToDocxArgs Member List

This is the complete list of members for ExportDocumentToDocxArgs, including all inherited members.

CreateCoverPage | ExportDocumentToDocxArgs |
CreateFooter | ExportDocumentToDocxArgs |
CreateHeader | ExportDocumentToDocxArgs |
CreateTableOfContents | ExportDocumentToDocxArgs |
ExportCollapsed | ExportDocumentToDocxArgs |
ExportDocumentToDocxArgs() (defined in ExportDocumentToDocxArgs) | ExportDocumentToDocxArgs | inline
ExportMarkup | ExportDocumentToDocxArgs |
ExportPreviewImages | ExportDocumentToDocxArgs |
Filename | ExportDocumentToDocxArgs |
LogSourceName | ComplexApiCallArgs |
PageSize | ExportDocumentToDocxArgs |
Portrait | ExportDocumentToDocxArgs |


articy:draft API: Member List

  • Api
  • ObjectProxy
ObjectProxy Member List

This is the complete list of members for ObjectProxy, including all inherited members.

AddAttachmentToStrip(string aPropertyName, ObjectProxy aAttachment) | ObjectProxy | inline
AddInputPin() (defined in ObjectProxy) | ObjectProxy | inline
AddOutputPin() (defined in ObjectProxy) | ObjectProxy | inline
CanBePartitioned | ObjectProxy |
CanHaveAttachments | ObjectProxy |
CanHaveChildren | ObjectProxy |
ClearStrip(string aPropertyName) | ObjectProxy | inline
FindIndex(string aPropertyName, ObjectProxy aAttachment) | ObjectProxy | inline
GetAttachments() | ObjectProxy | inline
GetAvailableProperties() | ObjectProxy | inline
GetAvailableProperties(PropertyFilter aPropFilter) | ObjectProxy | inline
GetChildren() | ObjectProxy | inline
GetColor() | ObjectProxy | inline
GetColumnIndex(string aPropertyName) | ObjectProxy | inline
GetDataType(string aProperty) | ObjectProxy | inline
GetDisplayName() | ObjectProxy | inline
GetExternalId() | ObjectProxy | inline
GetFlowPosition() | ObjectProxy | inline
GetFlowSize() | ObjectProxy | inline
GetInputPin(int aIndex) | ObjectProxy | inline
GetInputPins() | ObjectProxy | inline
GetObjectUrl() | ObjectProxy | inline
GetOutputPin(int aIndex) | ObjectProxy | inline
GetOutputPins() | ObjectProxy | inline
GetParent() | ObjectProxy | inline
GetPartitionId() | ObjectProxy | inline
GetPreviewImage() | ObjectProxy | inline
GetPropertyInfo(string aProperty) | ObjectProxy | inline
GetShortId() | ObjectProxy | inline
GetTechnicalName() | ObjectProxy | inline
GetTemplateId() | ObjectProxy | inline
GetTemplateTechnicalName() | ObjectProxy | inline
GetText() | ObjectProxy | inline
HasColor | ObjectProxy |
HasDisplayName | ObjectProxy |
HasExternalId | ObjectProxy |
HasPreviewImage | ObjectProxy |
HasProperty(string aProperty) | ObjectProxy | inline
HasShortId | ObjectProxy |
HasTechnicalName | ObjectProxy |
HasText | ObjectProxy |
HoldsPartition | ObjectProxy |
Id | ObjectProxy |
InsertAttachmentIntoStrip(string aPropertyName, ObjectProxy aAttachment, int aIndex) | ObjectProxy | inline
IsConnectable | ObjectProxy |
IsCustomizeable | ObjectProxy |
IsDisplayNameCalculated | ObjectProxy |
IsFolder | ObjectProxy |
IsReadOnly | ObjectProxy |
IsSystemFolder | ObjectProxy |
IsUserFolder | ObjectProxy |
IsValid | ObjectProxy |
IsValidExpressoScript(string aScriptText) | ObjectProxy | inline
IsValidExpressoScript(string aPropertyName, string aScriptText) | ObjectProxy | inline
MayAddAttachmentToStrip(string aPropertyName, ObjectProxy aAttachment) | ObjectProxy | inline
MayInsertAttachmentIntoStrip(string aPropertyName, ObjectProxy aAttachment, int aIndex) | ObjectProxy | inline
MaySetObjectReference(string aPropertyName, ObjectProxy aAttachment) (defined in ObjectProxy) | ObjectProxy | inline
ObjectType | ObjectProxy |
RemoveAttachmentFromStrip(string aPropertyName, ObjectProxy aAttachment) | ObjectProxy | inline
RemoveAttachmentFromStripAtIndex(string aPropertyName, int aIndex) | ObjectProxy | inline
RemoveInputPin(int aPinIndex) (defined in ObjectProxy) | ObjectProxy | inline
RemoveOutputPin(int aPinIndex) (defined in ObjectProxy) | ObjectProxy | inline
RunQuery(string aQuery) | ObjectProxy | inline
SetColor(System.Windows.Media.Color aColor) | ObjectProxy | inline
SetDisplayName(string aDisplayName) | ObjectProxy | inline
SetExternalId(string aExternalId) | ObjectProxy | inline
SetFlowPosition(Point aPosition) | ObjectProxy | inline
SetFlowPosition(double aPosX, double aPosY) | ObjectProxy | inline
SetFlowSize(Size aSize) | ObjectProxy | inline
SetFlowSize(double aWidth, double aHeigt) | ObjectProxy | inline
SetPreviewImage(ObjectProxy aPreviewImage) | ObjectProxy | inline
SetShortId(int aShortId) | ObjectProxy | inline
SetTechnicalName(string aTechnicalName) | ObjectProxy | inline
SetTemplate(ulong aId) | ObjectProxy | inline
SetTemplate(string aTechnicalName) | ObjectProxy | inline
SetText(string aText) | ObjectProxy | inline
this[int aColumnIndex] | ObjectProxy |
this[string aPropertyName] | ObjectProxy |
TypeName | ObjectProxy |
ValidateExpressoScript(string aScriptText) | ObjectProxy | inline
ValidateExpressoScript(string aPropertyName, string aScriptText) | ObjectProxy | inline


articy:draft API: Member List

  • Api
  • ExportToXlsxArgs
ExportToXlsxArgs Member List

This is the complete list of members for ExportToXlsxArgs, including all inherited members.

CollectStatistics | ExportToXlsxArgs |
ExporterName | ExportToXlsxArgs |
ExportMarkup | ExportToXlsxArgs |
ExportQueries | ExportToXlsxArgs |
ExportToXlsxArgs() (defined in ExportToXlsxArgs) | ExportToXlsxArgs | inline
FeatureOrder | ExportToXlsxArgs |
Filename | ExportDataArgs |
GroupedBy | ExportToXlsxArgs |
LogSourceName | ComplexApiCallArgs |
PageSize | ExportToXlsxArgs |
PreselectedObjects | ExportObjectSelectionDataArgs |
SortedBy | ExportToXlsxArgs |
TablePerGroup | ExportToXlsxArgs |
WhichName | ExportToXlsxArgs |


articy:draft API: Member List

  • Api
  • UnclaimPartitionArgs
UnclaimPartitionArgs Member List

This is the complete list of members for UnclaimPartitionArgs, including all inherited members.

CommitMessage | UnclaimPartitionArgs
KeepClaim | UnclaimPartitionArgs
LogSourceName | ComplexApiCallArgs
PartitionGuid | SimplePartitionActionArgs


articy:draft API: Member List

  • Api
  • Transformer
Transformer Member List

This is the complete list of members for Transformer, including all inherited members.

Add(ObjectProxy aObject) | Transformer | inline
AddRange(IEnumerable< ObjectProxy > aObjects) | Transformer | inline
AddResultSet(ResultSet aResultSet) | Transformer | inline
AnchorPosition enum name (defined in Transformer) | Transformer |
BeginTransform() | Transformer | inline
CancelTransform() | Transformer | inline
Clear() | Transformer | inline
Count (defined in Transformer) | Transformer |
EndTransform() | Transformer | inline
FlipHorizontal() | Transformer | inline
FlipVertical() | Transformer | inline
GetHeight() | Transformer | inline
GetPivot() | Transformer | inline
GetPosition() | Transformer | inline
GetRotation() | Transformer | inline
GetWidth() | Transformer | inline
RecenterPivot() | Transformer | inline
Redo() | Transformer | inline
Remove(ObjectProxy aObject) | Transformer | inline
RemoveRange(IEnumerable< ObjectProxy > aObjects) | Transformer | inline
RemoveResultSet(ResultSet aResultSet) | Transformer | inline
SetHeight(double aNewHeight, bool aKeepAspect=false) | Transformer | inline
SetPivot(AnchorPosition aAnchor) | Transformer | inline
SetPivot(Point aPivot) | Transformer | inline
SetPosition(Point aPosition) | Transformer | inline
SetRotation(double aNewAngle) | Transformer | inline
SetSize(Size aNewSize) | Transformer | inline
SetTransformMode(TransformMode aTransformMode) | Transformer | inline
SetWidth(double aNewWidth, bool aKeepAspect=false) | Transformer | inline
TransformMode enum name (defined in Transformer) | Transformer |
Undo() | Transformer | inline


articy:draft API: Member List

  • Api
  • ComplexApiCallArgs
ComplexApiCallArgs Member List

This is the complete list of members for ComplexApiCallArgs, including all inherited members.

LogSourceName ComplexApiCallArgs


articy:draft API: Member List

  • Api
  • ApiConsts
ApiConsts Member List

This is the complete list of members for ApiConsts, including all inherited members.

ApiFacility | ApiConsts |
ErrorCodeMask | ApiConsts |
FacilityMask | ApiConsts |
FacilityShift | ApiConsts |
MakeErrorCode(int aFacility, int aErrorNumber) | ApiConsts | inlinestatic
MsgSrcApi | ApiConsts |
MsgSrcSystem | ApiConsts |
ServerFacility | ApiConsts |


articy:draft API: Member List

  • Api
  • ExportToAccessArgs
ExportToAccessArgs Member List

This is the complete list of members for ExportToAccessArgs, including all inherited members.

CheckedPackages | ExportToAccessArgs |
ExporterName | ExportToAccessArgs |
ExportToAccessArgs() (defined in ExportToAccessArgs) | ExportToAccessArgs | inline
Filename | ExportDataArgs |
LogSourceName | ComplexApiCallArgs |
PackageFileName | ExportToAccessArgs |


articy:draft API: Member List

  • Api
  • ResultSet
ResultSet Member List

This is the complete list of members for ResultSet, including all inherited members.

CalculateColumns() (defined in ResultSet) | ResultSet | inline
Columns | ResultSet |
DumpToCSV(String aFileName) (defined in ResultSet) | ResultSet | inline
GetValue(int aRowIndex, int aColIndex) (defined in ResultSet) | ResultSet | inline
Rows | ResultSet |


articy:draft API: Member List

  • Api
  • ApiJourneyBuilder
ApiJourneyBuilder Member List

This is the complete list of members for ApiJourneyBuilder, including all inherited members.

AvailableActions (defined in ApiJourneyBuilder) | ApiJourneyBuilder |
CurrentJourneyPoint (defined in ApiJourneyBuilder) | ApiJourneyBuilder |
Dispose() (defined in ApiJourneyBuilder) | ApiJourneyBuilder | inline
Journey (defined in ApiJourneyBuilder) | ApiJourneyBuilder |
StoreJourney(ObjectProxy aFolder, string aDisplayName) (defined in ApiJourneyBuilder) | ApiJourneyBuilder | inline
TakeAction(JourneyPointAction aAction) (defined in ApiJourneyBuilder) | ApiJourneyBuilder | inline


articy:draft API: Member List

  • Api
  • ExportXlsxForReimportArgs
ExportXlsxForReimportArgs Member List

This is the complete list of members for ExportXlsxForReimportArgs, including all inherited members.

ExporterName (defined in ExportXlsxForReimportArgs) | ExportXlsxForReimportArgs |
ExportQueries | ExportXlsxForReimportArgs |
ExportXlsxForReimportArgs() (defined in ExportXlsxForReimportArgs) | ExportXlsxForReimportArgs | inline
Filename | ExportDataArgs |
LogSourceName | ComplexApiCallArgs |
SelectedProperties | ExportXlsxForReimportArgs |
SortedBy | ExportXlsxForReimportArgs |
SortObjectsBy enum name | ExportXlsxForReimportArgs |


articy:draft API: Member List

  • Api
  • ApiSession
ApiSession Member List

This is the complete list of members for ApiSession, including all inherited members.

ChangeAsset(ObjectProxy aAsset, string aFullFilename) | ApiSession | inline
ClaimPartition(Guid aPartitionGuid) | ApiSession | inline
ClaimPartition(SimplePartitionActionArgs aArgs) | ApiSession | inline
ClaimPartitions(List< ObjectProxy > aObjects) | ApiSession | inline
ClaimPartitions(List< ObjectProxy > aObjects, string aLogName) | ApiSession | inline
ClaimPartitions(List< ObjectProxy > aObjects, string aLogName, ref List< Guid > aClaimedPartitions, ref Dictionary< Guid, Exception > aFailedPartitions) | ApiSession | inline
CloneChildren(ObjectProxy aObject, ObjectProxy aParent) | ApiSession | inline
CloneObject(ObjectProxy aObject, ObjectProxy aParent) | ApiSession | inline
CloseProject(CloseProjectArgs aArgs) | ApiSession | inline
ConnectPins(ObjectProxy aOutPin, ObjectProxy aInPin) | ApiSession | inline
ConnectToServer(string aHost, int aPort) | ApiSession | inline
CreateCondition(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateCondition(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateCondition(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateCondition(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateDialogue(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateDialogue(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateDialogue(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateDialogue(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateDialogueFragment(ulong aParentId, string aText) | ApiSession | inline
CreateDialogueFragment(ObjectProxy aParent, string aText) | ApiSession | inline
CreateDialogueFragment(ulong aParentId, string aText, string aTemplateTechName) | ApiSession | inline
CreateDialogueFragment(ObjectProxy aParent, string aText, string aTemplateTechName) | ApiSession | inline
CreateDocument(ulong aParentId, String aDisplayName, String aTemplateTechName=null) | ApiSession | inline
CreateDocument(ObjectProxy aParent, String aDisplayName, String aTemplateTechName=null) | ApiSession | inline
CreateDocumentDialogue(ulong aContextElementId, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null) | ApiSession | inline
CreateDocumentDialogue(ObjectProxy aContextElement, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null) | ApiSession | inline
CreateDocumentImage(ulong aContextElementId, HierarchyAdjustment aHierarchy, ulong aImageAsset=0LU, String aText="", String aTemplateTechName=null) | ApiSession | inline
CreateDocumentImage(ObjectProxy aContextElement, HierarchyAdjustment aHierarchy, ObjectProxy aImageAsset=null, String aText="", String aTemplateTechName=null) | ApiSession | inline
CreateDocumentText(ulong aContextElementId, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null) | ApiSession | inline
CreateDocumentText(ObjectProxy aContextElement, HierarchyAdjustment aHierarchy, String aDisplayName="", String aText="", String aTemplateTechName=null) | ApiSession | inline
CreateEntity(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateEntity(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateEntity(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateEntity(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateFlowFragment(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateFlowFragment(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateFlowFragment(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateFlowFragment(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateFolder(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateFolder(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateGlobalVariable(ObjectProxy aParentVariableSet, String aScriptingName, VariableType aType=VariableType.Boolean, String aDescription="") | ApiSession | inline
CreateGlobalVariable(String aParentVariableSetName, String aScriptingName, VariableType aType=VariableType.Boolean, String aDescription="") | ApiSession | inline
CreateGlobalVariable(ObjectProxy aParentVariableSet, String aScriptingName, bool aDefaultValue, String aDescription="") | ApiSession | inline
CreateGlobalVariable(ObjectProxy aParentVariableSet, String aScriptingName, int aDefaultValue, String aDescription="") | ApiSession | inline
CreateGlobalVariable(String aParentVariableSetName, String aScriptingName, bool aDefaultValue, String aDescription="") | ApiSession | inline
CreateGlobalVariable(String aFullQualifiedName, bool aDefaultValue, out ObjectProxy aNamespace, string aVariableDescription="") | ApiSession | inline
CreateGlobalVariable(String aFullQualifiedName, int aDefaultValue, out ObjectProxy aNamespace, string aVariableDescription="") | ApiSession | inline
CreateGlobalVariable(String aFullQualifiedName, bool aDefaultValue, string aVariableDescription="") | ApiSession | inline
CreateGlobalVariable(String aFullQualifiedName, int aDefaultValue, string aVariableDescription="") | ApiSession | inline
CreateGlobalVariable(String aParentVariableSetName, String aScriptingName, int aDefaultValue, String aDescription="") | ApiSession | inline
CreateHub(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateHub(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateHub(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateHub(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateInstruction(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateInstruction(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateInstruction(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateInstruction(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateJump(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateJump(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateJump(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateJump(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateLink(ulong aParentId, Point aPosition) | ApiSession | inline
CreateLink(ObjectProxy aParent, Point aPosition) | ApiSession | inline
CreateLink(ulong aParentId, string aTemplateTechName, Point aPosition) | ApiSession | inline
CreateLink(ObjectProxy aParent, string aTemplateTechName, Point aPosition) | ApiSession | inline
CreateLink(ulong aParentId, string aTemplateTechName, Point aPosition, ObjectProxy aReferencedModel) | ApiSession | inline
CreateLink(ulong aParentId, string aTemplateTechName, Point aPosition, ulong aReferencedModelId) | ApiSession | inline
CreateLink(ObjectProxy aParent, string aTemplateTechName, Point aPosition, ObjectProxy aReferencedModel) | ApiSession | inline
CreateLink(ObjectProxy aParent, string aTemplateTechName, Point aPosition, ulong aReferencedModelId) | ApiSession | inline
CreateLocation(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateLocation(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateLocation(ulong aParentId, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateLocation(ObjectProxy aParent, string aDisplayName, string aTemplateTechName) | ApiSession | inline
CreateLocationGroup(ulong aParentId, string aDisplayName) | ApiSession | inline
CreateLocationImage(ulong aParentId, string aDisplayName, Point aTopLeft, ulong aImageAssetId) | ApiSession | inline
CreateLocationImage(ObjectProxy aParent, string aDisplayName, Point aTopLeft, ObjectProxy aImageAsset) | ApiSession | inline
CreateLocationImage(ulong aParentId, string aDisplayName, Point aTopLeft, ulong aImageAssetId, string aTemplateTechName) | ApiSession | inline
CreateLocationImage(ObjectProxy aParent, string aDisplayName, Point aTopLeft, ObjectProxy aImageAsset, string aTemplateTechName) | ApiSession | inline
CreateLocationLayerFolder(ObjectProxy aParent, string aDisplayName) | ApiSession | inline
CreateLocationText(ulong aParentId, Point aTopLeft, string aText, double aWidth, double aHeight) | ApiSession | inline
CreateLocationText(ObjectProxy aParent, Point aTopLeft, string aText, double aWidth, double aHeight) | ApiSession | inline
CreateLocationText(ulong aParentId, Point aTopLeft, string aText, double aWidth, double aHeight, string aTemplateTechName) | ApiSession | inline
CreateLocationText(ObjectProxy aParent, Point aTopLeft, string aText, double aWidth, double aHeight, string aTemplateTechName) | ApiSession | inline
CreatePath(ulong aParentId, string aDisplayName, params Point[] aVertices) | ApiSession | inline
CreatePath(ObjectProxy aParent, string aDisplayName, params Point[] aVertices) | ApiSession | inline
CreatePath(ulong aParentId, string aDisplayName, string aTemplateTechName, params Point[] aVertices) | ApiSession | inline
CreatePath(ObjectProxy aParent, string aDisplayName, string aTemplateTechName, params Point[] aVertices) | ApiSession | inline
CreateSpot(ulong aParentId, string aDisplayName, Point aPosition) | ApiSession | inline
CreateSpot(ObjectProxy aParent, string aDisplayName, Point aPosition) | ApiSession | inline
CreateSpot(ulong aParentId, string aDisplayName, string aTemplateTechName, Point aPosition) | ApiSession | inline
CreateSpot(ObjectProxy aParent, string aDisplayName, string aTemplateTechName, Point aPosition) | ApiSession | inline
CreateVariableSet(String aScriptingName, String aDescription="") | ApiSession | inline
CreateZoneCircle(ulong aParentId, string aDisplayName, Point aCenter, double aRadius) | ApiSession | inline
CreateZoneCircle(ObjectProxy aParent, string aDisplayName, Point aCenter, double aRadius) | ApiSession | inline
CreateZoneCircle(ulong aParentId, string aDisplayName, string aTemplateTechName, Point aCenter, double aRadius) | ApiSession | inline
CreateZoneCircle(ObjectProxy aParent, string aDisplayName, string aTemplateTechName, Point aCenter, double aRadius) | ApiSession | inline
CreateZonePolygon(ulong aParentId, string aDisplayName, params Point[] aVertices) | ApiSession | inline
CreateZonePolygon(ObjectProxy aParent, string aDisplayName, params Point[] aVertices) | ApiSession | inline
CreateZonePolygon(ulong aParentId, string aDisplayName, string aTemplateTechName, params Point[] aVertices) | ApiSession | inline
CreateZonePolygon(ObjectProxy aParent, string aDisplayName, string aTemplateTechName, params Point[] aVertices) | ApiSession | inline
CreateZoneRect(ulong aParentId, string aDisplayName, Rect aRect) | ApiSession | inline
CreateZoneRect(ObjectProxy aParent, string aDisplayName, Rect aRect) | ApiSession | inline
CreateZoneRect(ulong aParentId, string aDisplayName, string aTemplateTechName, Rect aRect) | ApiSession | inline
CreateZoneRect(ObjectProxy aParent, string aDisplayName, string aTemplateTechName, Rect aRect) | ApiSession | inline
DeleteObject(ObjectProxy aObject) | ApiSession | inline
DiscardChangesToPartition(Guid aPartitionGuid) | ApiSession | inline
DiscardChangesToPartition(SimplePartitionActionArgs aArgs) | ApiSession | inline
DisconnectServer() | ApiSession | inline
Dispose() | ApiSession | inline
ExclusivelyOpen | ApiSession |
ExportData(GenericExportDataArgs aArgs) | ApiSession | inline
ExportData(ExportDataArgs aArgs) | ApiSession | inline
ExportDocument(ObjectProxy aDocument, string aFilename) | ApiSession | inline
ExportDocument(ObjectProxy aDocument, ExportDocumentToDocxArgs aArgs) | ApiSession | inline
ForcefullyUnclaimPartition(Guid aPartitionGuid) | ApiSession | inline
ForcefullyUnclaimPartition(SimplePartitionActionArgs aArgs) | ApiSession | inline
GetExportSettings(ExportDataArgs aArgs) | ApiSession | inline
GetGlobalVariable(string aFullQualifiedName) | ApiSession | inline
GetGlobalVariable(ObjectProxy aParentVariableSet, String aScriptingName) | ApiSession | inline
GetGlobalVariable(string aVariableSetName, string aScriptingName) | ApiSession | inline
GetLocationToolsFor(ObjectProxy aLocationObject) | ApiSession | inline
GetObjectById(ulong aId) | ApiSession | inline
GetObjectByTechName(string aTechnicalName) | ApiSession | inline
GetPartitionInfo(Guid aPartition) | ApiSession | inline
GetPartitionInfos() | ApiSession | inline
GetProjectList() | ApiSession | inline
GetProjectRoot() | ApiSession | inline
GetSystemFolder(SystemFolderNames aFolderName) | ApiSession | inline
GetSystemFolderId(SystemFolderNames aFolderName) | ApiSession | inline
GetUser(Guid aUserGuid, bool aForceRequest=false) | ApiSession | inline
GetUsers(bool aForceRequest=false) | ApiSession | inline
GetVariableSetByName(string aName) | ApiSession | inline
ImportAsset(ulong aParentId, String aDisplayName, string aAssetFullFilename) | ApiSession | inline
ImportAsset(ObjectProxy aParent, String aDisplayName, string aAssetFullFilename) | ApiSession | inline
ImportAsset(ulong aParentId, String aDisplayName, string aAssetFullFilename, string aTemplateTechName) | ApiSession | inline
ImportAsset(ObjectProxy aParent, String aDisplayName, string aAssetFullFilename, string aTemplateTechName) | ApiSession | inline
IsConnected() | ApiSession | inline
IsLoggedIn() | ApiSession | inline
LinearizeFlowSegment(ObjectProxy aStartingElement, FlowToListTraversalType aTraversalType, int aMaxDepth=0, bool aIncludeUnconnected=true) | ApiSession | inline
LoadExportPreset(string aPresetDisplayName, ExporterNames aExporterName) | ApiSession | inline
Login(string aUserName, string aPassword) | ApiSession | inline
Logout() | ApiSession | inline
MoveObject(ObjectProxy aObject, ObjectProxy aNewParent) | ApiSession | inline
MoveObjects(List< ObjectProxy > aObjects, ObjectProxy aNewParent) | ApiSession | inline
OpenProject(OpenProjectArgs aArgs) | ApiSession | inline
ProjectOpen | ApiSession |
PublishProject() | ApiSession | inline
RefactorVariableReferences(ObjectProxy aVariableOrSet, bool aOnlyStrayReferences=true) | ApiSession | inline
ReimportAsset(ObjectProxy aAsset) | ApiSession | inline
Repartition(IList< ObjectProxy > aObjects, RepartitionMode aMode, bool aKeepPartitons=false) | ApiSession | inline
RunQuery(string aQuery) | ApiSession | inline
RunQuery(string aQuery, ObjectProxy aSelfReference) | ApiSession | inline
SaveProject() | ApiSession | inline
SetActionLog(CollaborativeActionBase aAction, ComplexApiCallArgs aArgs) (defined in ApiSession) | ApiSession | inline
SetActionLog(CollaborativeActionBase aAction, string aLogSourceName) (defined in ApiSession) | ApiSession | inline
SimpleFindConflicts(ulong aSearchRoot, SearchConflictsIn aWhereToSearch) | ApiSession | inline
SimpleFindObjects(string aTextToSearch) | ApiSession | inline
SimpleFindObjects(ulong aSearchRoot, string aTextToSearch) | ApiSession | inline
SimpleFindObjects(ulong aSearchRoot, string aTextToSearch, TextFilterRelation aRelation, SearchTextIn aWhereToSearch, bool aCaseSensitive) | ApiSession | inline
StartJourneyOn(ObjectProxy aStartObject) (defined in ApiSession) | ApiSession | inline
UnclaimAllMyPartitions() | ApiSession | inline
UnclaimAllMyPartitions(UnclaimPartitionArgs aArgs) | ApiSession | inline
UnclaimPartition(Guid aPartitionGuid) | ApiSession | inline
UnclaimPartition(UnclaimPartitionArgs aArgs) | ApiSession | inline
UnclaimPartitions(List< Guid > aPartitionGuids) | ApiSession | inline
UnclaimPartitions(List< Guid > aPartitionGuids, UnclaimPartitionArgs aArgs) | ApiSession | inline
UpdatePartition(Guid aPartitionGuid) | ApiSession | inline
UpdatePartition(SimplePartitionActionArgs aArgs) | ApiSession | inline
UpdatePartitions(List< Guid > aPartitionGuids) | ApiSession | inline
UpdatePartitions(List< Guid > aPartitionGuids, string aLogSourceName) | ApiSession | inline
WaitForAssetProcessing(WaitForAssetProcessingArgs aArgs) | ApiSession | inline
WaitForAssetProcessing(WaitForAssetProcessingArgs aArgs, IList< String > aMissingAssetFiles) | ApiSession | inline


articy:draft API: Member List

  • Api
  • ApiCollaborativeHelper
ApiCollaborativeHelper Member List

This is the complete list of members for ApiCollaborativeHelper, including all inherited members.

GetPartitionInfo(Guid aPartition) (defined in ApiCollaborativeHelper) | ApiCollaborativeHelper | inlinestatic
GetPartitionInfo(ProjPartitionModel aPartitionModel) (defined in ApiCollaborativeHelper) | ApiCollaborativeHelper | inlinestatic
SetActionLog(CollaborativeActionBase aAction, string aLogSourceName, LoggingCallback aLoggingCallback) (defined in ApiCollaborativeHelper) | ApiCollaborativeHelper | inlinestatic


articy:draft API: Member List

  • Api
  • WaitForAssetProcessingArgs
WaitForAssetProcessingArgs Member List

This is the complete list of members for WaitForAssetProcessingArgs, including all inherited members.

LogSourceName | ComplexApiCallArgs
WaitForThumbnails | WaitForAssetProcessingArgs


articy:draft API: Member List

  • Api
  • JourneyPointAction
JourneyPointAction Member List

This is the complete list of members for JourneyPointAction, including all inherited members.

Action (defined in JourneyPointAction) | JourneyPointAction
Target (defined in JourneyPointAction) | JourneyPointAction


articy:draft API: Member List

  • Api
  • ExportObjectSelectionDataArgs
ExportObjectSelectionDataArgs Member List

This is the complete list of members for ExportObjectSelectionDataArgs, including all inherited members.

ExporterName | ExportDataArgs
Filename | ExportDataArgs
LogSourceName | ComplexApiCallArgs
PreselectedObjects | ExportObjectSelectionDataArgs


articy:draft API: Member List

  • Api
  • ArticyApi
ArticyApi Member List

This is the complete list of members for ArticyApi, including all inherited members.

CreateSession() | ArticyApi | inlinestatic
CurrentSession | ArticyApi | static
SetLoggingCallback(LoggingCallback aLoggingCallback) | ArticyApi | inlinestatic
Shutdown() | ArticyApi | inlinestatic
Startup(LoggingCallback aLoggingCallback) | ArticyApi | inlinestatic
Startup(LoggingCallback aLoggingCallback, string[] aAdditionalStartupParameters) | ArticyApi | inlinestatic


articy:draft API: Member List

  • Api
  • ObjectPropertyInfo
ObjectPropertyInfo Member List

This is the complete list of members for ObjectPropertyInfo, including all inherited members.

DataSubType | ObjectPropertyInfo |
DataType | ObjectPropertyInfo |
EnumValues | ObjectPropertyInfo |
GetNameOfEnumValue(object aVal) | ObjectPropertyInfo | inline
IsCalculated | ObjectPropertyInfo |
IsCustomProperty | ObjectPropertyInfo |
Name | ObjectPropertyInfo |
ReadOnly | ObjectPropertyInfo |
SupportsExpressoScript | ObjectPropertyInfo |
TryGetEnumValueByName(string aName, out int aIndex) (defined in ObjectPropertyInfo) | ObjectPropertyInfo | inline


articy:draft API: Member List

  • Api
  • ExportToFullXmlArgs
ExportToFullXmlArgs Member List

This is the complete list of members for ExportToFullXmlArgs, including all inherited members.

ExporterName | ExportToFullXmlArgs |
ExportMarkup | ExportToFullXmlArgs |
ExportQueries | ExportToFullXmlArgs |
ExportToFullXmlArgs() (defined in ExportToFullXmlArgs) | ExportToFullXmlArgs | inline
Filename | ExportDataArgs |
LogSourceName | ComplexApiCallArgs |
WriteAllVariables | ExportToFullXmlArgs |
WriteNamespace | ExportToFullXmlArgs |


articy:draft API: Member List

  • Api
  • FlowReference
FlowReference Member List

This is the complete list of members for FlowReference, including all inherited members.

Connection | FlowReference |
ContextTarget | FlowReference |
IsInnerReference | FlowReference |
IsInternalReference | FlowReference |
ReferencedTarget | FlowReference |
ReferenceType | FlowReference |
RefType enum name | FlowReference |
ToString() (defined in FlowReference) | FlowReference | inline


articy:draft API: Member List

  • Api
  • ExportDataArgs
ExportDataArgs Member List

This is the complete list of members for ExportDataArgs, including all inherited members.

ExporterName | ExportDataArgs
Filename | ExportDataArgs
LogSourceName | ComplexApiCallArgs


articy:draft API: Member List

  • Api
  • ApiLocationTools
ApiLocationTools Member List

This is the complete list of members for ApiLocationTools, including all inherited members.

CircleToPolygon(ObjectProxy aZone, int aNumPoints=72) | ApiLocationTools | inline
CircleToRectangle(ObjectProxy aZone) | ApiLocationTools | inline
ClearCropRect(ObjectProxy aLocationImage) | ApiLocationTools | inline
CreateAnchor(ObjectProxy aLocationObject, Point aPosition) | ApiLocationTools | inline
CreateTransformer() | ApiLocationTools | inline
GetImageCropRect(ObjectProxy aLocationImage) | ApiLocationTools | inline
GetLocalBoundingBox(ObjectProxy aLocationObject) | ApiLocationTools | inline
GetLocalVertices(ObjectProxy aLocationObject) | ApiLocationTools | inline
GetLocationBitmap(Size aMaxSize) | ApiLocationTools | inline
GetPosition(ObjectProxy aLocationObject) | ApiLocationTools | inline
GetTransformedBoundingBox(ObjectProxy aLocationObject) | ApiLocationTools | inline
GetTransformedVertices(ObjectProxy aLocationObject) | ApiLocationTools | inline
GetTransformMatrix(ObjectProxy aLocationObject) | ApiLocationTools | inline
Location (defined in ApiLocationTools) | ApiLocationTools |
PolygonToCircle(ObjectProxy aZone) | ApiLocationTools | inline
PolygonToRectangle(ObjectProxy aZone) | ApiLocationTools | inline
RemoveAllAnchors(ObjectProxy aAnchoredObject) | ApiLocationTools | inline
RemoveAnchor(ObjectProxy aAnchor) | ApiLocationTools | inline
ResetAspectHorizontal(ObjectProxy aLocationImage) | ApiLocationTools | inline
ResetAspectVertical(ObjectProxy aLocationImage) | ApiLocationTools | inline
ResetTransformation(ObjectProxy aLocationObject) | ApiLocationTools | inline
SaveLocationAsJpeg(string aFilename, Size aMaxSize, int aJpegQuality=90) | ApiLocationTools | inline
SaveLocationAsPng(string aFilename, Size aMaxSize) | ApiLocationTools | inline
SaveLocationAsXps(string aFilename) | ApiLocationTools | inline
Session (defined in ApiLocationTools) | ApiLocationTools |
SetImage(ObjectProxy aLocationImage, ObjectProxy aImageAsset) | ApiLocationTools | inline
SetImageCropRect(ObjectProxy aLocationImage, Rect aCropRect) | ApiLocationTools | inline
SetPosition(ObjectProxy aLocationObject, Point aNewPosition) | ApiLocationTools | inline
SimplifyPath(ObjectProxy aPath, double aTolerance=-1) | ApiLocationTools | inline


articy:draft API: Member List

  • Api
  • ExportToDocxArgs
ExportToDocxArgs Member List

This is the complete list of members for ExportToDocxArgs, including all inherited members.

ExporterName | ExportToDocxArgs |
ExportMethod | ExportToDocxArgs |
ExportQueries | ExportToDocxArgs |
ExportToDocxArgs() (defined in ExportToDocxArgs) | ExportToDocxArgs | inline
Filename | ExportDataArgs |
GroupedBy | ExportToDocxArgs |
HyperlinkOnReferences | ExportToDocxArgs |
IncludeImages | ExportToDocxArgs |
IncludeTechnicalNames | ExportToDocxArgs |
IncludeTitlePage | ExportToDocxArgs |
InsertTableOfContents | ExportToDocxArgs |
LogSourceName | ComplexApiCallArgs |
PageSize | ExportToDocxArgs |
PreselectedObjects | ExportObjectSelectionDataArgs |
SideBySideImages | ExportToDocxArgs |
SortedBy | ExportToDocxArgs |


articy:draft API: Member List

  • Api
  • FlowListNode
FlowListNode Member List

This is the complete list of members for FlowListNode, including all inherited members.

ApplyNumbering | FlowListNode
IndentionLevel | FlowListNode
JumpTargets | FlowListNode
LocalOrder | FlowListNode
Node | FlowListNode
Parent | FlowListNode
SkipJumps | FlowListNode
UnconnectedThreads | FlowListNode


articy:draft API: Member List

  • Api
  • OpenProjectArgs
OpenProjectArgs Member List

This is the complete list of members for OpenProjectArgs, including all inherited members.

CleanCheckout | OpenProjectArgs
ForceProjectFolder | OpenProjectArgs
LogSourceName | ComplexApiCallArgs
OpenExclusively | OpenProjectArgs
ProjectFolder | OpenProjectArgs
ProjectGuid | OpenProjectArgs
ScmPassword | OpenProjectArgs
ScmUsername | OpenProjectArgs


articy:draft API: Member List

  • Api
  • SimplePartitionActionArgs
SimplePartitionActionArgs Member List

This is the complete list of members for SimplePartitionActionArgs, including all inherited members.

LogSourceName | ComplexApiCallArgs
PartitionGuid | SimplePartitionActionArgs


articy:draft API: Member List

  • Api
  • ObjectPropertyNames
ObjectPropertyNames Member List

This is the complete list of members for ObjectPropertyNames, including all inherited members.

AbsoluteFilePath | ObjectPropertyNames
AssetCategory | ObjectPropertyNames
AssetFilename | ObjectPropertyNames
AssetState | ObjectPropertyNames
Attachments | ObjectPropertyNames
AutoDisplayNamePosition | ObjectPropertyNames
BBCodeText | ObjectPropertyNames
BooleanValue | ObjectPropertyNames
Color | ObjectPropertyNames
Content | ObjectPropertyNames
CreatedBy | ObjectPropertyNames
CreatedOn | ObjectPropertyNames
DataType | ObjectPropertyNames
DefaultValue | ObjectPropertyNames
Description | ObjectPropertyNames
DisplayName | ObjectPropertyNames
DisplayNameColor | ObjectPropertyNames
DisplayNameColorForImage | ObjectPropertyNames
DisplayNameColorForLink | ObjectPropertyNames
DisplayNameColorForPath | ObjectPropertyNames
DisplayNameColorForSpot | ObjectPropertyNames
DisplayNameColorForZone | ObjectPropertyNames
DisplayNamePosX | ObjectPropertyNames
DisplayNamePosY | ObjectPropertyNames
DisplayNameSize | ObjectPropertyNames
DisplayNameSizeForImage | ObjectPropertyNames
DisplayNameSizeForLink | ObjectPropertyNames
DisplayNameSizeForPath | ObjectPropertyNames
DisplayNameSizeForSpot | ObjectPropertyNames
DisplayNameSizeForZone | ObjectPropertyNames
DropShadow | ObjectPropertyNames
DropShadowForImage | ObjectPropertyNames
DropShadowForLink | ObjectPropertyNames
DropShadowForPath | ObjectPropertyNames
DropShadowForSpot | ObjectPropertyNames
DropShadowForText | ObjectPropertyNames
DropShadowForZone | ObjectPropertyNames
EndCap | ObjectPropertyNames
Expression | ObjectPropertyNames
ExternalId | ObjectPropertyNames
FileExtension | ObjectPropertyNames
Filename | ObjectPropertyNames
FilePath | ObjectPropertyNames
FileSize | ObjectPropertyNames
FileType | ObjectPropertyNames
FillColor | ObjectPropertyNames
ForcedHeight | ObjectPropertyNames
ForcedWidth | ObjectPropertyNames
Height | ObjectPropertyNames
Id | ObjectPropertyNames
IdxInJourney | ObjectPropertyNames
ImageAsset | ObjectPropertyNames
ImageOpacity | ObjectPropertyNames
JourneyPoints | ObjectPropertyNames
JourneyPointType | ObjectPropertyNames
JourneyState | ObjectPropertyNames
Label | ObjectPropertyNames
LineWidth | ObjectPropertyNames
LinkStyleSize | ObjectPropertyNames
LinkStyleType | ObjectPropertyNames
MarkupText | ObjectPropertyNames
MenuText | ObjectPropertyNames
Namespaces | ObjectPropertyNames
NumericValue | ObjectPropertyNames
ObjectReference | ObjectPropertyNames
ObjectType | ObjectPropertyNames
OriginalSource | ObjectPropertyNames
OutlineColor | ObjectPropertyNames
OutlineSize | ObjectPropertyNames
OutlineStyle | ObjectPropertyNames
Parent | ObjectPropertyNames
PinIndex | ObjectPropertyNames
PinType | ObjectPropertyNames
PosX | ObjectPropertyNames
PosY | ObjectPropertyNames
PreviewImageAsset | ObjectPropertyNames
ReachedByActionType | ObjectPropertyNames
ScriptingName | ObjectPropertyNames
Selectability | ObjectPropertyNames
ShapeType | ObjectPropertyNames
ShortId | ObjectPropertyNames
ShowCalculatedDisplayName | ObjectPropertyNames
ShowDisplayName | ObjectPropertyNames
ShowDisplayNameForImage | ObjectPropertyNames
ShowDisplayNameForLink | ObjectPropertyNames
ShowDisplayNameForPath | ObjectPropertyNames
ShowDisplayNameForSpot | ObjectPropertyNames
ShowDisplayNameForZone | ObjectPropertyNames
ShowLabel | ObjectPropertyNames
Source | ObjectPropertyNames
SourcePin | ObjectPropertyNames
Speaker | ObjectPropertyNames
SpotStyleSize | ObjectPropertyNames
SpotStyleType | ObjectPropertyNames
StageDirections | ObjectPropertyNames
StartCap | ObjectPropertyNames
Target | ObjectPropertyNames
TargetPin | ObjectPropertyNames
TechnicalName | ObjectPropertyNames
TemplateName | ObjectPropertyNames
Text | ObjectPropertyNames
TransformPivotX | ObjectPropertyNames
TransformPivotY | ObjectPropertyNames
TransformRotation | ObjectPropertyNames
TransformXAxisX | ObjectPropertyNames
TransformXAxisY | ObjectPropertyNames
TransformYAxisX | ObjectPropertyNames
TransformYAxisY | ObjectPropertyNames
Url | ObjectPropertyNames
Variables | ObjectPropertyNames
Visibility | ObjectPropertyNames
Width | ObjectPropertyNames
ZIndex | ObjectPropertyNames